Projet - Contrôle Pompe à vide

Bonjour à vous !

j’ai pris la suite d’un projet déjà assez abouti qui consiste à piloter une pompe à vide en fonction de la pression de consigne.

La personne précédente a déjà réalisé un prototype fonctionnel qui permet à la pompe de tourner entre 2 valeurs de pression. Ce prototype est actuellement composé de:

  • 1 capteur de pression différentielle pour informer de la pression à l’intérieur du circuit pneumatique
  • 1 ampli-op pour augmenter la tension de sortie du capteur
  • 1 carte arduino UNO REV3 avec micro-contrôleur ATmega328P-PU
  • 1 MOFSET
  • 1 une pompe à vide qui se met en route à une valeur seuil jusqu’à la valeur max
  • 1 batterie ou générateur

Mon travail est de me servir de ce qui a déjà été fait est de rendre ce circuit transportable dans une petite boite. Pour cela, le but premier est de réduire l’encombrement du circuit et le cout. L’idée est donc de faire ce circuit, actuellement câblé sur des breadboards, sur circuit imprimé pour passer à quelque chose de “plus industriel” et “moins cher”.

Histoire de pouvoir contrôler l’appareil sans utiliser l’ordinateur, je prévois aussi de rajouter

  • un écran LCD pour afficher la pression
  • un interrupteur entre la batterie et le MC
  • Un bouton on/off pour pour éteindre/allumer la pompe, sortir/entrer dans le mode modif. de la pression
  • 2 boutons pour modifier la pression de consigne

J’ai vu que l’on pouvait n’utiliser que le micro-contrôleur (avec connexion ICSP pour le programmer) afin de diminuer le coût. Est ce que ces 2 composants suffisent pour garantir le fonctionnement du circuit imprimé ?

J’ai donc continué le circuit électronique (en admettant que la réponse à la question était oui) en rajoutant ces composants (voir lien). (J’ai câble ca sur une carte arduino pour simplifier la lecture mais je veux juste utiliser le MC Atmega328P avec la connexion ICSP)

Je voulais vous demander si celui a l’air cohérent. (J’ai essayé de chercher un maximum de réponses à mes questions avant de venir vous voir)
J’ai des doutes sur certains points tel que l’alimentation de la connection ICSP: Est-elle alimenté en 5V par la sonde ou bien directement par le 5V du MC ?
De plus j’ai mis toutes les liaisons à la terre dans l’optique de pouvoir les brancher tous au même point sur le circuit imprimé. Est ce judicieux ?

Voila voila, en espérant avoir été assez clair dans mes explications, je vous remercie de vos futurs conseils.

Edit: Je veux surtout savoir si je pars dans une bonne direction ou pas. En bref, s’il n’y a pas d’erreurs flagrantes qui compromettent la suite ?

Circuit-Control-system.pdf (54.7 KB)

Bonsoir,

Je réponds juste sur le schéma.

1/ montage ampli diff, le choix des résistances n'est pas judicieux, avec certaines condition, le réglage du gain devient simplisme et équilibré.

La tu a un gain extravaguant, je n'ai pas calculé mais ca ne doit pas être ce que l'on recherche je pense.

2/ la sortie 1 de U2.1 est reliée à Q2, je trouve cela étrange, l'alimentation de l'afficheur dépand de la sortie de l'ampli diff?

3/ le GND sur ARDUINO n'est pas relié au GND de la carte électronique, cela pose un problème de référence de tension.

Le reste, les considération sur les alim, beaucoup de choses ont déja été dites à propos des composants alimentés par le modules arduino lui même ... ce n'est pas la meilleure idée je pense.

Merci pour ta réponse ZigZag !

1/ montage ampli diff, le choix des résistances n'est pas judicieux, avec certaines condition, le réglage du gain devient simplisme et équilibré.
Montages de base de l'amplificateur opérationnel — Wikipédia
La tu a un gain extravaguant, je n'ai pas calculé mais ca ne doit pas être ce que l'on recherche je pense.

D'accord, je vais vérifier si c'est cohérent pour ce qu'il nous faut.

2/ la sortie 1 de U2.1 est reliée à Q2, je trouve cela étrange, l'alimentation de l'afficheur dépand de la sortie de l'ampli diff?

Erreur d'inattention :smiley: En fait, le Q2 est censé être relié à l'alimentation du 5V

3/ le GND sur ARDUINO n'est pas relié au GND de la carte électronique, cela pose un problème de référence de tension.

Ok merci ! J'ai rectifié ca.

Le reste, les considération sur les alim, beaucoup de choses ont déja été dites à propos des composants alimentés par le modules arduino lui même ... ce n'est pas la meilleure idée je pense

Je vais voir ce que je peux faire pour améliorer la méthode d'alimentation des composants, merci déjà d'avoir mis en lumière certains points !