Property line '

Hi everybody!

I'm new in Arduino programming

I installed 1.6.8 release in windows and in Linux Ubuntu, but if I try to compile an example project I obtain this message:

Arduino:1.6.8 (Linux), Scheda:"Arduino/Genuino Uno"

Property line '

Why this behaviour ? How can I fix it?

Thank you very much

I am using 1.6.7 in Linux Mint which is based on Ubuntu and don't see that problem.

There have been frequent posts here that the last "good" release of the IDE was 1.6.5

giamby3000:
Property line '

This error indicates there is some bad data in the library.properties file included with one of your libraries. Unfortunately the bad data seems to be be breaking the full output of the error which should tell you which library has the problem. Chances are that it's not one of the official Arduino libraries causing the problem. You can verify this by temporarily changing File > Properties > Sketchbook location: to a different folder, then try to compile. If this solves the problem then you would need to open the library.properties file in each folder under your original {sketchbook folder}/libraries folder. Look for any extra line other than the standard content as shown in the library.properties File Format section of Home · arduino/Arduino Wiki · GitHub

library.properties file format

The library.properties file is a key=value properties list. Every field in this file is UTF-8 encoded. The available fields are:

name - the name of the library
version - version of the library. Version should be semver compliant. 1.2.0 is correct; 1.2 is accepted; r5, 003, 1.1c are invalid
author - name/nickname of the authors and their email addresses (not mandatory) separated by comma ","
maintainer - name and email of the maintainer
sentence - a sentence explaining the purpose of the library
paragraph - a longer description of the library. The value of sentence always will be prepended, so you should start by writing the second sentence here
category - if present, one of these: "Display", "Communication", "Signal Input/Output", "Sensors", "Device Control", "Timing", "Data Storage", "Data Processing", "Other"
url - the URL of the library project, for a person to visit. Can be a github or similar page as well
architectures - a comma separated list of architectures supported by the library. If the library doesn’t contain architecture specific code use “*” to match all architectures

If you can find the issue or narrow it down to a single library let me know and I'll see if I can get the library author to fix the problem and also report the issue that is causing the incomplete error message output to the Arduino IDE developers.

You can also probably solve the problem by using Arduino IDE 1.6.5-r5 or previous because it doesn't do this check on the library.properties content.

Thank you for response; unfortunately even if I change the schetch path, I obtain the same error.
Any idea?

I run blink example project.

giamby3000:
even if I change the schetch path, I obtain the same error.

That indicates that it isn't a library in your sketchbook causing the issue. So next I would recommend reinstalling the IDE in case it is one of the libraries in the Arduino IDE installation folder that is causing the error.

giamby3000:
I run blink example project.

It shouldn't matter which sketch you are trying to compile because this check is done for every compile even if the problematic library is not used in that code.

I tried to re installing the IDE in windows or in linux (Virtual box Virtual machine) but I obtained the same issue.
I tried to use the zip file for windows (portable one) but the behaviour is the same. With other PCs Ihaven't problem, I have problems only with my notebook Win7 Pro 64 bit. Can it cause the issue?

Thanks

Ok, so it looks like the problem is not in the sketchbook or installation folder so there is only one other place to check, the Arduino15 folder where the hardware packages and their bundled libraries are installed. So try the following:

  • Click on the link after File > Preferences > More preferences can be edited directly in the file. That should open the Arduino15(or similar name depending on OS) folder.
  • Close the Arduino IDE
  • Rename the Arduino15 folder to Arduino15.bak
  • Start the Arduino IDE
  • Compile and hope for no error!

Let me know how it goes. Per

Hi Per. I found out the prroblem. Sometimes AArduino crashes on my pc (bluescreen). When I reboot I find that libraries folder is damaged (missing files) so when i try to compile Iobttaain thee error. So I have to ddelete Arduino Folder , open Arduino ide, change ino's ddirectory, reload my prooject with libraries and then all is ok (till thee nex blue screen).

Thank you forr your support

Sorry to hear the IDE is causing problems but I'm glad at least you found the cause of the error message. Thanks for the update!