pyfirmatta wont read digital inputs on a mega 2560 clone

I am designing a project that uses a raspberry pi to control & collect Data from a Mega 2560 clone. (security system) & initially I was going to run the 2560 as a modbus/rtu client but the project was becoming too complex so I changed direction to use standard Firmatta on the arduino & Pyfirmatta on the PI. For the moment I am using a HP netbook running Linux mint for proof of concept as pyfirmatta will need to be compiled for the R-PI.

The issue I have run into is that on the Mega 2560 I am intending to use. (Clone with the CH340G USB chip) I cannot read the value of the digital inputs. They always come back as (None) I wasted almost three evenings on this before trying another board (genuine) that had been junked as the I2c port was fried. & it worked, with all of the code examples I had tried on the old board & failed.

Interestingly the firmatta test program works perfectly on both boards. so its an issue with Pyfirmatta Probably timing.

Has anyone any idea what could be causing the issue.

Have you tried PyMata?