Python bindings for ZeroMQ and Arduino Yún

Hello everyone,

I am currently working with the Yún board and a MPU6050 gyroscope/accelerometer in the context of a project based on the Internet of Things. The Arduino side collects data from the sensor and sends them to the Linux side through the datastore. Then, a Python program collects the data from the datastore and would send them to other machines, behaving as a middleware.

I didn't know a thing about ZMQ sockets before but after reading the beginning of the official guide, I saw they seemed to give a lot of advantages compared to "classic" sockets. So the first thing I tried to have pyzmq on the board is using pip (previously installed thanks to the official documentation) but there seems to be dependencies with libraries and stuff such as libzmq, and it turns out to be rather unclear.

What I tried then is building Openwrt-Yún on a Debian Wheezy virtual machine (VirtualBox), following the instructions at After building, I followed the instructions given at (the address says everything), and I managed to have the zmq headers and libraires in the staging_dir/target-.../usr/{include/, lib/} directories of the built environment. I then rebuilt Openwrt-Yún, thinking that the freshly added files would be taken into account by the image itself (.bin), and upgraded the board with that image through the Web interface.

I saw that the new files weren't on the board, so I directly copied them on the Yún board with scp and put them in the /usr/{include/, lib/} directories. I had pip installed before the upgrade, and ever since, when I try the "opkg update" command to start having it again, there is a "wrong signature file" error, which I can't manage to override.

My big question is this : am I doing it right to have pyzmq ? I really felt like creating this topic since as far as I have searched on the Internet, nobody has ever talked about pyzmq on the Yún. I looked for the right sources to pick and the right steps to follow concerning cross-compilation again and again , always encountering errors, and I definitely can't figure the problem out. Your help would be greatly appreciated.