[Q] Unable to change Port on IDE 1.6.3

Hi, i just updated Arduino IDE to 1.6.3. But i have a problem, i am not able change the com port, it is grayed out. I can change it by editing preferences.txt though.

ide1.6.png

Hi. I'm new to all this. I find it amazing. I also can't change the comm port on the new IDE release.
I'm uninstalling this version and reinstalling the previous version.

After all the uninstall/install I got it working. Using 1.0.6 now. When the bug is fixed I'll upgrade.

Hello,

same Problem here, "Port" is grayed out in 1.6.3 but working fine with older IDEs (1.6.1, 1.0.6,...) on same machine.

Christian

Ports list is generated in background and on some windows machines it can even take some tens of seconds. Can you try waiting for a minute and see if the list gets filled?

waited for half an hour but still no luck

Weird. In the IDE/hardware/tools there's a program called "listComPorts". Can you try executing it from the command prompt? (otherwise the windows will immediately close)
What's the output and how long it takes to print it?

COM1 - (Standard port types) - ACPI\PNP0501\1
COM3 - IVT Corporation - {F12D3CF8-B11D-457E-8641-BE2AF2D6D204}\IVTCOMM\1&27902E60&2&0001
COM4 - IVT Corporation - {F12D3CF8-B11D-457E-8641-BE2AF2D6D204}\IVTCOMM\1&27902E60&2&0002
COM18 - FTDI - FTDIBUS\VID_0403+PID_0000+A9EPHBR7A\0000

It is working fine

I had same problem, running windows 7.1, "PORT" grayed out.
The IDE 1.6.3 trying to compile on COM1, my Arduino uno was configured at install on port COM4.
Shows in device manger OK

This worked for me

I downloaded the FTDI drivers from VCP Drivers - FTDI

installed, all working, including option to select port - Not nice when things dont work out the Box!!!