R3 ethernet shield is holding Mega 2560 in reset state

Hi, I have an R3 ethernet shield plugged into a MEGA 2560 they were both working fine then suddenly as I was uploading a new version of code I was working on the upload froze, after trying various things I found that with the ethernet board plugged in to the MEGA board the reset line is being pulled low. If I de-power the boards but leave them plugged into each other and put a meter between ground and the reset pin I can see it change as I push/release both the reset switches, so what ever is pulling the line low only does it when there is power. I've also checked the reset pin on the MEGA board without the shield and it is high also I can program the MEGA board fine on it's own so the problem appears to be with my R3 shield board. I'm 99.9% certain I didn't do anything to damage the hardware (shorts etc.). The only likely culprit I can see from the circuit diagram is the reset chip IC1 on the R3 shield board. Even weirder is that if I carefully plug the Ethernet shield in so that only the ICSP connector is connected the reset line goes low

Martin.

Update, didn't do anything with it over the weekend, tried it again this morning and it both boards seem to work fine! I noticed that the Ethernet chip gets quite hot (not to hot to touch but not far off!) so I wonder if it's an overheating issue? If so I can't think what suddenly brought it on?

Martin.

I've the same problem!
I have an R3 ethernet shield plugged into a MEGA 2560 R3 and when i tried to upload a sketch to it, i get a timeout message, but when i tried to upload the same sketch to the Mega 2560 without the shield it works!
What is wrong?

I've found this: http://mcukits.com/2009/04/06/arduino-ethernet-shield-mega-hack/ but i dont know if i have to do this.

I Use Windows XP, USB cable, the port COM is correctly detected. The board is correctly selected in the IDE.

Check your USB cable, some cables not delivered 5 volts and cause the Mega to reset and failed upload with timeout!
To check rapidly, see if the LED on in shield ethernet shines little.

Unplug and plug the usb, then upload again, if it is freeze, push reset button, hope it can be uploaded (rx tx blink)

http://mcukits.com/2009/04/06/arduino-ethernet-shield-mega-hack/
in above website, it is not relevant with new type of arduino and IDE,
so probably, you could follow this for the wiring: http://arduino.cc/forum/index.php/topic,113102.0.html
or learn something from this post: UNO R3 + Eth Shield + SD Card = Problem after uploading [SOLVED!!] - #7 by system - Installation & Troubleshooting - Arduino Forum

Hope helping you :grin: