R305 Finger Print

Iam trying Enroll sketch in Adafruit finger print library and i get error number is 0X80 HEX When Execute Command (CreateModel). this Error number (0x80 HEX) could not find it in R305 DataSheet.
Any Help.....

What, EXACTLY, does the output say when you try to enroll a finger? You can copy and paste text from Serial Monitor.

I have not yet found where the Adafruit library would display more than "Unknown error".

This is a part from the code when error happen
p = finger.createModel();
if (p == FINGERPRINT_OK) {
Serial.println(“Prints matched!”);
} else if (p == FINGERPRINT_PACKETRECIEVEERR) {
Serial.println(“Communication error”);

return p;
} else if (p == FINGERPRINT_ENROLLMISMATCH) {
Serial.println(“Fingerprints did not match”);
return p;
} else {
Serial.println(“Unknown error”);
Serial.println(p,DEC);
return p;
}

this serial monitor:

fingertest
Found fingerprint sensor!

Type in the ID # you want to save this finger as…
Enrolling ID #1
Waiting for valid finger to enroll
.
.
Image taken
Image converted
Remove finger
Place same finger again
…Image taken
Image converted
Unknown error
128

Here When execute p = finger.createModel();
i write Serial.println(p,DEC);
Then iget This Error Value (128)…

That doesn't seem to match the latest Adafruit fingerprint sensor library. I don't know if using the latest library would help but it's probably a good idea:

i found the problem...
i am using latest version arduino IDE then i deleted it and installed old version IDE 1.0.6 then the sensor worked properly without problems...

Yes sir, even i am using arduino ide 1.6.13, but in serial monitor it shows unknown error, so what should i do now? Some people suggested that it does not give error in older versions of ide, so i used 1.6.6 but it still gave me same error >:(

What is 1:1 method, in adafruit fingerprint library they have used 1:N searching method. Can anyone tell me how to use 1:1 method.