Radio.available true even if NRF24 disconnected

That's what I'm trying to figure thnaks to you all !

The libraries work, the Arduinos too. I'm not saying anyone other than me did his job wrong. But I sincerely do not understand what doesn't work (and have in parallel the same kind of issues with my Python code, maybe I'm just cursed). I ordered a new bunch of NRFs, hope this ones will work well enough.

It would just bother me if it was that, because I would be losing a lot of time for stuff I can't do anythin about, that's why I'm trying to find my mistakes as soon as possible.
Sorry if I look nervous :confused:

So your NRF24 setup does not work with MicroPython either ?

I have not tried to use Python on the NRF yet. I just found a pre-made sketch to turn on a diode through PyFirmata (on the Uno, that's why I know it works). My goal is to send a message, coded with a Python program, wirelessly. So, once I finally manage to make this chips work, I'll adapt a bit the code to make it fit in Python.

Those 'ciphering' algorithms also encounter issues (which do not relate to our current problem), and it's been a week I'm also trying to solve those little bugs without success. I guess that's what engineers do :laughing:

Yes.

Also yes (I do not plug the IRQ, saw several places where they said it wasn't required and therefore I don't know where to plug it in)

Hi everyone !

A little update : I received the alientation modules and a new dozen of NRF24 chips yesterday. Just tried the "checking code" srnet posted and I finally gets this :


Reg    0  1  2  3  4  5  6  7  8  9  A  B  C  D  E  F
0x00  08 3F 1C 03 38 38 1C 0E 70 70 70 70 38 38 1C C6 
0x10  E7 00 1C 00 38 38 1C 11 70 70 

Print registers 0x00 to 0x19
Printing 26 registers

Reg    0  1  2  3  4  5  6  7  8  9  A  B  C  D  E  F
0x00  08 3F 03 03 03 02 0F 0E 00 00 E7 C2 C3 C4 C5 C6 
0x10  E7 00 00 00 00 00 00 11 00 00 

I conclude that it finally works ! Thank you so much for you support and help, I can now get into hacking the NSA ! (or at least getting my degree).

EDIT : Weirdly, the NRF24 chip doesn't work with the Uno if I use the 3.3V pin, but works with the 5V pin (through the convertor chip). The 3.3V pin lights on a LED however, but doesn't feed the NRF24. Anyway, it's working !!

Wish the best to all of you.
Archer

It would be a very good idea to give the forum and indication of what the problem with your not working NRF24 modules actually was.

It would be, I admit, a good thing if I knew where the problem was. As I said, just plugged in new NRF24 modules and it's working now. Check the edit on my previous post, I found one source of problems, but it certainly doesn't explain everything.