Random issues with Arduino

It has been working fine for the past 2 weeks, but suddenly today it stopped working and gave me the "programmer is not responding" error. I've looked all over the internet for solutions, basically tried everything, and still doesn't work. I'm on a 10.04 Ubuntu Linux running on a Vostro V13 Notebook. The board that I'm using is the Arduino Pro with ATmega168. Gcc-avr -- check avrdude -- check libusb -- check arduino 18 -- check rewired everything -- check restarted computer -- check restarted arduino -- check resintalled everything -- check hit reset after the "binary sketch size" comes up -- check

Might have to do with this: http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1279568600/0#1

But I have no idea why it would randomly not work, I have not touched it since last Thursday (4 days ago).

This is the error that I get:

Binary sketch size: 5722 bytes (of a 14336 byte maximum)
/home/jeff/Desktop/arduino-18/hardware/tools/avrdude -C/home/jeff/Desktop/arduino-18/hardware/tools/avrdude.conf -v -v -v -v -patmega168 -cstk500v1 -P/dev/ttyUSB0 -b19200 -D -Uflash:w:/tmp/build9203353306334377290.tmp/completesketch3.cpp.hex:i 


avrdude: Version 5.4-arduino, compiled on Oct 22 2007 at 13:15:12
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         System wide configuration file is "/home/jeff/Desktop/arduino-18/hardware/tools/avrdude.conf"
         User configuration file is "/home/jeff/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port            : /dev/ttyUSB0
         Using Programmer      : stk500v1
         Overriding Baud Rate  : 19200
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: Send: 0 [30]   [20] 
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding
avrdude: Send: Q [51]   [20] 
avrdude: ser_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

And this is my sketch: (THIS HAS WORKED BEFORE)

int sensorPin = 0;       
int sensorValue = 0;  
float realVolt = 0;
float resist = 0;
float lightInt = 0;
int bluetooth = 0;
unsigned long previous_millis_value = 0;
unsigned long cumulativeSeconds = 0;
unsigned int seconds = 0;
unsigned int minutes = 0;
unsigned int hours = 0;
void setup() {
  Serial.begin(9600);
  pinMode(bluetooth, OUTPUT);
  Serial.println("Test: ");
}

void loop() {
  while( millis() - previous_millis_value >= 1000){
    cumulativeSeconds++;
    previous_millis_value += 1000;
  }
  seconds = cumulativeSeconds % 60;
  minutes = (cumulativeSeconds / 60) % 60;
  hours = cumulativeSeconds / 3600;
  sensorValue = analogRead(sensorPin);    
  realVolt = 5-(sensorValue/204.8);
  //realVolt = 2*(2.5-(sensorValue/409.6));
  resist = (110/realVolt) - 22;
  lightInt = (pow(10,((resist-15)/-6.95)));
  ;  
    if(Serial.available() > 0){
        char inChar = Serial.read();
      if(inChar == 'V')
         Serial.println("Remote Sensor Data Collector Version 2");
        if(inChar == 'v')
           Serial.println("RSDC v3");
        if(inChar == 'd'){
           Serial.print(lightInt, DEC);
           Serial.println (" lux");
        }
        if(inChar == 'T'){
           Serial.print(hours, DEC);
           Serial.print("h");
           Serial.print(minutes, DEC);
           Serial.print("m");
           Serial.print(seconds, DEC);
           Serial.println("s");
        }
        if(inChar == 't'){
           Serial.print(hours, DEC);
           Serial.print(":");
           Serial.print(minutes, DEC);
           Serial.print(":");
           Serial.println(seconds, DEC);   
        }
  delay (2500);
    }
}

HELP PLEASE

I would disconnect the arduino from any circuit it's connected to and load blink. If this won't work, you have a dead chip on the arduino board. Otherwise, check your circuit. Good luck. BTW, upload a few pictures if you can for your circuit.

The problem is I can't upload anything... Like i said, I unplugged, rewired EVERYTHING. Even the BlueSmirf connected to it. Here's a picture of my board (btw, the red ON LED turns on, the green one, however, doesn't)

Another thing, though. The above picture was taken a week ago, and back then, it still worked even though the pin 13 LED was not flashing.