Raspberry Pi als Entwicklungsrechner für Arduino

Hallo zusammen, ich habe mich heute neu als Mitglied im Arduino-Forum angemeldet und freue mich auf regen Gedankenaustausch mit Gleich-Interessierten ("Gleichgesinnten" klingt so bisschen nach Porno-Plattform - deshalb vermeide ich den Begriff hier).

Als Neu-Rentner kann ich mich nun endlich wieder meinem Hobby (Elektronik - ich hab noch weitere, aber die spielen hier keine Rolle) zuwenden, nach 30 Jahren Pause. Offenbar hat sich die Welt ja nach Apple ][ und 6502-SBC weiterentwickelt.

Also: Als erstes habe ich mir einen RaspberryPi B zugelegt, und jetzt vor kurzem einen Arduino MICRO und einen UNO (nebst einigem Zubehör). Da ich mich mit Linux schon seit "geraumerer" Zeit beschäftige, kam sofort die Idee, den Raspi als Entwicklungsrechner für den Arduino einzusetzen. Also die Arduino IDE auf 1. meinen Windows-(7)-PC (Version 1.6.7) und 2. den Raspi (Version 1.0.1) installiert. Hat alles geklappt und tut einwandfrei - auf dem UNO! Aber leider nicht auf dem MICRO. Daher:

PROBLEM:

In der Menü-Auswahl TOOLS > BOARDS bietet die - Version 1.6.7 den UNO und den MICRO an, aber die - Version 1.0.1 nur den UNO, nicht aber den MICRO ! Daher meine

FRAGE:

  • Wie kann ich der 1.0.1 auch den MICRO "unterjubeln" (Parameterfile?), oder
  • gibt's eine unter Raspbian Wheezy installierbare Version der IDE, die den MICRO kennt?

ANMERKUNG:

Auf dem Raspi gibt es eine Datei boards.txt unter /usr/share/hardware/arduino, in der es neben Einträgen zu anderen Arduino-Boards auch einen zum UNO gibt (Parameter uno.name=...). Auf dem Win7-PC gibt es eine gleiche Datei, die ebenso einen solchen Eintrag, darüber hinaus aber auch eine mit dem Parameter micro.name=... trägt. Der Versuch, letzteren Eintrag auch in die boards.txt des Raspi zu übertragen, blieb aber leider wirkungslos.

Ich bin für jede Antwort dankbar. Gruss an alle! Manfred

PS: Falls mein Eingangs-Geschwafel off-topic war (weil schlicht zuviel): Lasst es mich wissen, aber haut mich nicht - ich gelobe Besserung.

Die IDE-Version 1.0.x kennt den MICRO wie auch den Leonardo noch nicht weil es ihn damals noch nicht gab. Was spricht gegen die IDE-Versioen 1.6.9? Grüße Uwe

guckst du hier https://www.dropbox.com/s/m4pp9stjhsrc0nf/arduino-1.6.5-arm_wheezy.tar.xz?dl=0

hier auch n topic dazu https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=92662&start=75#p779301

könnte weiter helfen

uwefed: Die IDE-Version 1.0.x kennt den MICRO wie auch den Leonardo noch nicht weil es ihn damals noch nicht gab. Was spricht gegen die IDE-Versioen 1.6.9? Grüße Uwe

Absolut nix, nur scheint die Version für Linux (oder jedenfalls RaspberryWheezy noch) nicht verfügbar zu sein ... Trotzdem: Danke!

Hallo Manfred, auch die neuen 1.6.x IDE gibt es für Linux nur nicht über die apt-get routine du musst dir die .tar Dateiein runtergeladen und über die install.sh auf deinem System komplieren bzw installieren. Mit dem B bzw B+ wirst du nicht viel Freude haben als IDE besser den Pi 3 der ist auch mit der GUI gut nutzttbar bei dem B hast du sehr viel "Verzögerung" das es keinen Spaß macht. Ich habe einen keines 6 Jahre altes "Netbook" mit dem LUBUNTU drauf damit ist es Spaß zu programmieren. Der kompiliert sogar schneller als mein i5 mit 6Gb und Windows 7. Gruß DerDani Raspbian Wheezy ist ja auf Basis von debian also sollte man es installieren können.

Hi,

ich bin auch seit kurzer Zeit dabei, den Raspi als Programmierer für meine Arduinos zu nutzern. Da ich oft unterwegs bin und nicht immer Arduino, Breadboard usw. mitnehmen möchte, habe ich alles zuhause an einen RPi gehängt. Einen VPN Tunnel konfiguriert und nun kann ich von überall programmieren.

Da ich es möglichst schnell haben wollte, habe ich mich nach einer Möglichkeit umgesehen, die GUI zu umgehen und habe hier von PlatformIo gelesen. Installiert, getestet, läuft super. Also wem die GUI zu langsam ist, und wer sich nicht scheut ein paar Befehle in eine Konsole zu tippen, sollte sich das Tool mal anschauen. Auch das Hinzufügen von Libs ist mit dem Libmanager sehr einfach gemacht.

VG, Lars

Erst mal Danke an alle, die geantwortet haben! Werde es mal mit einer Eigeninstallation der 1.6.x aus dem tar-ball versuchen. Dann ggf. einen Raspi 3 kaufen, wanns auf meinem gar zu langsam geht. Stehe leider privat z.Zt. etwas unter Stress (meine Frau ist im Krankenhaus), daher kann's u.U. etwas dauern, bis ich (hoffentlich) Erfolg vermelden kann.

Trotzdem hab ich da noch eine dämliche (?) Frage, aber die poste ich in einem neuen Thread. Bis denne! Manfred

manfred474: Trotzdem hab ich da noch eine dämliche (?) Frage, aber die poste ich in einem neuen Thread. Bis denne! Manfred

Auf http://forum.arduino.cc/index.php?board=31.0 oben rechst steht "New Topic" Grüße Uwe