re-appearing libraries

I'm trying to remove a library and it keeps coming back. I tried installing "TFT_Touch_Shield_V2-master" and had problems getting the display to work. (I kept getting the dreaded /357 error) I thought I'd try deleting the library and re-installing it manually so I deleted the directory in the 'Arduino\libraries' folder. Before I could download the files again, the directory was re-created. Opening it up showed a 'libraries' folder containing a 'TFT_Touch_Shield_V2-master' folder containing a 'libraries' folder etc... for 8 layers. I tried deleting it again and it came back before I could navigate away from the Arduino libraries folder. The IDE was not active. I tried restarting the system then deleting the folder with the same results.

Any thoughts on how to stop the madness?

It should be in the sketchbook/libraries folder for a start.

A program that isn't running is hardly going to create directories, so you need to look further.

What operating system are you using? What IDE version?

I wonder if you could describe the 357 error. Any error I've ever seen in the arduino IDE gives a textual description of the nature of the problem. That's the bit that I read so the error number means nothing to me.