Re: Dreaded Serial Monitor -- Xubuntu 13.04 [SOLVED]

Hi,

I seem to be experiencing the somewhat common issue where my serial monitor won't work. Prior to uploading a sketch, the Serial Port is listed as /dev/ttyACM0 and checked. Once I upload and open the serial monitor, there is not output showing and the Serial Port menu option greys out. I've read through several of the posts about the Cannot find /dev/ttyACM0 issue, and I walked through some of the remediation steps. None of them seems to fix my issue.

Ran groups and determined I was a member of the dialout group, but not tty group. I added myself. Still not working.

Next, I verified that my /.arduino/Preferences.txt file listed the default serial.debug baud rate at 14400. I set it to 9600 and changed file permission to read only. Still no fix.

I tried changing the permission on the ttyACM0 port to rw. When I sudo chmod 777 /dev/ttyACM0, I get the output that no file exists. Indeed, if I browse to ./dev, I don't see this port listed

EDIT - I didn't realize that my arduino wasn't plugged in when I searched for /dev/ttyACM0. I subsequently ran: ls -l /dev/ttyACM?, which returned

crw-rw---- 1 root dialout 166, 0 Dec  2 22:22 /dev/ttyACM0

Honestly, never had to use the serial monitor on my netbook (I moved all my Arduino projects over to this for portability --- it's a homebrewing project), so I didn't know this was an issue. I needed to debug some stuff, so I really need it now! Help!

After plugging in Arduino, I was able to:

sudo chmod 777 /dev/ttyACM0

Yay. If anything, hopefully somebody finds my thought and work process helpful, as it seems like many Linux users have come across this issue.