Really weird LCD bug!!!

I'm getting my 11 y/o son into Arduino. I have an LCD shield and uploaded the "Hello World" sketch. Everything worked fine. I then asked him to make it display something else. He changed "Hello World" to "GET LOST!!!" (you know how boys are) The strange thing is, it would not upload. I spent the next 3 hours changing COM ports, baud rates, drivers, WIN7 permissions, stood on one foot, moved the house 3 feet to the left, nothing worked! It would not upload.

In desperation, I went back to basics and uploaded the Blink sketch - uploaded fine. I then uploaded the Fade sketch - no problems. Uploaded Hello World again - working fine now, (pulling hair out). I then changed "Hello World" to "GET LOST!!!" - would not upload! Started to think that maybe the ! was an illegal character, so changed text to "GET LOST" - uploaded fine, AH-HA! Changed text to "GET LOST!" - uploaded fine, changed to "GET LOST!!" - no problems. Changed to "GET LOST!!!" - will not upload!

So it would appear that you cannot have 3 or more exclamation marks in a row. Something screwy with the LCD library perhaps or am I missing something?

Anyone else care to give it a go and try to figure out what's causing the problem?

Which Arduino do you have? I believe three exclamation marks launches some internal process on Mega2560s.

Care to give some error messages and details?

@ dxw00d - You might be onto something, I'm using a MEGA 2560. There's no error codes given, the IDE just says it's uploading, but never completes. I have to unplug the Arduino to regain control.

@ dxw00d - You've hit it on the head. Doing a Google search for "Arduino !!!" turns up these threads...,49591.0.html,46966.0.html

and for the explanation -

I thought I would be the only silly one to come unstuck by this, but it seems to have trapped a few.

Thanks all for you help - beware the evil !!!

You aren't the first and won't be the last- I spent three hours wondering about this before I found out about the exclamation mark thing, and worse, it was my first go with a Mega. I didn't know I could swear so many times per minute! :grin: