RECENTLY getting ptoblems such as "Arduino IDE won't start"

I am working with both the attiny and esp8266 chips. The idea is that with 1.6.4 I can add their boards manager package URL's in the preferences, open up the boards manager and simultaneously install whichever platforms I care to work with.

The reality is that both urls work separately but when I include them both and open up the manager I get a Java.lang.nullpointerException and can install neither. Furthermore if I close the IDE it fails to restart and I have to fix preferences.txt and clean up packages manually.

I have read the forums which suggest that you have to re-select your board. I tried this several times in various ways with no luck.

Tia, Michael

Relevant line from preferences.txt:

boardsmanager.additional.urls=http://arduino.esp8266.com/package_esp8266com_index.json,https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-manager/package_damellis_attiny_index.json

Strange line that does not seem to harm anything from preferences.txt: browser=mozilla,http://arduino.esp8266.com/package_esp8266com_index.json

Full error follows:

java.lang.NullPointerException java.lang.RuntimeException: java.lang.NullPointerException at cc.arduino.contributions.packages.ui.ContributionManagerUI$3.run(ContributionManagerUI.java:155) at java.lang.Thread.run(Thread.java:745) Caused by: java.lang.NullPointerException at cc.arduino.contributions.packages.ContributedToolReference.resolve(ContributedToolReference.java:43) at cc.arduino.contributions.packages.ContributedPlatform.resolveToolsDependencies(ContributedPlatform.java:76) at cc.arduino.contributions.packages.ContributionsIndexer.parseIndex(ContributionsIndexer.java:92) at processing.app.BaseNoGui.initPackages(BaseNoGui.java:600) at processing.app.Base$10.onIndexesUpdated(Base.java:1279) at cc.arduino.contributions.packages.ui.ContributionManagerUI$3.run(ContributionManagerUI.java:153) ... 1 more

I also have the same issue. I am managing application packages with brew (arduino from brew-cask). Not sure if related, but worth noting environment.

Same problem here; here’s the error I get by running arduino-debug:

Loading configuration...
Initializing packages...
java.lang.NullPointerException
        at cc.arduino.contributions.packages.ContributedToolReference.resolve(ContributedToolReference.java:43)
        at cc.arduino.contributions.packages.ContributedPlatform.resolveToolsDependencies(ContributedPlatform.java:76)
        at cc.arduino.contributions.packages.ContributionsIndexer.parseIndex(ContributionsIndexer.java:92)
        at processing.app.BaseNoGui.initPackages(BaseNoGui.java:600)
        at processing.app.Base.<init>(Base.java:271)
        at processing.app.Base.guardedMain(Base.java:215)
        at processing.app.Base.main(Base.java:128)

That’s strange. Could the problem be linked to the comma that separates the two json files?
The two json files are written in the config like this: https://raw.githubusercontent.com/damellis/attiny/ide-1.6.x-boards-manager/package_damellis_attiny_index.json,http://arduino.esp8266.com/package_esp8266com_index.json

I have altered the attiny Boards Manager json index file to solve this issue. ESP8266 and attiny should now be able to be added simultaneously to your Additional Boards Manager URLs. Also, the problem with the Arduino IDE that was causing it not to load with the previous attiny json index file has been fixed and is available in the hourly build. Sorry for any inconvenience this has caused you. Per

I would recommend installing the new boards manually, the normal way, instead of using the very buggy board manager.

The only Boards Manager bugs I've seen are caused by improperly formatted 3rd party files and the IDE's assumption that those files will be properly formatted despite a lack of documentation. Now Arduino has added failure handling and documentation.

It took me a while to see the benefit of using Boards Manager but it is really nice to be able to check for updates to all my installed boards with a single click. I also think it makes installation easier for beginners which is what Arduino is all about.

The boards manager is working great now, as with any new feature, it will have bugs. Having a package manager is definitely a step in the right direction.

Just want to ask how the hotfixes get applied onto the board manager? Does the app call a REST service and receive a list of available packages based on the JSON parameter you send over?

Every time you open Boards Manager it downloads the Arduino JSON index file and any 3rd party URLs added to Preferences. If the JSON file contains a newer version than the currently installed version it will show an Update button on that Boards Manager entry when you click on it.

Hello guys, I know there has existed a lot of posts regarding this issue, but I haven’t been able to launch any newer Arduino IDE’s for almost a year now. Tho I have searched and read for many hours on several forums on this problem, I haven’t found my solution yet.

To make it easier for you guys to help me, I will now explain exactly what I experience, and what I already have tried.

I’m able to run the classic Arduino 1.0.x, but from 1.5 and newer, I haven’t found a version that would open. Since first time I experienced this, I have updated my OS two times, Java several times, and of cause tried all the newer versions of the Arduino IDE, but without luck. Right now I use the following updates:

OS: macOS Sierra V. 10.12
Arduino IDE : 1.6.12
JAVA: V. 8 update 111 (build 1.8.0_111-b14)

I have tried to reinstall Arduino several times, and the first time I try to launch the IDE after I have made a reinstall, it gives me the following message: (See Attachments)

If I try again the the startup window appears for some seconds, but then i disappears again. I tried to check the console when the problem appears and it gave me the following:

System.log:
Oct 20 13:49:12 netigoss Console[2788]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked
Oct 20 13:49:16 netigoss com.apple.xpc.launchd[1] (cc.arduino.Arduino.1948[2790]): Service exited with abnormal code: 255
Oct 20 13:49:40 netigoss com.apple.xpc.launchd[1] (cc.arduino.Arduino.1948[2799]): Service exited with abnormal code: 255
Oct 20 13:51:28 netigoss Dock[837]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] add: “No such file or directory” - 0x2
Oct 20 13:51:31 netigoss com.apple.xpc.launchd[1] (cc.arduino.Arduino.1948[2811]): Service exited with abnormal code: 255

I hope you guys can help me out, and pls ask for it if you need more information.

When i try to run the IDE through the terminal with the following code:
/Applications/Arduino.app/Contents/MacOS/Arduino

It opened the startup window and crashed again. But it left the following log in the terminal:

java.lang.NumberFormatException: For input string: “null”
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
at java.lang.Integer.parseInt(Integer.java:580)
at java.lang.Integer.parseInt(Integer.java:615)
at processing.app.PreferencesData.getInteger(PreferencesData.java:191)
at processing.app.Base.defaultEditorLocation(Base.java:627)
at processing.app.Base.nextEditorLocation(Base.java:639)
at processing.app.Base.handleOpen(Base.java:808)
at processing.app.Base.handleNew(Base.java:747)
at processing.app.Base.(Base.java:458)
at processing.app.Base.guardedMain(Base.java:218)
at processing.app.Base.main(Base.java:131)

Looks like it is having problems with your preferences.txt file which is in ~/Library/Arduino15 It's such a notable source of IDE problems that I have a boilerplate reply:

A bunch of people have had IDE 1.6.x problems, including IDE crashes and bizarre compile errors, when they had a previous 1.5.x/1.6.x installation. At least some of those problems seem to be caused by out-of-date executables and preference files that the IDE saves outside the IDE installation directory. Perhaps that is what is causing your particular problem. In such cases it appears that the fix is to delete or rename the old "Arduino15" directory and re-install 1.6.x.

On Mac OS X: /Users/(username)/Library/Arduino15 (a.k.a. ~/Library/Arduino15) (Note: The 'Library' folder is greyed out in Finder. The contents are not included in a Spotlight or Finder search. The folder can't be opened with a double-click. To browse the contents of 'Library', ctrl-click on it and select "Open in New Tab" from the pop-up menu.)

On Windows delete or rename both: Arduino IDE 1.6.5r5 and previous: C:\Users(username)\AppData\Roaming\Arduino15 Arduino IDE 1.6.6 and later: C:\Users(username)\AppData\Local\Arduino15

On Linux: /home/(username)/.arduino15 (a.k.a. ~/.arduino15) (Note: file/folder names starting with '.' are not normally shown in directory listings. Use 'ls -a' to get a directory listing that includes the hidden files.)

Hello,

When I open the Arduino IDE the window doesn't pop up. In the taskbar the icon does appear and if I hover over it, it gives the preview of the window. But whatever I try, the window will not appear. It worked fine a couple of days ago.

I have tried accesing the window with alt+tab, restarting my computer and reinstalling the sotware entirely, with no succes.

Thanks in advance, Ben

(deleted)

Yes, I do have a second monitor, but it doesn't appear anywhere.

Bringing to the front using the Task Manager didn't work.

With reinstalling it I chose the most resent one, 1.8.1.

A few recent posts about win 10 and 1.8.0 / 1.8.1 with permissions errors around in the forum. Maybe worth a quick run through those.

A few more questions though if you dont mind.

  1. Are you a regular "User" as far as permissions go on that computer or are you Administrator ?
  2. IF you are Administrator are you sudo (user with admin rights) or FULL ?
  3. Is this your own personal computer or a company / educational one ?
  4. When installing are you selecting your own destination folder or allowing the IDE to choose its own ?
  5. During install are you selecting YES to allow it access to the things it needs ?

Add any additional information you think might be relevant eg. network type etc etc.

Just trying to piece things together and see if there is a common issue or a larger one.

I am an Administarator. I have full admin rights. It is my own PC. I did install it on my second drive (D:\Arduino) I did allow everything during the install.

I do suspect it has nothing to do with the version. I just tried 1.6.13 and got the same result.

I don't realy know what would have caused this, it worked fine this morning and I didn't realy do anything beside being on the internet today.

(deleted)

That fixed it!

Thank you.

Hi! I have a same problem! Arduino IDE is not working. I cut the "Arduino15" directory but still have problem: Arduino IDE is not running! (Windows 10 / x64)

I try running the "arduino_debug.exe" also and see the error message: "Program 'Java(TM) Platform SE binary' is not working"... May be it's a major problem?

Hot to fix it?