Recepteur 433mhz ou code qui ne marche pas

J'ai récemment acheté un recepteur 433 Mhz chez GoTronic http://www.gotronic.fr/art-kit-emetteur-recepteur-433mhz-18881.htm J'ai branché comme cela : GND = GND 5v =5v OUT = Pin digital 2 Puis j ai envoyer l'exemple "ReceiveDemo Simple" de la librairie "RCSwitch " J'ouvre le moniteur serie à 9600 bauds et j'appuie sur le bouton d'une télécommande 433,92 Mhz Et là rien aucun message (la telecommande marche :grin: car elle allume un module Velleman recepteur) :astonished:

Merci de vos réponces

Yann442:
J’ai récemment acheté un recepteur 433 Mhz chez GoTronic
http://www.gotronic.fr/art-kit-emetteur-recepteur-433mhz-18881.htm
J’ai branché comme cela :
GND = GND
5v =5v
OUT = Pin digital 2
Puis j ai envoyer l’exemple “ReceiveDemo Simple” de la librairie "RCSwitch "
J’ouvre le moniteur serie à 9600 bauds et j’appuie sur le bouton d’une télécommande 433,92 Mhz
Et là rien aucun message (la telecommande marche :grin: car elle allume un module Velleman recepteur)
:astonished:

Merci de vos réponces

bonsoir
voir déjà des cotés :
SOFT : la lib rcswitch ne reconnais que quelques “protocoles” simples (je ne sais pas si ta telco en fait partie)
HARD : il faut aussi sur ce genre de module mettre une antenne “un peu adaptée” (pastille angle en bas à gauche , recepteur vu face compo)

tu peux faire une levée de doute en utilisant un test de tempo avec ce petit prog sans modif de ton cablage (prevu pour UNO et INT0 = pin2)
en appuyant sur les “boutons ta telco” ; tu devrais voir de l’activité sur le serial ( > et tempo etats)

enum PinAssignments {
  encoderPinA = 2,

};

unsigned long Tparc=0; //  temps de parcours du secteur
unsigned long Tact=0; // Test pour  micros() en entrée 
unsigned long ParcMax=3000000; // delai max en µs pour parcourir un secteur, si > arret theorique 
unsigned long Tparct[256] ; // tableau de long stockant les valeurs micros() à chaque interruption
byte Eparc; // etat du 1er creneau

byte Iparc=0; // indice pour parcourir Tparct

boolean Sint=false; // passé par l'interruption oui/non
void setup() {

  pinMode(encoderPinA, INPUT);

  attachInterrupt(0, doEncoderA, CHANGE); // // encoder pin on interrupt 0 (pin 2)

  Serial.begin(115200);
}

void loop(){
  Eparc=digitalRead(encoderPinA); // recup de l'etat pin à l'init
  if (Sint==true)
  {

    Serial.print(">"); // pour test d'entre/sortie de secteur ,indique passage par int0 

    Sint=false;
    
  }

  if (micros()-Tact > ParcMax) { // tempo en µsecondes pour test si pas eu d'interruption 

    Tact=micros();
    Serial.println();
    Serial.print("-- passe tempo --> ETATS=");  
    
    Serial.print(Iparc-1);
    Serial.print(" ");
    
    Serial.print(millis());
    Serial.print("=millis ");
    Serial.print("Etat init=");
    Serial.print(Eparc);
    Serial.print(" ");
    for (byte i=1; i < Iparc; i++){
      
  
      Tparc=Tparct[i]-Tparct[i-1];
      
      
      Serial.print(Tparc); 
      Serial.print(";"); // delimiteur pour log tableur

    } 

    Serial.println();

    Iparc=0;
  }

}

// Interrupt on A changing state
void doEncoderA(){

  Tparct[Iparc]=micros(); // plus rapide 
    
  Iparc ++;
  Sint=true;
}

Il y avait déjà un antenne torsadée ,je suis rassuré le recepteur fonctionne
le moniteur serie m’affiche ça :

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
-- passe tempo --> ETATS=85 3000=millis Etat init=1 340;204;1604;396;196;3128;228;736;744;1840;68;2408;6732;1696;36;716;240;6224;1124;952;1856;1352;1712;1072;1900;1084;2004;2636;828;428;428;552;2472;408;2496;308;460;2068;308;768;564;284;504;3284;692;880;500;1364;2924;2432;1328;1752;624;1244;132;2012;2664;32;5448;124;2508;856;600;324;1304;388;1552;724;44;1792;1596;2040;1336;1508;64;852;644;1000;464;2984;2468;2212;1744;628;1204;516;320;1524;1028;844;224;2880;160;7264;216;1948;736;196;224;512;464;868;568;412;1012;2008;1540;1340;1692;4704;2408;308;2084;1000;148;
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Mais je souhaite pouvoir émettre le code après
Sinon existe t - il une autre librairie plus simple ?(j’ai recherché ,je suis tomber sur une librairie qui se nomme “VirtualWire” qui permet de communique entre deux arduino mais qui ne semble pas adapter a recevoir et tranmettre des codes a des appareil comme recepteur pour porte de garage ou
prise télécommandée ,est ce vrai ? :slight_smile: )

bonjour
A priori ta telecommande velleman n’est pas reconnue par les softs basiques , mais “coup de bol” elle ne semble pas etre une telecommande faisant du rolling code.
Le probleme reste donc “assez simple”
le vrai gros probleme est déjà de recuperer une/des trames pour voir à quoi elle ressemble , et là il faut un peu d’astuce.
Le plus simple si tu ne dispose pas d’equipement genre : analyseur logique, recepteur/enregistreur RF est d’utiliser un logiciel d’enregistrement (I.e Audacity) et un petit montage faisant l’interface entre la sortie data du module recepteur et l’entrée ligne d’un PC.
exemple

Artouste:
bonsoir
voir déjà des cotés :
SOFT : la lib rcswitch ne reconnais que quelques “protocoles” simples (je ne sais pas si ta telco en fait partie)
HARD : il faut aussi sur ce genre de module mettre une antenne “un peu adaptée” (pastille angle en bas à gauche , recepteur vu face compo)

tu peux faire une levée de doute en utilisant un test de tempo avec ce petit prog sans modif de ton cablage (prevu pour UNO et INT0 = pin2)
en appuyant sur les “boutons ta telco” ; tu devrais voir de l’activité sur le serial ( > et tempo etats)

enum PinAssignments {

encoderPinA = 2,

};

unsigned long Tparc=0; //  temps de parcours du secteur
unsigned long Tact=0; // Test pour  micros() en entrée
unsigned long ParcMax=3000000; // delai max en µs pour parcourir un secteur, si > arret theorique
unsigned long Tparct[256] ; // tableau de long stockant les valeurs micros() à chaque interruption
byte Eparc; // etat du 1er creneau

byte Iparc=0; // indice pour parcourir Tparct

boolean Sint=false; // passé par l’interruption oui/non
void setup() {

pinMode(encoderPinA, INPUT);

attachInterrupt(0, doEncoderA, CHANGE); // // encoder pin on interrupt 0 (pin 2)

Serial.begin(115200);
}

void loop(){
 Eparc=digitalRead(encoderPinA); // recup de l’etat pin à l’init
 if (Sint==true)
 {

Serial.print(">"); // pour test d’entre/sortie de secteur ,indique passage par int0

Sint=false;
   
 }

if (micros()-Tact > ParcMax) { // tempo en µsecondes pour test si pas eu d’interruption

Tact=micros();
   Serial.println();
   Serial.print("-- passe tempo → ETATS=");  
   
   Serial.print(Iparc-1);
   Serial.print(" “);
   
   Serial.print(millis());
   Serial.print(”=millis “);
   Serial.print(“Etat init=”);
   Serial.print(Eparc);
   Serial.print(” “);
   for (byte i=1; i < Iparc; i++){
     
 
     Tparc=Tparct[i]-Tparct[i-1];
     
     
     Serial.print(Tparc);
     Serial.print(”;"); // delimiteur pour log tableur

}

Serial.println();

Iparc=0;
 }

}

// Interrupt on A changing state
void doEncoderA(){

Tparct[Iparc]=micros(); // plus rapide
   
 Iparc ++;
 Sint=true;
}

Bonjour,

Je suis débutante je n’arrive pas à faire communiquer mes modules 433 mHz. Je suis à priori dans la même config que Yann442 et j’aurais pu écrire son premier post, alors j’ai testé ce bout de code poté par Artouste mais moi je reçois ça sur le moniteur série :

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>÷¹ÿÿùîü½üÿê|¾^ì{ìÞÿë¿ü¼øÚ¿ÿßÿÞüüÞüýö¿ß¯ûüÿßïëÿ÷ÿíü{ÿïü|ÿÞü¼žü¿ÿÿß¿Ýøþÿìý|ö¿ÇÜü»ÿÿÿ÷ÿ|ìÿÿÜ3÷¼ììòÝÿû÷ÿÿÿ<ÿ¾ÿÿüÿwüÿ÷¿¿õ{ïÞÿÿ÷}÷ûûüÿz÷žü{ÿÿïþïÿÜþüìüüÿÿÿûßÿîÿÿÿÿÿÿ¿þÜì·ïÿÿvßýÿþÚ·Üüÿßÿ›Ýßíÿÿÿ÷{ÿ÷ÿ7÷7ÿüÿÿÿÿïüÿÇÿÿüïýÿÿìþ|Žì7|ÞæÜ/~Ëÿÿ¼÷û÷ÿÿþÿÿÿûÿÿÿÿßþÿÿýÿÿÿÿÿWÿîÿÿ·ÿ;óìŸìÿÿúíýÿîßúÜìÿÿÿ~ìî{÷ÿüÿonüîûoìüÞ÷þ»üÿþßßùÿþììæüììûÿÿÿïÿÿÿÿýììv¿¼ÿÿÿÿÿÞÿ¿÷þû{ýüßüßììììÿýÿûì÷ÿÿþîîþúþoþýÿõÿÿÿÿüþþÿÿþÿÞþÿýÿÿÿ÷ÿÿÿïËÿýûÿütùì·üìö¼Õÿ÷ÿíüÿúÿüæ,ÿÿ|ì;Üìÿÿÿ¿ÿùŒìûº>ï¼þÿüìÿßì›ÿÿÿìÿÿþìÿþÿûÿÿýÿúÿÿïþÿþûά¼üìwrÜþìì?ÿì~óÜûþ<ìÿþý÷÷®þþÿÑÞÿüÜî¼ßíîÿ÷ÿíºÝܼüÜÙ?ÿÿïÜÿ¬÷ÿÿìÞŒþÞ©ÿßûÿÿßÜÿÿÿý¿ÿÿýÿÿÿÿÿÿÿÿüüîÿ¿þÿÿ¬ü?ÞÜüuÿïï¿ïüïûÿ¿�Í»vüÿþ¿÷OÿüûÿýþÞüìlüìÜ}cÿÿþÿ¿ÿÜÿÿÿ÷ÿ¿üÿÿÿÿÿÿÿüÿçoÿÿÿÿÿ÷ÿüïûÿüy»ìÞ{Úý7ÿ�ÞÿþÞüÿßýüüÿ¼�½ìÞìÜnÿûÞ›ÿßÿÿÿÿÿÿÜÿÿüÿöÿÿÿ»½ò¿ºÿû¿ìó¿7îÿÿìÿÿ¼öü·?{w{ÿ·ü{�?ÿû¿ÿìì÷ÿïÎìÿÿïÿÿ¾ÿÿûþÿÿüþÿÿÿýì¯ýÿþ|o¼þûÿßîÝÞóqûûûììÞìÜþìßþþÿßÿíþÿwìü¾}ûýÿÿÿýÿûÿÿÿþÿÿþÿþÿïÞìóý»¿ÿÿÿþçÿûÿÿÿºÜü¾ýþÿ¼ÿ»ÿÿÿÿþÿñ÷ÿ˜ûì}Þìÿÿ÷÷ÿÿÞý»:
„&5²#P·³­³³·5³}5º³55å##³|¼£'R?-²2¿3-1»²¿uÿìÿýÿÜ¿ÿìì?ìÿ¾ìÿÞìÿÿþÿÿÿÿÿÿü¼ü{ÿìÿÿÿÿÿÿÿÿûÿìõ÷½wüþï~ÿÿûìÿÿüßÿÿÿÿÿ{ÿïÿßÙÜï{þÿÿÿßÿûÿ~zûÿÿßìû¿þœì´¿üüÿüÞý¿ÿÿììÝ>¿ÿþþÿïÿÿÿÿÆßüÿÿÿÿÿÿÿÿÿïÿÿÿÿþÿÿÿÿüÿßýçþÿþ<Ï¿üþïÿþîÜlìóÿ^ÿÿÿüÿÜÿÿüÿÿÿÿÿÿïÿÿÿûÿþÿüÿÿÿÿÿÿŸýÿßÿÿïÇþÿÿÿøw¾þ�ÿÞììÞìþüeþïÿÿôÿ¬ÿ~ìì½�›üüÿþÿÿÿÿ«úÜ|ÿþ¿Ü�ììþ¿þÿÿçýìÞ÷ÿûïüÿüÿÿÿÿÿöÜïÿ÷ó|ÿÿ¿þÿþÞã÷¼ÿþÿÜþÿÿÿÿ³¾çìûwlÿÿÿÿü÷ÿÿÿÿþ÷û÷ÿïßì÷ÿýÿÿùüÿÿÛÜ¿ýõÿüñ¿´üþ_žÿwûÿÿoß»ÿìÞÿÿ�üßÿ»ü¯ÿÿÿêÿÿóû÷wìýÝý¬»=Lÿþÿý¬ÛìþÿüÍôìÞìœÿÿÿÿ{Ç÷þûýûüÿìûÿìÿÿÿÿÏÿ÷¼ÿ¬ÿÿÿÿÿÿþÿöüÜììÿì}ÿ÷ûßÿüüÛþ÷ìÿþ{ÿüÿûÿÿÿÿÿÿÿÿÿÿÿÿÿûÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿûÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿûûÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿûÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ÷ÿüÿÿÿï÷þ{¼ý}ýËüÿÿÿþÿþ¿ÿî·Ÿÿýë/ʽÿvÿþüïìÿÿßÿ¿¿¿ìÿü�wÿýïÿï÷ïÞÞû÷½ÞÿÛ¾Ýÿÿÿü|üüÿÿýÜÿü콟ÿ½öÞÜìÞÿÿÞïÿ¿~ÿþ~ÿïüûÚìZê·y½¿ÿ¿½ÿþÿìÿüæþ3w¼=JÝü¿¿ÞÂZ.5½1Þ÷ÿßß—}ûÿþ}ÞóÿÿÿÿÿþlÜûïæÿÿïÿ¾üììô·ÿïýºóÿ¾~þßÿ÷Þþ>ì÷vÿÿÿÿüË÷ßü÷üììÜï¿ììl<ýÿÿÿÿÿÿºÛ¼üü¿ÿûÿ³lþÿüÿÿÿÿÿÿÿÿÿÿÿÿïÝóÿûÿ}ï¿ÿÿÞÿßü¿ßÜÿÿóÿßÿïìwûÿÞÿüìïœüÿÿÿþÿÿÿüïþÿÿüÿÿÌÿÿÿÿÿîýµüδ¿þÿºþÿüÿþÿÿ{ÿÿÿõüÿþÿÿþ<üÿû¿ÿ¯ÿÿÿ|ÿûÿýý¿ü?ý¿Ü~_ûzÞÇÿüßûo<ÿÜÿûÿ÷üþüÝÿ¼ÿ¯ûÙ~þÿüœÿÿ­÷ÞÞìyüÞ¼ß÷ÿþþüÿÿþÿÿÿ¼ÿÿÞ{ÍlïÞÿ|ÿÿýßþûÿÿÞìÏÝÿüý÷÷Üýþßþÿÿß}ÿÿûìýìÿÿ÷þþüÿÞÿÿÿÿÿ÷ÿÿŽüûÿÿþìüüÜßìüÏ–½Ïmÿûôüÿÿÿûÿ¿üûwÿ÷«þîîïÿû¿ÿûÿÿïÿwþÜÿüÿÿüïÿõ¿îû¾üÿÿÿìÿÿÿÿÿÿï{þvÿüììÿûÿ¿ÿþ÷÷üŸïûÿíû?ÿÿÿïõýÿlþÿÿÿÿÿþ»ÿÿ½þ¶¿úîÜÜÞììÄ}ÿÝ�ìÇþÿ¿ïü¿¿}ëüüìÿÿÿÿvß{Þßÿ¼·þ|þÿ|ßÿýÿ÷ÿ;üÿ¼ìöìì[ÿܯÿÛþßÿ÷ÿÿüÿÿÿþÿþÿíûÿÿÿhþÛ¿÷þŸ÷ïýÿ÷ï¿îïü¼dìì|ÿüþÿÿÿÿÿÿÿÿûÿÿÿûÿÿÿÿûÿÿÿÿÿÿûÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿûÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿûÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿûÿÿÿÿÿÿÿÿÿÿÿÿÿûÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿûÿûÿÿÿÿÿÿÿÿÿÿÿÿûÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿï¿ÿýÿÿ}Þ7½ÿßÿßþÿÿÿ_ßÿûÿÿÿÿÿï{þÿÿûÿ~ãøßÿ¿÷Ýú¾{ÿÏþììØwÞÿÿÖgÞíýüÿü_üï¼|ü÷¶þü¬Üûüÿ˸{¿þ¼Þì{ìþ|ü7ý¿¯ÍüºþÿýÿÿìóÿÿýÜÿßïüÞÿµ÷ǼßþÿúŽFK'²£³y#³¢-5«}£xƒ~ßûÿÿþìûö7Çú÷ÿÿÿ÷îöüì®ü¬þ»Þ÷ÿÿÿÿï·ö_?ßÿüû�ïûûÿÿþßýÿÿÿ÷ÿüüÿ÷ïü¿ÿ¯ìܼü÷Üì½÷·½÷ü¯ÿ¬{»ýìïÛìÿïÿÿßÿÿÿÿþþïþüÞ¿Vöüžüÿÿÿÿÿ¾ÿÿÿÿoþÿþÌÿïÿßüÿÿÿþ·ÿÿÿåÿüìŽþÿÿÿ~ÿþþÜl·þþÿÿþþ?Ô÷»÷þÜüÿÿ¾ÿþÿÿÿÏÿÿÿÿü¼ìÿÿýÞüº|Œ¼þÿ¿ÿýýßÿÿ_¿¶ß?÷ìÞ]ÿ|ýüœþýûòïÝÞÿÿþûûÿ÷Çûÿ~óÞÞÜúûÿÿÿÿüÿÿÿÞ»ÌÛýÞ¼üììûþþÿÿ?ÿßìììÿ÷ýý}ýóüûþÿõÿÿüï¿ÜÞ_ãÝì}ÿýÿüÿÿÿÿþÿìÞüüüÿßÿÿ~ÿÿïí¬ÞûÿÿÿþïÿæþÜìÜ�ì¼õßîúÿÿÿÿÿþüý½þÞÿ·Ù÷üþÛÞßÆÿÿÿþÿûÿûÿÿÿûÿÿÜßòo~Îïæ»ÿÿ÷�Þ~Þÿû~ìï~ì´ú}ü½¿÷ÜvÿÿÿÜgÿÜ÷Þÿ¿wüüÿÿÿÿÿÿû¾ÿÿïï÷ÿÿöÞ÷ÿì|ûÿÿÿÿÿÿÿüü~ü|úÿìýþÿïüÿüÿwìüüÞÿß¾þÿÿýþüÿßÿßüüþÿÿÿÿþ¿ÿÿüÛìü÷ùïmÞ÷ýìüÿÿn¿ÿÿÿßþïììüüþÿìììì|üÞÿû¿ÿÜÌßÿÿþÿïÿüŸüz~ÿ÷¾žÜÝïüÿÿÿÿÿÿÿÿüÿÿÿÿýÿÿÿú¿þýüÝßÿ÷ÿÿïÿÿî×ïì~|ýýÿÿ÷�ïþwÿÿÿßÿëìþþÿÿÿÿ÷ßýÿÿßÿÿÿÿÿþýÝ÷ÿÿÿ›»ÿïwïßìììüýÿÿü÷ëûwô¾ìÿÿÿÿýÿü>ÿïÜ÷woìþ?ÿÿÿïûÿÿz÷ûüeÿ{wÿÿþ

Est-ce que celà veut dire que mon récepteur ne fonctionne pas ?

J’ai pour tester 2 paires émetteur/récepteur (FS1000A / XY-MK-5V), j’ai une télécommande de porte de garage (doitrand ts2de) mais j’ai le même résultat à chaque fois. J’ai l’impression que plein de caractères défilent et quand j’appuie sur un bouton de la télécommande ou que j’envoie une trame avec l’émetteur connecté à un raspberry, il y a alors beaucoup de “ÿÿÿ” qui s’affichent.

Est-ce que j’ai un problème matériel ? trop d’interférences ?

Merci de votre aide,

Céline

hello
si tu utilises le code de notre ami Artouste, vérifies que tu as bien paramètré ton moniteur à 115200 bauds

dfgh: hello si tu utilises le code de notre ami Artouste, vérifies que tu as bien paramètré ton moniteur à 115200 bauds

Merci beaucoup. En effet je n'avais pas mis la bonne vitesse.

Je vois mon problème : je capte beaucoup de bruit ... puisque sans appuyer sur aucun bouton j'ai plein de trames qui passent.

Merci

Bonjour, ce poste m'interresse car je suis également dans cette meme configuration. Beaucoup d'activitée dans la console sans aucunes réaction de ma part. Je vais suivre tout ça de très pret

bonsoir le code n'a reellement qu'une utilité : "voir" si il y a de l'activité venant du capteur (là le récepteur UHF)

pour la cas "particulier" des récepteur UHF "cheap" , il y a toujours +/- de l'activité ce qu'il faut "regarder" c'est la variation temporelle lorsqu'il y a de l'activité venant de l’émetteur, mais ce n'est pas avec ce code que l'on décodera tous les protocoles. :grin:

Et alors comment réussir à communiquer avec une télécommande 433 ? Comment pouvoir la décoder ?

Fredericzim: Et alors comment réussir à communiquer avec une télécommande 433 ? Comment pouvoir la décoder ?

bonjour Frederic Si il n'exista pas déjà une librairie existante pour ta telecommande , il faut "analyser" les trames (tempos) et pour ça il faut un peu de materiel , du plus simple au plus sophistiqué

  • un petit montage pour injection du signal sur une entrée son de PC et utilisation d'un soft d'enregistrement (i.e audacity )
  • un recepteur large bande (dongle RTL) et un logiciel d'exploitation genre SDR#
  • un analyseur logique

l'ideal etant d'acquerir les trames au niveau de l’émetteur.

apres le debut du jeu consiste à voir si "on" est sur du codage fixe ou du codage plus evolué.

(re)voir ce topic, de 2012 où l'on c'etait mis à plusieurs pour s'amuser avec des telcos "exotiques"

c'est quoi la reference de ta telecommande ? Photos lisibles des PCB et des composants ?

|375x500

bonjour c'est etonnant que la lib rcswitch ne reconnaisse pas ton emetteur l'encodeur est un xx2260 compatible avec cette lib.

à coté ce n'est pas le recepteur d'origine avec ta telecommande , mais un recepteur "cheap" 433.920 ? ta telecommande vient d'où ? , tu es sur que c'est une 433.920 MHz ? la frequence est indiquée sur le boitier de l’émetteur ?

Salut, non ce n'est pas la télécommande qui va avec le récepteur. La télécommande provient d'un petit Quad chinois pour enfant , elle servait à arrêter le Quad à distance .

Pour la fréquence , je ne suis sur de rien , rien n'est indiqué sur le boîtier

Fredericzim: Pour la fréquence , je ne suis sur de rien , rien n'est indiqué sur le boîtier

c'est le premier doute à lever pour faire court : 434 MHz c'est plus europe 315 MHz c'est plus US

les asia vendent les 2 "standards" vois tu avec le prog d'activité exposé plus haut et ton recepteur de l'activité plus importante lorsque tu appuie sur les contacts ?

Quand je lance le monieur serie, il y a enormément d'activité qui défile, mais ça ne change absolument rien quand j'appuis sur la telco

Fredericzim: Quand je lance le monieur serie, il y a enormément d'activité qui défile, mais ça ne change absolument rien quand j'appuis sur la telco

teste en utilisant en sortie de ton recepteur un ecouteur de casque ou un petit haut parleur sur le quel tu met une petit R (100 Ω par exemple, rien de critique ) entre GND et DATA de ton recepteur alimenté. tu devrais entendre distinctement les trames envoyées par ton emmeteur. si tu ne distingue rien c'est mauvais signe : -emmeteur HS -récepteur HS - pas d'accord de frequence

si, quand j'appuis, j'entend un grésillement!