reconnaitre une horloge sur une entrée....

bonjour a tous

J'ai un programme simple principal qui fonctionne avec divers capteurs, mais j'ai besoin de faire pouvoir lancer un autre programme (programme de test sans prendre en compte les diverses sécurités) sur demande sans avoir a reuploader quoi que ce soit. Comme il ne me reste plus aucune entrée et qu'elles sont toutes protégées par optocoupleur, Je pense donc faire un petit montage avec un 555 pour faire une horloge sur une entrée (branché comme une "clé" à la place d'un capteur) et donc "switcher" de programme dans ce cas de figure. Actuellement, mon montage a base de 555 delivre une horloge ayant une période de 1.4ms.

que dois je mettre comme condition if pour que cette horloge soit reconnue?

Merci

n1c0l45: mon montage a base de 555 delivre une horloge ayant une période de 1.4ms.

que dois je mettre comme condition if pour que cette horloge soit reconnue?

Merci

bonjour en gros tu veux vérifier sur une entrée un signal de P° 1.4 ms pour entrer dans un mode "maintenance" ? en fonctionnement normal cette entrée est "activée" par quoi ?

c'est exactement cela

en mode normal elle est activé par un capteur pnp (capteur de fin de course de verin)

la detection de la frequence de 1.4ms peut etre assez large car, en fait il dans l'utilisation normale, il n'y a que contact ou non contact (1 ou 0)

n1c0l45:
c’est exactement cela

en mode normal elle est activé par un capteur pnp (capteur de fin de course de verin)

la detection de la frequence de 1.4ms peut etre assez large car, en fait il dans l’utilisation normale, il n’y a que contact ou non contact (1 ou 0)

bonsoir
à chaud je compterais le nombre de transitions (low high) sur une petite période de temps, periode de temps << à la periode de detection et de transition du verin entre extremes.

Intuitivement et personnellement je n’aime “trop” pas cette approche de changement de mode :grin:

aurais tu un exemple de code que je puisse utiliser pour m'inspirer?

merci

Bonjour,

Toutes les broches sont utilisées ? Même Rx/Tx (D0/D1) ? Si le port série est toujours dispo il suffirait de mettre un fil en Rx et Tx, avec un code qui envoi un message au démarrage. Si le message revient sur Rx c'est que le fil est présent -> mode maintenance, sinon -> mode normal.

non malheureusement je n’ai aucune broche dispo… donc la solution n’est pas possible :frowning:

n1c0l45: non malheureusement je n'ai aucune broche dispo..... donc la solution n'est pas possible :(

bonjour ton contact verin avant d'entrer en en mode maintenance est obligatoirement dans un seul état stable et connu ? l'entrée arduino est tirée à low ou high ?

pas forcement.... il peut etre soit activé soit desactivé.

Sinon je pensais, pour etre plus "safe" on pourrait proceder comme cela. 1- carte off 2- branchement du montage timer sur l'entrée 3- allumage de la carte

Comme cela, par exemple on verifie à l'allumage de la carte si le timer est present, sinon on passe dans le mode normal? qu'en pensez vous?

l'entrée est tirée en Low

n1c0l45: pas forcement.... il peut etre soit activé soit desactivé.

Sinon je pensais, pour etre plus "safe" on pourrait proceder comme cela. 1- carte off 2- branchement du montage timer sur l'entrée 3- allumage de la carte

Comme cela, par exemple on verifie à l'allumage de la carte si le timer est present, sinon on passe dans le mode normal? qu'en pensez vous?

l'entrée est tirée en Low

bonsoir si je devais faire avec ses contraintes , je me tournerais vers une solution 1wire (mais bon c'est parce que j'aime bien les 1W ) un compo 1wire + sa R4.7K cablé sur un jack male , la jack femelle à coupure (1 voie vers le capteur verin, l'autre vers le jack male)

et dans le soft une lecture 1wire toutes les x boucles , si compo 1W reconnu = mode maintenance, si non mode production

l'entrée est tirée à low à quel niveau du systeme ?

le soucis est que toutes les entrées sont protégées par des optocoupleurs et que je n'ai acces qu'a l'exterieur du boitier (soit le connecteur de capteur).... donc la solution 1w n'est pas possible :s

n1c0l45: le soucis est que toutes les entrées sont protégées par des optocoupleurs et que je n'ai acces qu'a l'exterieur du boitier (soit le connecteur de capteur).... donc la solution 1w n'est pas possible :s

ok Alors l'approche serial evoqué par skywodd reste intéressante, peut etre en utilisant du "softserial" en entrée tu peux faire un schema electrique exact de ce qui est pris des l'exterieur du pin arduino ? quelle tension sur le contact du verin, industriel en 24V , optocoupleur en collecteur ouvert ?

voila le branchement de l’opto

la tension de travail est du 12v

n1c0l45: voila le branchement de l'opto

la tension de travail est du 12v

ok, bon c'est bien un optocoupleur 8) mais le contact verin est où ? et est cablé comment (prise de potentiel) ? :grin: et du coté arduino , il y a quoi d'autre ? c'est cablé comment ?

voila la doc du capteur

le + du capteur est pris sur le 12v d’alimentation de la carte
la masse du capteur est également prise sur la masse de l’alimentation de la carte

IFM fin courseIR5014.pdf (20.3 KB)

n1c0l45: voila la doc du capteur

le + du capteur est pris sur le 12v d'alimentation de la carte la masse du capteur est également prise sur la masse de l'alimentation de la carte

OK en gros ton probleme c'est çà ? tu n'a acces facilement qu'en zone verte (reste un doute pas levé = avant ou après R6 ? ) si tu applique du 5V en entrée de R6 tu detecte ou pas ?

oui c'est cela, je n'ai acces qu'a la zone verte la resistance est sur la carte donc je n'y ai pas acces de l'exterieur

je sais pas si en appliquant du 5v, je vais avoir detection... le soucis est que je n'ai d'ailleurs pas de 5v de dispo, que du 12

n1c0l45: oui c'est cela, je n'ai acces qu'a la zone verte la resistance est sur la carte donc je n'y ai pas acces de l'exterieur

je sais pas si en appliquant du 5v, je vais avoir detection... le soucis est que je n'ai d'ailleurs pas de 5v de dispo, que du 12

tu n'a pas sous la main de quoi generer à peu pres du 5V ? tu ne peux pas travailler à l'aveugle là dessus sans un minimum de "matos" :grin: pas de petit bloc alim ? pas de "piles" pas de regulateur genre 7805 ? pas de quoi faire un diviseur de tension avec un potentiomètre ? pas possibilité pour test d'utiliser le 5V d'un arduino de developpement ? pas de diodes pour faire chuter 12v vers 5 ? (une 10zaine 1n400x en serie)

lol si, je dois pouvoir trouver cela

bon je fais le test au plus vite ;) merci de ton aide

juste une question, pourquoi vouloir voir ce qu'il se passe sur l'opto si on lui balance du 5v, je comprends pas (mais je vais le faire quand meme, mais c'est juste pour ma science ;) )

n1c0l45: lol si, je dois pouvoir trouver cela

bon je fais le test au plus vite ;) merci de ton aide

juste une question, pourquoi vouloir voir ce qu'il se passe sur l'opto si on lui balance du 5v, je comprends pas (mais je vais le faire quand meme, mais c'est juste pour ma science ;) )

:grin: je suis déjà éventuellement dans l’étape de simplification, moins il y a de tripaille sur ce genre de truc , mieux c'est :grin: si l'opto reagit au 5V ça simplifie(ra) 8)