Recurring problems with arduino nanos

For about 2-3 weeks I’ve been having trouble with my arduino nanos, at first I had 3 chinese clones with the ch340 chip which worked for 6 months, then they all stopped uploading, so I spent a week trying to fix the drivers which didnt work, so finally I ordered a on brand arduino nano with the ftdi chip instead. The board worked for like 5 minutes then stopped uploading with the avrdude: attempt 10 of 10 failed error just as before. I came on to the forums to get help and someone told me to uninstall its drivers then they would be automatically reinstalled when I plug it back in so I did that and now the board doesn’t have drivers and isnt even recognized by my laptop.

TLDR: Basically my arduino nano drivers aren’t working, I just want to build my stuff again and I’m trying to see if I anyone could help or if I should just switch over to raspberry pi and go through that whole process.

That is a lot of trouble. I read about a few similar problems when running Windows XP or Windows 7.

Do you use Windows 10 ?
How old is your laptop ?
Perhaps there is software installed that does something with the serial ports.

You might have to reinstall Windows.
Do you have another computer or can you install linux on the laptop ?
Did you install the CH340G driver from the manufacturer ?

A Raspberry Pi is a complete computer running linux. The simple boards are too slow though. It should see all the Arduino boards without installing additional drivers. I think you have to put yourself in the DIALOUT group and perhaps set permission for avrdure.

I order to gather more information that might help us to troubleshoot your problem, I’m going to ask you to post the full output from the upload when in verbose mode.

Please do this:

  1. Select File > Preferences from the Arduino IDE’s menus.
  2. Uncheck the checkbox next to Show verbose output during: [ ] compilation
  3. Check the checkbox next to Show verbose output during: [ ] upload.
  4. Click the OK button.
  5. Attempt an upload, as you did before.
  6. After the upload fails, you’ll see a button on the right side of the orange bar Copy error messages. Click that button. This copies the full output to the clipboard.
  7. Open a forum reply here by clicking the Reply button.
  8. Click the </> icon on the post composer toolbar. This will add the forum’s code block markup (```) to your reply to make sure the error messages are correctly formatted.
    Code block
  9. Press Ctrl+V. This will paste the error output from the upload into the code block.
  10. Move the cursor outside of the code tags before you add any additional text to your reply.
  11. Click the Reply button to post the output.

Ok ill post the pictures in a minute but the new board doesn’t have any drivers so I cant select its port when attempting to upload, my computer is windows 10, the laptop is only a couple years old, I installed the ch340 drivers for the old boards but saw no effect, and the ch340 Chinese boards worked for about 6 months flawlessly then decided to stop uploading, and I have tried multiple versions of arduino ide.

Arduino: 1.8.13 (Windows Store 1.8.42.0) (Windows 10), Board: "Arduino Nano, ATmega328P (Old Bootloader)"

Sketch uses 3114 bytes (10%) of program storage space. Maximum is 30720 bytes.

Global variables use 54 bytes (2%) of dynamic memory, leaving 1994 bytes for local variables. Maximum is 2048 bytes.

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.42.0_x86__mdqgnx93n4wtt\hardware\tools\avr/bin/avrdude -CC:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.42.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM5 -b57600 -D -Uflash:w:C:\Users\Brooks\AppData\Local\Temp\arduino_build_766129/LightSwitch_Code.ino.hex:i 



avrdude: Version 6.3-20190619

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2014 Joerg Wunsch



         System wide configuration file is "C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.42.0_x86__mdqgnx93n4wtt\hardware\tools\avr/etc/avrdude.conf"



         Using Port                    : COM5

         Using Programmer              : arduino

         Overriding Baud Rate          : 57600

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x55

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x55

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x55

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x55

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x55

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x55

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x55

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x55

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x55

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x55



avrdude done.  Thank you.



Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.



This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

This is for the ch340 boards not the on brand one with the deleted drivers, thanks

Yeah, that’s why I thought we could start with the Chinese boards.

Select Tools > Board > Processor > ATmega328P from the Arduino IDE’s menus and try uploading again.

Even though many of the Chinese boards require the “Old Bootloader” setting, some of those manufacturers have started using the new bootloader. So it’s not always the case that the old bootloader is the right selection.

Yeah Ive tried both, I think I used to use the old bootloader anyway

Use the zip version, not the windows app.