réglage GRBL

Salut,

j'utilise GRBL pour controler les moteur d'une cnc. Le problème c'est que les moteurs saccadent. Je pense que c'est du au delay entre chaque impulsion de pas qui est trop court.
Comment le modifier dans les fichiers librairies grbl? car dans les réglages grbl on ne peut pas dépasser 250 us.

merci

en fait que pense que le temps entre chaque impulsion est trop long (et non trop court).

J'ai testé avec mon programme :

        digitalWrite(PUL,LOW);
        delayMicroseconds(900);
        digitalWrite(PUL,HIGH);
        delayMicroseconds(900);

La ca tourne bien

        digitalWrite(PUL,LOW);
        delayMicroseconds(2000);
        digitalWrite(PUL,HIGH);
        delayMicroseconds(2000);

La avec 2000us ca tourne comme avec grbl, ca saccade. Donc grbl est trop lent je crois

bonjour,
tu as programmé le nombre de pas comme il faut pour tes moteurs?

step pulse est désactivé d'origine dans le config

#define DWELL_TIME_STEP 50 // Integer (1-255) (milliseconds)

// Creates a delay between the direction pin setting and corresponding step pulse by creating
// another interrupt (Timer2 compare) to manage it. The main Grbl interrupt (Timer1 compare)
// sets the direction pins, and does not immediately set the stepper pins, as it would in
// normal operation. The Timer2 compare fires next to set the stepper pins after the step
// pulse delay time, and Timer2 overflow will complete the step pulse, except now delayed
// by the step pulse time plus the step pulse delay. (Thanks langwadt for the idea!)
// NOTE: Uncomment to enable. The recommended delay must be > 3us, and, when added with the
// user-supplied step pulse time, the total time must not exceed 127us. Reported successful
// values for certain setups have ranged from 5 to 20us.
// #define STEP_PULSE_DELAY 10 // Step pulse delay in microseconds. Default disabled.

salut et merci pour ta réponse.

Eh bin jessaye de faire les modifs dont tu parles dans le fichier config.h mais ca change rien, j'ai même essayé de supprimé le fichier config.h (dans librairies) puis de retéléverser le programme exemple de grbl dans la carte arduino mais ca change rien, les modifications ne sont pas prisent en compte on dirait.

https://letmeknow.fr/blog/2016/07/11/piloter-une-cnc-avec-arduino-et-grbl/

Salut j'ai reussi a modifier le bon fichier.

le step pulse delay n'a presque aucun effet, juste qu'a 250 le moteur ne tourne pas. J'ai essayé de mettre les step/mm a 1200 et la du coup ca tourne un peu mieux mais ya toujours des sauts de pas. Et puis c'est pa logique, le moteur est censé tourner correctement quelque soit la vitesse à laquelle il tourne non?