Regolare la corrente in un L298N

Salve a tutti,
Scusate la domanda sicuramente stupida ma è il mio primo intervento nel forum ed è anche la prima volta che uso Arduino quindi sono veramente ignorante in materia!
Sto alimentando un motore DC con un ponte H L298N, che riceve il voltaggio dai 5V da una scheda Arduino UNO R3.
Il mio problema è che una volta collegato il carico il motore fa davvero fatica, mentre se lo alimento direttamente da un trasformatore a 4,5V va senza problemi e anche forte...
Ho controllato il voltaggio che esce dagli output 1 e 2 del ponte H ed è anch'esso di 4,5V... Riuscite a spiegarmi cosa mi sfugge?
Potrebbe essere un problema di corrente non sufficiente in uscita dal ponte, a parità di tensione, quindi coppia bassa?

Grazie per aver letto e in anticipo per una risposta :wink:

E" buona norma presentarsi prima di partire in qarta con le domande...
deto quest, secondo me il motore richied troppa corrente e la usb del pc con cui lo alimenti non basta.. hai provato ad alimentare arduino con un alimentatore esterno e vedre se il proble,a si ripresenta |
se ci dai piu info sul motore potremmo aiutarti meglio.
ciao

Grazie mille, mi scuso se non mi sono presentato ma questo è il mio primo post in un forum in generale in 25 anni di vita quindi non conosco certe usanze, non volevo cero essere maleducato!
Sto costruendo un semplice (ovviamente non per me) garage automatico in cui la porta è trainata da questo motore DC di cui non ho i dati di targa, perché l'ho ottenuto cannibalizzando una stampante...
Si, ho provato a dare fino a 12V con un alimentatore esterno ma il problema sussiste, potrei pensare di alimentare il ponte H in modo indipendente e con un voltaggio diverso dai 5V dell'Arduino UNO?

Grazie ancora

Dono

... non lo puoi alimentare tramite Arduino, non è in grado di fornirti la "corrente" necessaria e rischi solo di danneggiarlo.

Ti servono, molto probabilmente, due alimentatori diversi, uno per alimentare Arduino ed uno per alimentare tutta la parte motore ... i due alimentatori dovranno avere la massa in comune.

Guglielmo

dono:
Grazie mille, mi scuso se non mi sono presentato ma questo è il mio primo post in un forum in generale in 25 anni di vita quindi non conosco certe usanze, non volevo cero essere maleducato!

mica eraa una critica :slight_smile:

gpb01:
... non lo puoi alimentare tramite Arduino, non è in grado di fornirti la "corrente" necessaria e rischi solo di danneggiarlo.

beh dipende magari consuma 3.400mA....
comunque sempre meglio un alimentatore esterno, ora. puoi alimentare l298 con i 12v, la sua parte di logica a 5v se non ha un regolatore on board, qui sarebbe un ottima cosa la foto del driver che stai usando.. poi colleghi i 3(enable,dir A,dir B) o 6 segnali tra arduimo ed il ponte H e la massa che dev essere comune, il gioco e"fatto :slight_smile:

ratto93:

gpb01:
... non lo puoi alimentare tramite Arduino, non è in grado di fornirti la "corrente" necessaria e rischi solo di danneggiarlo.

beh dipende magari consuma 3.400mA.........

Mi ero basato su questa sua affermazione : "Il mio problema è che una volta collegato il carico il motore fa davvero fatica, mentre se lo alimento direttamente da un trasformatore a 4,5V va senza problemi e anche forte..." ... alquanto sospetta XD

Guglielmo

Se la corrente richiesta dal motore é maggiore di quella ammessa dalla USB interverrebbero il fusibile sul Arduino e /o il controllo corrente del PC.
Il L298 é un ponte H costruito con transistori NPN. Ha una tensione di saturazione abbastanza alta (totale fino a 3,2V a 1A)
Il datasheet da come valore minimo della tensione di alimentazine del motore una tensione di VS= VIH+2,5V. percui almeno di 7,5V se lo piloti con 5V.

Non so se questo é la causa del malfunzionamento del L298.

Prova di alimentare la parte motore del L298 con almeno 8V . (non usare una pila da 9V perché non puó dare tanta corrente).

Ciao Uwe