Regolatore di tensione AMS1117 e tensione di uscita troppo alta.

Buongiorno a tutti,

Qualche giorno fa collegando una batteria Lipo da 11,1V e 1300 mAh completamente carica ad una scheda Sainsmart Mega 2560 il regolatore di tensione AMS1117 presente sulla stessa è andato in avaria mandando circa 7V a tutti i moduli in quel momento collegati (LCD, sensori, Pixy CMUcam5) danneggiandoli quasi tutti.

Ho provato a sostituire l’AMS1117 con uno nuovo di zecca, ma alimentando la Mega 2560 con batteria Li-Ion da 9V il cui voltaggio attuale è di 7,47V ottengo i seguenti voltaggi letti sui piedini del regolatore:

Piedino 1: 0,00V
Piedino 2: 5,85V :o
Piedino 3: 6,66V
Piedino 4: 5,85V :o

Alimentando una schedina step down (capace di erogare max 2A) con una batteria Lipo da 11,1V e 1500 mAh, regolando l’uscita della step down a 9,04V e collegandola al power jack della Mega 2560 ottengo invece:

Piedino 1: 0,00V
Piedino 2: 7,38V :confused:
Piedino 3: 8,20V
Piedino 4: 7,38V :confused:

Mi aiutate a capire perchè continuo ad ottenere tensioni fuori norma?

Ancora buona giornata.

Prima che passi un mod a "sgridarti" ... per favore presentati nell'apposito thread, come da regolamento ... ;)

>Fanbotica: essendo il tuo primo post, nel rispetto del regolamento (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD ([u]spiegando bene quali conoscenze hai di elettronica e di programmazione[/u] ... possibilmente [u]evitando[/u] di scrivere solo una riga di saluto) e di leggere con MOLTA attenzione il su citato REGOLAMENTO ... Grazie.

Guglielmo

P.S.: Qui una serie di link utili, [u]NON[/u] necessariamente inerenti alla tua domanda: - serie di schede by xxxPighi per i collegamenti elettronici vari: ABC - Arduino Basic Connections - pinout delle varie schede by xxxPighi: Pinout - link [u]generali[/u] utili: Link Utili

>Etem: ... troppo tardi, abbiamo scritto assieme :D :D :D

Grazie per il prezioso suggerimento, ammetto che nonostante avessi letto il regolamento mi era sfuggito il punto 13 che però a questo punto mi sembra sia citato troppo in basso visto che si tratta di una priorità.

Provvederò subito a presentarmi nella apposita sezione, va bene un reply o occorre aprire un nuovo post?

Domanda numero due: Va bene la sezione "Hardware" per domande sul regolatore di tensione AMS1117, se non lo è, quale sezione sarebbe meglio utilizzare?

Fanbotica: 1. Provvederò subito a presentarmi nella apposita sezione, va bene un reply o occorre aprire un nuovo post?

  1. Domanda numero due: Va bene la sezione "Hardware" per domande sul regolatore di tensione AMS1117, se non lo è, quale sezione sarebbe meglio utilizzare?
  1. Si, va bene un "reply" che crea un nuovo post in fila con gli altri :) ... cosa che però fa anche il bottone "post" che trovi in basso, sotto la finesta dove puoi scrivere il testo ;)

  2. Si, la sezione HW è quella giusta.

Grazie,

Guglielmo

gpb01: 1. Si, va bene un "reply" che crea un nuovo post in fila con gli altri :) ... cosa che però fa anche il bottone "post" che trovi in basso, sotto la finesta dove puoi scrivere il testo ;)

  1. Si, la sezione HW è quella giusta.

Grazie,

Guglielmo

Ciao Guglielmo,

Per completezza di seguito ti riporto il link della mia presentazione:

http://forum.arduino.cc/index.php?topic=113640.msg3516271#msg3516271

Buona giornata.

Non so cosa significa la numerazione dei piedini.
Comunque secondo me tutte le schede che hanno ricevuto 7V sono rotte o “maccate” e percui non affidabili.
non so perché si é rotto lo stabilizzatore.
Ciao Uwe

uwefed: Non so cosa significa la numerazione dei piedini. Comunque secondo me tutte le schede che hanno ricevuto 7V sono rotte o "maccate" e percui non affidabili. non so perché si é rotto lo stabilizzatore. Ciao Uwe

Per numerazione dei piedini intendo quella raffigurata difianco alle isole di saldatura dei quattro piedini del regolatore sulla scheda Sainsmart Mega 2560.

Per "tutte le schede" tu intendi i microcontrollori?

Lo stabilizzatore credo si sia fritto perchè non è stato in grado di supportare una tensione di 12V, nonostante nelle specifiche sia indicato di sì, o forse per il quantitativo di corrente richiesta in quel momento. In seguito quello avariato è stato sostituito con uno nuovo nonostante questo il risultato non cambia, la differenza di tensione tra il piedino di ingresso e quello di uscita del regolatore è solo di 0,81V.

Domanda ... ... quando hai collegato la batteria la prima volta, era anche collegata la USB del PC?

Guglielmo

gpb01: Domanda ... ... quando hai collegato la batteria la prima volta, era anche collegata la USB del PC?

Guglielmo

No, il tutto era installato a bordo di un prototipo di rover e non alimentato dal pc.

Potresti aver fritto qualche altro componente, oppure pista ... l'AMS1117, al contrario dei "normali" regolatori fissi che guardandoli da sopra con i pin in basso hanno ingresso - massa - uscita (con la massa collegata anche al tab di dissipazione), ha i pin disposti massa - uscita - entrata (con l'uscita collegata al tab di dissipazione) ... quindi se funziona, fra GND ed il pin verso il jack devi misurare 0V (e' la massa), fra GND ed il centrale (ed anche il tab) devi misurare i 5V, e fra GND ed il pin piu distante dal jack devi avere la tensione di ingresso meno i circa 0.8V che cadono sul diodo in serie ... se non hai quei valori, allora c'e' qualcosa che non va ...

Ovviamente hai usato un 1117, e non un 117, e ne hai usato uno con uscita gia prefissata a 5V, e non la versione "adj", che e' a tensione variabile ... giusto ? ...

Fanbotica: Per numerazione dei piedini intendo quella raffigurata difianco alle isole di saldatura dei quattro piedini del regolatore sulla scheda Sainsmart Mega 2560.

Per "tutte le schede" tu intendi i microcontrollori?

0,8V per il diodo é troppo (differenza tensione batteria e pin 3 del AMS1117)

Io intendo tutte le schede che al posto dei 5V hanno ricevuto di piú.

Ciao Uwe

Etemenanki: Potresti aver fritto qualche altro componente, oppure pista ... l'AMS1117, al contrario dei "normali" regolatori fissi che guardandoli da sopra con i pin in basso hanno ingresso - massa - uscita (con la massa collegata anche al tab di dissipazione), ha i pin disposti massa - uscita - entrata (con l'uscita collegata al tab di dissipazione) ... quindi se funziona, fra GND ed il pin verso il jack devi misurare 0V (e' la massa), fra GND ed il centrale (ed anche il tab) devi misurare i 5V, e fra GND ed il pin piu distante dal jack devi avere la tensione di ingresso meno i circa 0.8V che cadono sul diodo in serie ... se non hai quei valori, allora c'e' qualcosa che non va ...

Ovviamente hai usato un 1117, e non un 117, e ne hai usato uno con uscita gia prefissata a 5V, e non la versione "adj", che e' a tensione variabile ... giusto ? ...

Sì in merito al regolatore AMS1117 da me installato, in sostituzione del precedente identico, è esatto mi ritrovo con quanto da te de descritto, secondo la numerazione dei piedini riportata da me sopra:

Piedino 1: 0,00V corrisponde alla MASSA Piedino 2: 5,85V corrisponde all'uscita Piedino 3: 6,66V corrisponde all'entrata Piedino 4: 5,85V corrisponde all'uscita (tab di dissipazione)

i valori che ottengo in uscita sono sballati (5,85V) e fornendo 9,04V in entrata il problema si acuisce perchè l'uscita è di 7,38V.

Sono veramente curioso di sapere come mai, visto che il regolatore dovrebbe essere a monte del sistema di alimentazione della Mega.

Il dissipatore é collegto col pin di uscita non con la massa.

Allora hai un "AMS1117CD-5.0"

Ciao Uwe

uwefed: Il dissipatore é collegto col pin di uscita non con la massa.

Allora hai un "AMS1117CD-5.0"

Ciao Uwe

Sì, la sigla stampigliata sul regolatore è AMS1117-5.0 H1518.

Cosa impedisce dunque al regolatore di svolgere la sua funzione di riduzione del voltaggio ai canonici 5V?

Mistero.

Fanbotica: Cosa impedisce dunque al regolatore di svolgere la sua funzione di riduzione del voltaggio ai canonici 5V?

1) la sua rottura 2) la rottura di qualcos'altro intorno a lui che lo bypassa. Ciao Uwe

Dubito che il nuovo AMS1117 appena installato possa essere rotto, la seconda ipotesi è più probabile, allego lo schema elettrico relativo al regolatore, estrapolato dal pdf originale, si possono notare il diodo di protezione M7, i due condensatori elettrolitici da 47u e il condensatore non polarizzato da 100n.

Il cerchio si stringerebbe a questi componenti.

Schema regolatore Arduino AMS1117.jpg

Non ho trovato schema del "Sainsmart Mega 2560". Mi dai il link? Ciao Uwe

uwefed: Non ho trovato schema del "Sainsmart Mega 2560". Mi dai il link? Ciao Uwe

Il particolare del datasheet che ho allegato è preso dal file disponibile su sito ufficiale Arduino, in quanto purtroppo la Sainsmart non rende disponibile lo schema della Mega 2560 16AU, ma confrontando suddetta scheda in mio possesso con l'originale mi sembra proprio un clone esatto. Per di più il regolatore che ho sostituito è identico a quello che c'era tranne che per i numeri finali, difatti sul regolatore danneggiato c'è la sigla AMS1117 5.0 HK616C (forse il lotto di produzione), mentre sul nuovo installato c'è AMS1117 5.0 H1518.

Alimentando la Mega con la porta USB del pc ho rilevato la giusta tensione 5,04V sul pin 5V. La scheda viene vista regolarmente e la comunicazione seriale è ok, controllato da pannello IDE.

Comincio a sospettare del diodo M7, sai se può determinare questo tipo di problema di voltaggio o se quando si rompe non parte proprio la scheda?

Il diodo e’ in serie … se va in corto, sul pin di ingresso hai la stessa tensione del jack, invece che un po meno, se invece si apre, non arriva piu nulla … altre possibilita’ non ne ha … :wink: