reinstall problems

I had a problem with libraries loading and before i knew it they were all over, so i thought i would start over so i deleated everything (what a mistake). i was using an older version of software and everything loaded fine and worked fine. this time when i load the software it will not launch, it will just let me unzip it back into the download folder and thats it. the program will not upload and launch like other programs do. when i plug the Arduino uno board into my computer it locates a driver and gives it a com. i have loaded and unloaded the program several times with the same result, nothing. the program will not load and it does not give me the option of assiging a driver. what am i doing wrong ? why won't the program load properly ? has anyone else had this issue and how do i fix it? all i have now is hundreds of dollars of parts and components that i cannot use. does anyone out there have an answer for me ? i really need your help !!!!!!!!!!!!!!!!

do you mean, your installation-program doesnt work or you arduino-ide?!?