Relay 8ch / Nodemcu 8266

Hey!
I'm in a project using the Nodemcu 1.0 and a relay module 8ch.
The idea is simple, I use my Alexa to give orders using Sinric to the Nodemcu/relay 8ch, but my problem is in the relay module
When the order has been received, the red light turns on, but it doesn't do the function of a relay, It does not make the typical sound of the relay
The module isn't the problem, because I used my Arduino Uno and the module works well
So I don't know what to do

Sorry if I have grammatical errors, English isn't my First language

How are you powering the relay module?

Jahg2150:
So I don't know what to do

Tell us what relay module you are using and give a diagram of how you are attempting to connect it. :roll_eyes:

Hi,
What voltage does the output of the NodeMCU output?

Do you have a DMM?

Can you post a picture of your relay board?
Does it have optocoupler and/or transistor drive for the relay coils on the relay PCB?

Thanks.. Tom... :slight_smile:
PS, Are you asking the same question here? Modulo Relay 8 canales - Software - Arduino Forum

Arduinos usually operate at 5V.
The NodeMCU operates at 3.3V.
That may be the cause of your problem.

wvmarle:
Arduinos usually operate at 5V.
The NodeMCU operates at 3.3V.
That may be the cause of your problem.

It is not a problem if it is an active-low relay module which has a LED in series with each optocoupler, connected to 5 V and the ESP running from its standard 3.3 V.

I would use some sort of port expander between a NodeMCU and an 8-relay module.
Not because of the voltage, but because of possible (number of) pin problems.
Leo..

Excellent idea, and the port expanders (PCF8574/ PCF8575) are perfectly suited to the active low relay modules. In particular they default to the relays being off at power up.