replace 1.0 avr with old avr; howto?

Hi I found a suggested solution to the problem of IDE 1.0 hanging during upload, or only allowing one upload before hanging, on my Mega2560:,98691.msg740621.html#msg740621

which suggests replacing the new avr folder with an older one (form 0.22 or 0.23). Inside the Arduino/hardware/tools/avr folder, there are lots of references to "avr" and I don't want to start deleting stuff randomly; has anyone tried this successfully and if so, would you be so kind as to describe the correct process, thanks again. Do I simply replace this entire "avr" folder with the one from 0.22?


Yes, this solution solved my problem with upload issues with IDE 1.0 and 1.0.1 just yesterday (I am on Windows XP). I only replaced two files as was mentioned in the link you referenced. I’ll give a try at a medium level step-by step.

  1. The two files I replaced in my 1.0.1 folder structure are; avrdude.exe and & avrdude.conf. They are located in the following directory or folder trees;
  2. I renamed the existing files instead of deleteing them; avrdude.exe_1.0.1 and avrdude.conf_1.0.1
  3. Download the Arduino 0023 IDE and extract these two files from the zip; avrdude.exe and & avrdude.conf.
  4. Copy these two older files to the respective folder tree locations listed above where you removed or renamed the originals.

That’s it. If you hade the same issue I did you should experience the wonderful sight of “avrdude done. Thank you.” on every upload attempt as I now do. Thanks to Louis for pointing the same link out to me. Note, there are other problems that can cause uploads to fail such as driver related or the infamaous “!!!”, but your description sounds just like the issue I had.

Good luck!

Thank you so much for the speedy reply atheis,

I have a performance/seminar at an international conference in 6 days, so your help is very much appreciated. I downloaded 1.0.1 and gave it a quick test, but no 'serious' stress-testing (serial monitor open, edit sketch, upload without saving, general amateur tinkering etc). I will try your solution the next time uploading fails on me

: )) Brendan