reset web panel password (solved)

greetings.

So, i forgot the webpanel password..

I tried to reset the wireless thingie, and revert it back to AP, so I can enter the "web control panel"

It asks me for the password, but the default one doesn't work.

Resseting the wireless won't change the webpanel password back to default?

The question is:
How can I reset the web panel password?

opkg update  
opkg install coreutils-sha256sum
echo -n arduino | sha256sum
775e9f944188a7bcb36e9ca5dc51672b44bcceeb7d56d89dfb914eb3a1ff2d69

default password is "arduino"
"775e9f944188a7bcb36e9ca5dc51672b44bcceeb7d56d89dfb914eb3a1ff2d69" is sha256 of "arduino"

nano /etc/config/arduino
config arduino
        option password '775e9f944188a7bcb36e9ca5dc51672b44bcceeb7d56d89dfb914eb3a1ff2d69'
...

Re: Enable REST commands from shell command line

It still doesn't work

I changed the root password
I ssh'ed into YUN
I nano'ed into /etc/config/arduino

changed it to

config arduino
        option password '775e9f944188a7bcb36e9ca5dc51672b44bcceeb7d56d89dfb914eb3a1ff2d69'
        option wifi_reset_step 'clear'
        option secure_rest_api 'true'

And when i go to 192.168.240.1 (yun's ip) I get the "welcome to ... please enter your password to access the web control"

And it won't accept arduino as password

reboot

or Power cycling Yun.

tried that, reboot, unplug/plug back in, the password still wouldn't work.

Ended up reverting yun to factory settings.It seems that it works now.

the revert-to-factroy-settings script didn't work, it would flash the wlan led on and off for ever, and nothing happend.

Someone said to use the sbin/firstboot command then restarted the yun, that seems to work.

The web panel password is as same as root password at OS, for some reason Yun's team decide not use PAM api, but UCI api to hold hash sha256 of root password.

if use

passwd

to change root password and web panel password will be out of sync.

echo -n password_of_root | sha256sum
e5ffc0313130aed382ee8883ac779b614ee7dc0927c5fa1784d077f67dcb8eb1

Put that hash into "/etc/config/arduino" should sync it back.