[résolu] Montage emétteur commun: D'ou vient cette valeur?

Bonjour

Voici le schéma suivant:

Je l'ai actuellement créé sur une breadboard.

Voici les paramètres:

Le transistor NPN est un 2n222 (datasheet: http://pdf1.alldatasheet.com/datasheet-pdf/view/5612/MOTOROLA/2N222.html)

Le led, est une led infrarouge (datasheet: http://www.taydaelectronics.com/datasheets/A-1544.pdf)

L'alim d'un voltage de 3.3v peut founir au maximum un courant max de 800ma.

R1 = 150 ohms R2 = 20 ohms

J'aimerais avoir un courant de 100ma dans la led infrarouge.

Pour saturer le transistor, je pense qu'un courant de 20ma est suffisant. Pour cette raison j'ai calculé R1 comme suit: R = U/I = 3.3/0.02 = 165 ohms J'ai mis une 150 ohms, ce qui devrait me donner: I = U/R = 3.3/150 = 22ma. En mesurant avec le multimètre, j'obtient 26ma. Ok

Pour avoir 100ma dans ma led, voici le calcul que j'ai fais:

(Vcc - Vled) / 100ma = (3.3-1.35)/0.1 = 19.5 => 20ohms

Quand je mesure le courant qui traverse la led, je n'ai que 36ma et non 100ma. J'ai donc faux quelque part.. Quelqu'un peut m'aider?

A l'aide du voltmetre, voici ce que je trouve:

Vbe = 0.76v Vr1 = 1.53v Vr2 = 0.92v Vled = 1.31v

Yep!

La valeur de R1 est certainement fausse et le transistor n'est (heureusement) pas saturé.

Sans regarder le datasheet de la led infra (la flemme), je suppose qu'elle peut supporter 100 mA maxi. Mais il faut extremement faire attention à ce qu'elle ne surchauffe pas trop et (je ne me rappelle plus) elle doit être allumé proportionnellement à sa résistance calorifique. Peut être que quelqu'un précisera cet aspect. Le risque : le led grille. 40 mA pour une led c'est déjà pas mal...

Calcul de la résistance du 2n2222.

Ic = 40 mA (courant traversant la led infra, R2=80ohms) hfe du 2n2222 = 100 (appelé aussi Beta, lettre grec)

On calcule Ib, courant de saturation à la base du transistor : Ib = Ic / hfe

Ib = 0,040 / 100 = 0,0004 A (des cahouèttes)

Calcul de la résistance Rb.

U = Ur + Vbe (3.3v = Ur + 0.4) 0.4v corresponde à la chutte de tension classique de transistor. Soit Ur = 3.3 - 0.4 = 2.9v

Comme U = R x I, Ur = Rb x Ib

Remplaçons.

2.9 = Rb x 0.0004, Rb = 2.9 / 0.0004 = 7250 ohms.

Les valeurs courantes sont 1 Kohm et 10 kohm, on prendra 10 kohm (J'ai omis de multiplier hfe par un coef de sécurité)

J'espère ne pas m'être planté, je suis un peu rouillé :grin:

@+

Zoroastre.

PS : Après lecture du datasheet, la led peut travailler à 100 mA :astonished: , R1 = 2900 ohms, R2 = 20 ohms. Le principe de calcul reste le même.

atlas2003: Pour avoir 100ma dans ma led, voici le calcul que j'ai fais:

(Vcc - Vled) / 100ma = (3.3-1.35)/0.1 = 19.5 => 20ohms

En pratique il existe une très faible chute de tension dans le transistor. Une diminution très faible de la résistance en série avec la led devrais faire l'affaire. Mais le courant qui la traverse actuellement est déjà pas mauvais et il faut prendre en compte l'échauffement si elle doit rester allumer sur une longue période.

Première étape lire les bonnes données "typiques" dans les datasheets 1)Transistor -> je suppose que ce n'est pas un 2N222 mais un 2N2222. Beta @ 100mA -> 100 Vce sat@ 100mA -> 0,3V

2) diode Les 100mA sont normalement pulsés, si tu n'as pas d'oscillo tu peux les mettre en continu mais juste le temps de faire la mesure. Vd typ = 1.35 max = 1.6 Min = ?

Calcul de la résistance R2 : La tension appliquée aux bornes de R2 est égale à 3,3 -Vcesat -Vd = 3,3 - 0,3 - 1,35 = 1,65 V Si Id = 100mA alors R2 = 16,5 ohms -> quand tu as calculé R2 tu n'a pas pris en compte le Vcesat du transistor.

Calcul de la résistance R1 Pour être sur de saturer le transistor on considère beta/10 -> c'est ceinture + bretelle. La tension Vbe est équivalente à une diode de signal soit 0,8 V La tension appliquée aux bornes de R1 est égale à 3,3 - 0,8 = 2,5 Volts. si on veut que Ib soit égal à 100mA/(100/10) = 10mA il vient pour R1: R1 = 2.5 /10mA =250 ohms

Ça c'est le calcul théorique. Dans le cas réel les valeurs de Vd, Vcesat et beta vont varier autour de ces valeurs typiques. Une variation de 0,1V du Vcesat aura plus de répercutions avec une alim à 3,3V qu'avec une alim à 5V.

Deuxième étape : Examen de tes mesures : Circuit de collecteur Comme tu n'avais pas pris en compte le Vcesat du transistor c'est normal que tu trouve moins de courant. Néanmoins les résultats ne sont pas cohérents avec 20 ohms le courant est normalement plus faible mais le Vcesat devrait aussi être légèrement inférieur or si je fais le compte des tensions que tu indiques je trouve un Vcesat égal à 3,3 - 0,92 -1,31 = 1,07V ce qui est énorme. Circuit de base Là aussi les résultats me semble incohérents : Vbe = 0,76 VR1 = 1,53 Total = 2,29 V. Où est passé le volt qui manque ? Est-tu certain de tes mesures ?

Il se pourrait bien qu'il y ait une erreur dans le circuit de commande de base et que le transistor n'est pas réellement saturé.

Merci pour ces explications super detaillé. Effectivement, j'ai un volt d'ecart... Je vais retester mon montage (aussi simple qu'il soit)

Et oui, c'est pour être pulsé par la suite. La je laisse en continu le temps de faire mes mesures.

Pour vérifier le montage tu n'es pas obligé d'avoir une diode : tu peux juste brancher une résistance en adaptant sa valeur. R = (Valim - Vcesat)/100mA. La diode sera épargnée le temps de vérifier que tout va comme prévu.

Il y a quelque chose que je ne comprend pas. Mon alim fait bien 3.3v. Je viens de verifier avec un voltmetre (lorsqu'elle n'est pas branché au circuit)

Si je mesure a nouveau lorsqu'elle est connecté au circuit, la tension baisse a 2.25v ?? J'imagine que c'est du a une erreur de montage.. Mais on s'entend que le montage est quand même TRES basique... Je l'ai verifié 25 fois. Est ce que ca peut etre du au transistor qui est mort (je l'ai peut etre cramé lors d'ancien tests?)

Si j'enleve la led du montage, et que je re mesure la tension au borne de vcc, j'obtient cette fois ci non pas 2.25v mais 1.44v.

Je ne comprend pas!

Bonjour 9 chances sur dix que tu en demande de trop à ton alimentation 3,3 V. Met une résistance de 33 ohms (un court instant !), ce qui fait 100mA, aux bornes de ton alimentation en mesurant la tension pour voir si tu as toujours 3,3 V.

Bonne remarque. Elle sort d'où cette alim 3,3V ?

Bonjour

C'est une alimentation de breadboard mb102 que j'ai acheté 2 ou 3$ sur ebay en provenance de chine...

Je viens d'essayer à nouveau avec un simple lm1117 et deux condensateurs. je n'ai effectivement plus de baisse de tension! Et j'obtient un courant de 82ma avec mes valeurs de resistances. Et 86ma avec R1=16 ohms et R2=270 ohms.

Je pense que c'est très correct!

Mon projet réel consiste à contrôler mon air climatiser via internet. J'émule la télécommande de la clim grâce à mon montage. Mon prototype fonctionnait bien mais là, comme je vais faire le circuit imprimé, j'essais d'améliorer la porté IR au passage. je voudrais donc mettre 3 leds infrarouges plutôt qu'une.

J'ai vu sur le schema du "tv be gone", ils alimentent leurs 3 leds / 3 NPN via une seule pin de l'atmega mais il passe par un PNP pour cela. je ne comprend pas pourquoi:

In v1.2 we decided that we really wanted an extra pin to do region detection. We could go back to having one micro pin control all four transistors but the range would suffer so instead we have a PNP transistor that will buffer the weak microcontroller pin and push plenty of current into the bases of the IR driver transistors.

http://learn.adafruit.com/tv-b-gone-kit/design-notes

Est ce que je pourrais faire la meme chose avec un autre NPN qui "feederait" mes 3 autres paire LED/NPN?

qui “feederait”

Quelle horreur ce mot ! C’est les poissons qu’on nourrit !

Principe du fonctionnement :
Le rôle du PNP est de servir d’amplificateur pour éviter de tirer trop de courant sur la sortie de l’arduino.
Tel que le montage est dessiné quand le micro sort un état bas le transistor Q5 est passant et saturé, son collecteur est à Vcc-Vcesat c’est à dire quasiment Vcc soit 5Volts.
Les émetteurs des transistors Q2 à Q4 sont à Vcc. Les transistors sont passants et saturés.
Les colecteurs des transistors Q2 à Q4 sont à Vcesat soit < 0,3Volts, les diodes émettent.

Inconvénients de ce montage :
Si le micro-controleur est déconnecté les diodes émettent en permanence, ce peut être dangereux et si elles sont prévues pour être commandées avec un signal pulsé tant pis pour elles.
Pour la sécurité les diodes ne doivent émettre que si elles reçoivent un signal différent de 0Volts.

Erreur dans ce montage :
Il n’y a aucune résistance dans les bases des transistors Q2 à Q4. Les transistors sont saturés à mort, je rappelle que la saturation c’est quand la tension de base dépasse celle du collecteur et là ça dépasse de plus de 4 volts.
Conséquence directe sur la durée de vie du transistor ET sur son temps de réaction : il ne se coupe plus instantanément il lui faut d’abord évacuer toutes les charges qu’il a accumulé inutilement du fait de la saturation excessive.
PS : je ne parle même pas de l’absence sur le schéma de résistance de limitation de courant dans les diodes.

Remplacement du PNP
Un NPN monté en collecteur commun devrait faire l’affaire.
Un 0V sur sa base le bloque et par conséquence bloque Q2 à Q4 donc pas de courant dans les diodes.
Un montage en collecteur commun est un amplificateur de courant donc aucun stress sur la sortie du micro-controleur.

Autre solution possible :
Si tu peux disposer d’une alim de plus forte tension pour alimenter les diodes IR il y a la solution de la source de courant. Les diodes doivent être mise en série c’est pour cela qu’il faut un voltage plus important, 9Volts serait bien.

Bonjour

Merci enormément pour ces réponses claires et précises.

La solution la plus simple pour moi serait le NPN une nouvelle fois. (quoi que je suis curieux à propos de la source de courant. Je ne connais pas du tout, je vais aller me renseigner) Est ce que le schema donnerait quelque chose comme cela?

Pour les valeurs des resistances, si je reprend les meme caluls, il me faudrait environ 10ma à la base de chaque transistors. Donc il faut 30ma qui traverse R11. Vr11 = Vcc -Vcesat = 3,3 - 0,3 = 3V R11 = 3/0.03 = 100 Ohms

Hummmm, je suis en train de me rendre compte que c'est surement faux mon shema. ll faudrait surement une resistance juste avant le point qui relie les 3 bases des transistors?

Hummmm, je suis en train de me rendre compte que c'est sûrement faux mon schéma

Oui mais pas pour ce que tu pense : tel quel, quand il n'y a rien sur la base de Q4 d’après toi il se passe quoi pour le courant dans les diodes ?

Un indice : gogole ou wikipédia --> montage "émetteur commun" ou "collecteur commun".

mmm

Vbe = 0.7v alors meme quand Q4 n'est pas alimenté, il y a quand meme une différence de potentiel entre mon 3.3v et les Vbe des 3 autres transistors? et par conséquent je devrais de placer la jonction des 3 transistor à la sortie de l'emetteur de Q4 pour etre sur que lorsque Q4 n'a pas de tension appliqué a sa base qu'il y ait 0v sur les 3 autres transistors? J'ai du mal!

Quand la base de Q4 est à 0V ou laissée en l'air le transistor est bloqué. Si le transistor est bloqué "c'est comme si il n'existait pas". Dans ce cas les bases de Q1 à Q3 sont raccordées au Vcc par l'intermédiaire de R11, ces transistors sont donc passants et les diodes IR sont alimentées en permanence.

Dans mon message précédent je t'ai parlé pour Q4 d'un montage EN COLLECTEUR COMMUN. Fait l'effort de te renseigner et tu verra qu'avec le montage en collecteur commun quand la base de Q3 est à 0V ou laissée en l'air les bases de Q1 à Q3 ne sont plus au potentiel de Vcc mais de la masse. Ces transistors sont donc bloqués.

Merci pour ton excellent tuto sur les transistors. J'ai cherché pas mal de cours simplifié mais le tient est de loin le plus simple pour moi.

Est ce que ca parait deja mieux?

Merci, c’est vrai que les tuto du Web sont très souvent plus compliqués. Mais il faut bien se rendre compte que si le transistor monté en interrupteur représente 99% des utilisations sur ce forum, dans la “vraie” vie ce ne doit pas dépasser 5%. Le transistor est surtout employé en amplification analogique ou en commutation digitale haute fréquence et dans ces cas les formules deviennent vite très compliquées.

Schéma :
Oui c’est mieux mais plusieurs remarques:

  1. Il n’y a pas deux transistors parfaitement identiques. Chaque Vbe est différent même s’ils sont très proches.
    Avec les 3 bases reliées ensembles c’est le plus faible Vbe qui imposera la tension, les deux autres transistors seront mal polarisés. Pour un fonctionnement sûr on met une résistance par base. cette remarque est générale on ne met pas davantage des Dels directement en parallèle.

  2. La résistance Ro n’est pas inutile mais ne sert qu’en protection puisque comme tu as pu le lire dans le tuto le transistor en collecteur commun est toujours en régime linéaire : il ne consomme que ce dont il a besoin. Son impédance équivalente est Re=beta*R11, donc le courant sera auto limité. En protection une centaine d’Ohms suffisent.
    Une résistance supplémentaire de 10k entre Ro et la masse ne perturberait pas le montage (consommation 0,33 mA) et permettrait de fixer le potentiel quand interrupteur est ouvert. Il n’est pas recommandé de laisser une entrée en l’air, elle peut capter n’importe quoi.

Ok je pense vraiment comprendre maintenant.

Je n’avais pas compris dans ton tuto, qu’en régime linéaire le transistor prenait seulement ce qu’il avait besoin comme courant. Je laisse quand meme R0 quand meme d’apres ce que tu dis.

Pour les valeurs des résistances, je prendrais:

R0 = 100ohms
R1 = 10k
R11 = 10k
R13 = R14=R15= 250 ohms
R2 = 15 ohms

Est ce que ça parait correcte?

A vu de nez oui sauf pour R11 qui est trop élevée, passe la à 1 K c'est préférable.

Je viens de faire le montage sur une breadboard. J'arrive a 86ma si j'utilise: R13=160 ohms R2=10 ohms

je pense que je peux travailler avec un 86ma.

Je vais pouvoir enfin passer à la suite de mon projet!

merci beaucoup pour TOUTES ces explications.