[résolu] problème avec une Arduino pro micro 32U4 5V et récepteur 433

bonjour,

je suis débutant, est j’ai besoin d’aide…

je suis confronté à un problème avec la réception de fréquence 433, sur une Arduino micro 32U4 5V

j’utilise la librairie RC-Switch, sur une Arduino Uno pas de problème je reçois bien les infos, mais sur la micro rien…

j’ai cru comprendre après quelques recherches que le port interrupt n’est pas le même que sur les Uno voir ici:

https://www.arduino.cc/reference/en/language/functions/external-interrupts/attachinterrupt/

j’ai donc changer ma pinINPUT = 2 en 3 mais toujours rien,

voila mon code: example simple demo rc-switch

#include <RCSwitch.h>

RCSwitch mySwitch = RCSwitch();

void setup() {
  Serial.begin(9600);
  mySwitch.enableReceive(0);  // Receiver on interrupt 0 => that is pin #2 ou pin 3 sur micro 32U4
}

void loop() {
  if (mySwitch.available()) {
    
    int value = mySwitch.getReceivedValue();
    
    if (value == 0) {
      Serial.print("Unknown encoding");
    } else {
      Serial.print("Received ");
      Serial.print( mySwitch.getReceivedValue() );
      Serial.print(" / ");
      Serial.print( mySwitch.getReceivedBitlength() );
      Serial.print("bit ");
      Serial.print("Protocol: ");
      Serial.println( mySwitch.getReceivedProtocol() );
    }

    mySwitch.resetAvailable();
  }
}

voila ou j’en suis, me manque t’il quelque chose avant mon setup pour définir la pin interrupt ?

en attendant merci,

Mario.

Bonjour, Sur l'arduino micro l'interruption int0 est bien sur la pin 3.

Avez vous bien sélectionné cette carte dans le gestionnaire de l'IDE?

bonjour, merci pour votre intérêt,

oui, j'ai bien choisi micro dans IDE...

et j'ai également tester mon récepteur sur une Uno pour voir si je ne l'aurai pas "grillé" lors de mes manipulation...

Il ya d'autres interruptions sur le micro, INT1,INT2,INT3

Un essai permettra peut être de voir s'il n'y a pas un problème avec le Int0.

bon après plusieurs essais, le problème venait de l'IDE qui plante (sans planter clairement) sur mac osx10.13.1

merci quand meme.