[Résolu]Taille des caractères des menus d'Arduino trop petite !

Bonjour,

Après plusieurs recherches, je ne trouve pas de solution à mon problème.

La taille des caractères des menus d’Arduino est trop petite, voire une copie d’écran en pièce jointe

Je suis sous Linux Kubuntu 12.04 64 bits et comme version Java, j’ai (~$ java -version ) :

java version “1.6.0_27”
OpenJDK Runtime Environment (IcedTea6 1.12.5) (6b27-1.12.5-0ubuntu0.12.04.1)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

En seconde pièce jointe, un fichier texte brut de la liste des paquets touchants au Java qui sont installés dans mon système (au cas ou).

Une aide charitable serait grandement appréciée !

L’ami René

aptitude search java.txt (236 KB)

Regarde dans ton home le répertoire caché .arduino il y a un fichier preference.txt tu l'ouvres avec ton éditeur préféré et tu cherches une ligne commençant par editor.font (ne pas confondre avec editor.font.macosx). Là tu mets la police que tu veux dans le corps que tu veux. Et tu vas voir qu'il y a plein d'autres options auxquels tu n'avais peut être pas pensé.

Bonjour âme charitable fdufnews,

Merci pour votre aide !

J’ai changé la ligne :

editor.font=Monospaced,plain,12

Pour la ligne :

editor.font=Monospaced,plain,24

Enregistrer et fermer le fichier et démarrer Arduino.

Mais ça n’a aucun effet sur la taille de police de caractère des menus, mais seulement sur la taille des caractères de la fenêtre d’édition du code source d’Arduino (voir ma copie d’écran en pièce jointe). Les menus sont toujours minuscules et illisibles.

J’ai regardé les autres paramètres dans le fichier « ~/.Arduino/preferences.txt », mais je n’ai rien trouvé en rapport avec les menus, etc.

Si vous avez une autre piste de solution, je suis preneur.

Merci encore !

L’ami René

Mais ça n'a aucun effet sur la taille de police de caractère des menus

Je me suis trompé.

Je suis sur Ubuntu même version java que toi et mes menus ont une police plutôt grosse bizarre!!!

Je viens de vérifier et par contre moi je suis toujours en version 1.0 de l'IDE

Rebonjour fdufnews,

J'ai le même problème, que cela soit avec la version 1.0, 1.05 et 1.5.2 de Arduino.

Si vous avez une autre piste de solution, je suis preneur.

Merci de l'aide !

L'ami René

Bonjour,

ça ressemble à un problème qui existait avec GTK, essaye d'installer les polices avec la commande suivante :

sudo apt-get install xfonts-75dpi-transcoded xfonts-100dpi-transcoded

et redémarre le serveur X ou la machine au cas où...

Bonjour DrWaX,

Voici donc une autre âme charitable !

Votre solution ne résout pas le problème, mais cela ressemble à la bonne piste à suivre.

Avec votre commande, il y a deux tailles de police de caractère, mais comment le système d’exploitation sélectionne-t-il la taille entre 75dpi et 100dpi. Où et comment configurer ce choix ? Je cherche de mon côté, mais si vous avez la solution, cela serait apprécié !

Un détail que je n’avais pas mentionné, c’est que je suis avec une résolution d’affichage de 1920x1080.

D’ailleurs, j’ai de minuscules tailles de caractère dans le système, mais seulement à l’écran de connexion au démarrage de Kubuntu.

Merci DrWaX !

L’ami René

Rebonjour,

Je viens d'ajouter le paquet « xfonts-100dpi » avec Synaptic et redémarré l'ordinateur, mais sans résultat.

Je poursuis ma recherche...

L'ami René

Bonjour, meme probleme sous Windows 7 sur un portable 16" 1920x1080. Les messages d'erreurs sont illisibles. Je dois utiliser un ecran 22" meme resolution pour pouvoir lire, mais avec difficultes, des caracteres rouges sur un fond noir il faut le faire.

Rebonjour,

Du côté de la Lumière ("Linux"), je plaisante :P, il y a une curiosité !

La zone d'ombre est que dans « Configuration -> Apparence des applications -> Styles et Polices GTK+ -> Polices GTK+ -> Utiliser une autre police », le changement du style de la police de caractère à un effet sur mes menus de l'IDE d'Arduino, mais que le changement de taille des caractères reste minuscule (aucun changement de taille), même si je mais la taille à 72 ou à 128 !?!

Bizarre bizarre !

L'ami René

Bonjour,

peut-être au niveau des paramètres d'affichage des applications Java :

https://wiki.archlinux.org/index.php/Java_Runtime_Environment_Fonts

et

https://wiki.archlinux.org/index.php/Java#Tips_and_tricks

Bonjour DrWaX,

Un grand merci pour votre aide !

Je ne suis pas anglophone, mais j'utilise Google pour traduire les textes anglais. Au meilleur de ma compréhension du texte de la page « Java_Runtime_Environment_Fonts », j'ai procédé aux modifications des fichiers indiqués, mais sans succès, et seul je n'arrive à rien. Est-ce que vous auriez la générosité de m'aider une coche de plus pour la configuration du ou des fichiers à modifier ?

D'en l'affirmative, voici en résumé la situation de mon système :

Linux Kubuntu 12.04 64 bits avec Arduino et le Java :

~$ java -version
Picked up _JAVA_OPTIONS: -Dawt.useSystemAAFontSettings=on -Dswing.aatext=true -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel
java version "1.6.0_27"
OpenJDK Runtime Environment (IcedTea6 1.12.5) (6b27-1.12.5-0ubuntu0.12.04.1)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

J'avais installé la version standard 'Arduino disponible dans ma distribution « Arduino : 1:1.0+dfsg-9 (precis) », mais dû au problème de la police de caractère des menus de l'IDE, j'ai essayé l'archive de la dernière version téléchargeable « arduino-1.5.2-linux64.tgz ».

Sans bon résultat dans mon "Home", j'ai remplacé le contenu de la version 1.0 du dossier « /usr/share/arduino » par la version 1.5.2 de mon dossier "Home" et c'est dans ce dossier que j'ai essayé les modifications du fichier « /usr/share/arduino/arduino» avec les conseils de la page « Java_Runtime_Environment_Fonts », mais sans succès.

Voici le contenu de la version originale de ce fichier qui est mon actuelle configuration :

#!/bin/sh

APPDIR="$(dirname -- "$(readlink -f -- "${0}")" )"

cd "$APPDIR"

for LIB in \
    java/lib/rt.jar \
    java/lib/tools.jar \
    lib/*.jar \
    ;
do
    CLASSPATH="${CLASSPATH}:${LIB}"
done
export CLASSPATH

LD_LIBRARY_PATH=`pwd`/lib${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
export LD_LIBRARY_PATH

export PATH="${APPDIR}/java/bin:${PATH}"

java -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel processing.app.Base "$@"

Pourriez-vous procéder à sa modification selon vos connaissances et me coller dans votre réponse l'ensemble du fichier modifié ?

D'avance un grand merci si cela vous est possible !

L'ami René

Malheureusement, je ne vais pas pouvoir être d’une plus grande utilité, ce sont seulement des pistes que j’ai évoquées, je ne suis pas en mesure de donner un réponse ferme et définitive sur la bonne solution à appliquer.

Avez vous bien modifier le fichier .bashrc avec les variables d’environnement de JAVA comme indiqué ?

Il y a ceci sur un des liens que t'as donné DrWaX

 Fonts are Illegible

In addition to the suggestions mentioned below in #Better_font_rendering some fonts may still not be legible afterwards. If this is the case there is a good chance ms-fonts are being used. Install ttf-ms-fonts from the AUR.

Et j'ai vérifié sur ma conf j'ai les polices ms-fonts d'installées. Sur Ubuntu la paquet s'appelle ttf-mscorefonts-installer.

Bonjour DrWaX et fdufnews,

Merci de prendre le temps de m’aider !

DrWaX:

Avez vous bien modifier le fichier .bashrc avec les variables d’environnement de JAVA comme indiqué ?

Oui et non ! J’ai modifié ce fichier, mais est-ce que cela était de la bonne manière ?

Ce fichier dans mon “home”, contient ceci :

export JAVA_FONTS=/usr/share/fonts/truetype
export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=on -Dswing.aatext=true -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel'

fdufnews, pour ce qui est de du paquet « ttf-mscorefonts-installer », il est déjà installé dans mon système.

Et comme indiqué dans la section « Fonts are Illegible » et « Tips and tricks », au meilleur de ma compréhension, j’ai fait ces modifications :

Dans le fichier « /etc/profile.d/jre.sh », j’ai remplacé la ligne :

export _JAVA_OPTIONS='swing.crossplatformlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel'

Par la ligne :

export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=on -Dswing.aatext=true -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel'

Mais pour les indications de la section « Better font rendering » et « GTKLookAndFeel », je ne sais pas dans quel fichier et quelle ligne modifier :

[b]Better font rendering[/b]

Both closed source and open source implementations of Java are known to have improperly implemented anti-aliasing of fonts. This can be fixed with the following options: awt.useSystemAAFontSettings=on, swing.aatext=true GTK LookAndFeel

If your Java programs look ugly, you may want to set up the default look and feel for the swing components: swing.defaultlaf=com.sun.java.swing.plaf.gtk.

[b]GTKLookAndFeel.[/b]

Some stubborn Java programs insist on using the cross platform Metal look and feel. In some of these cases you can force these apps to use the GTK look and feel by setting the following property:

swing.crossplatformlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel.

Si vous pouviez me fournir le contenu de vos fichiers de configuration, que j’adapterais au besoin, cela pourrait m’être utile.

Merci d’avance pour toute initiative de votre part.

L’ami René

Rebonjour à tous,

Après 2 semaines recherches et essais de solution, je ne trouve pas de remède à mon problème.

Pour rappel, mon ordinateur à comme écran un téléviseur 42" avec une résolution de 1920x1080 et mon Linux Kubuntu 12.04 64 bits est configuré en conséquence pour les tailles des caractères et tout s’affiche correctement, sauf dans un cas de figure.

J’ai un problème avec les interfaces faites en Java qui ont une police de caractère trop petite (microscopique) ! Cela concerne uniquement la taille des caractères des menus et leur contenu, par exemple dans les interfaces de l’IDE d’Arduino et de Processing qui sont écrites en langage Java, voire la nouvelle copie d’écran en pièce jointe.

C’est aussi le cas avec l’extension ArduBlock.

Notez que je suis unilingue francophone, ce qui n’aide pas, car ma compréhension limitée des solutions sur le Web que j’ai trouvé sont presque uniquement en anglais et j’ai peut-être loupé un détail ou une subtilité avec Google et sa traduction vers le français.

L’aide d’une âme charitable serait grandement appréciée, car je suis vraiment bloqué !

Merci d’avance !

L’ami René

Bonjour,

Un bon génie de la lampe est passé chez moi !

Avant :

Hé oui, le problème est résolut.

Pour corriger un problème de police de caractère trop petit dans l’écran d’accueil (écran du Login) ou dans les applications écrite en langage Java, il faut modifier le fichier « /etc/X11/xorg.conf » pour qu’il reflète les mêmes valeurs que ce qui est configuré dans le panneau de configuration « Configuration → Apparence des applications → Polices → Forcer le PPP des polices : XX ».

Chez moi cela donne :

« Configuration → Apparence des applications → Polices → Forcer le PPP des polices : 96 ».

Ce “96” est à retenir pour la suite de la solution.

Donc, dans le fichier « /etc/X11/xorg.conf », dans « Section “Device” », ajouter à la fin les deux lignes suivantes en les adaptent à votre configuration :

    Option         "UseEdidDpi" "False"
    Option         "DPI" "XX x XX"

Chez moi, je passe de :

Section "Device"
    Identifier         "Device0"
    Driver              "nvidia"
    VendorName   "NVIDIA Corporation"
    BoardName     "GeForce GTX 560 Ti"
EndSection

Avec mon “96”, je passe à :

Section "Device"
    Identifier        "Device0"
    Driver             "nvidia"
    VendorName  "NVIDIA Corporation"
    BoardName    "GeForce GTX 560 Ti"
    Option            "UseEdidDpi" "False"
    Option             "DPI" "96 x 96"
EndSection

Un redémarrage de l’ordinateur et le tour est joué !

Voire pièces jointes, pour le avant et le après solution.

Bravo et encore merci à Frédéric Côté, sans son aide, je ne m’en sortais pas !

L’ami René
P.-S.: Un prochain reconnaissant !

Taille des caractères des menus d'Arduino trop petite[Résolu].jpg