[RESOLU] Utilisation du module Grove - MP3 v2.0 ?

C'est Normal pour du code d'avoir des grands cadres

Pour votre librairie allez enlever le -master à la fin du nom du répertoire - c'est une ancienne convention pour les librairies mais pas adapté pour l'IDE aujourd'hui - mais dans votre cas ça ne suffira pas, pour simplifier l'idéal c'est que le répertoire ait le même nom que la librairie qu'on inclut (sans le .h) donc appelez le répertoire MP3Player_KT403A et redémarrez votre IDE

SoftwareSerial mp3(2, 3); ça veut dire utiliser un objet qui va simuler un port série en software. si vous reprenez juste l'exemple qui est dans la bibliothèque et que vous branchez les pins 2 au Tx du module et la 3 vers le Rx du module vous avez déclaré une variable de type port série simulé, appelée mp3 et parlant au module.

la librairie est codée en dur pour avoir une variable mp3 de type SoftwareSerial ce qui n'est pas une super idée... vu que vous avez un mega, vous devriez modifier le .h

//#include // <-- commenter
//extern SoftwareSerial mp3; // <-- commenter

extern HardwareSerial mp3; // <-- redéfinir comme cela

la doc est ici vous y verrez l'usage SoftwareSerial(rxPin, txPin) => rxPin c'est la Pin qui va recevoir des données (à connecter donc au Tx de l'autre côté) et la txPin est celle qui va emetttre (à connecter donc au Rx de l'autre côté).

avez vous ecrit un bout de code? Postez le et décrivez comment sont branchés les éléments on vous guidera

Voici un bout de code à tester - je n'ai pas le module donc je me suis simplement inspiré de l'exemple disponible.

Connectez votre shield MP3 de la façon suivante à votre MEGA

  1. vérifiez bien que le module que vous avez est en 5V
  2. vérifiez bien aussi que sur votre module les pins du modules Gnd, Vcc, Rx et Tx sont bien comme cela:

|331x500

  1. connectez au méga |500x294

Mettez la vitesse en baud de l'interface Série de l'IDE à 115200 bauds (le popup en bas de la fenêtre), une carte SD dans le lecteur avec des fichiers. Je pense qu'ils seront joués dans l'ordre d'ajout sur la carte SD.

// on inclut la librairie adaptée
#include 

// l'arduino Mega dispo de plusieurs port séries matériels
// Serial: 0 (RX) and 1 (TX); le port Serial est connecté à l'USB qui va à l'ordinateur
// Serial 1: 19 (RX) and 18 (TX);
// Serial 2: 17 (RX) and 16 (TX);
// Serial 3: 15 (RX) and 14 (TX).
// (RX) c'est pour recevoir et (TX) transmettre des données séries TTL

// dans cet exemple je vais utiliser Serial1, donc les pin 19 pour Rx et 18 pour Tx
// la pin 19 du Mega sera donc connecté au Tx du module Grove
// la pin 18 du Mega sera donc connecté au Rx du module Grove

// modifier le MP3Player_KT403A.h de la librairie  pour avoir au début la variable mp3 en port hardware, pas softwareSerial
//   // #include // <-- commenter
//   // extern SoftwareSerial mp3; // <-- commenter
//   extern HardwareSerial mp3; // <-- redéfinir comme cela

HardwareSerial mp3 = Serial1; // la librairie attend une variable mp3.

void setup()
{
  // On parlera avec l'ordinateur à 115200 bauds, mettre la console à cette vitesse
  Serial.begin(115200);

  // le module grove est configré pour discuter à 9600 bauds, donc c'est la vitesse que l'on choisit
  mp3.begin(9600);

  // petit délai pour s'assurer que tout s'initialise bien
  delay(100);

  // On configure la libraire pour utiliser la carte SD
  SelectPlayerDevice(0x02);

  // On met le volume à 15, les valeurs admissibles sont entre 0 et 30
  SetVolume(15);

  Serial.println(F("------ Commmandes ------"));
  Serial.println(F("J\tJouer #1"));
  Serial.println(F("P\tPause"));
  Serial.println(F("C\tContinuer"));
  Serial.println(F(">\tSuivante"));
  Serial.println(F("<\tPrecedente"));
  Serial.println(F("B\tboucle sur toutes les chansons"));
  Serial.println(F("+\tAugmente le volume"));
  Serial.println(F("-\tDiminue le volume"));
  Serial.println(F("------------------------"));
}



void loop()
{
  int caractereRecu = 0;

  // On attend un ordre sur le port Série (à travers la console Série de l'IDE)
  while (Serial.available());
  caractereRecu = Serial.read();

  switch ((char) caractereRecu)
  {
    case 'j':
    case 'J':
      SpecifyMusicPlay(1); // index de la chanson entre 0 et 65535 (unsigned int - uint16_t)
      Serial.println("J");
      break;
    case 'p':
    case 'P':
      PlayPause();
      Serial.println("P");
      break;
    case 'c':
    case 'C':
      PlayResume();
      Serial.println("C");
      break;
    case '>':
      PlayNext();
      Serial.println(">");
      break;
    case '<':
      PlayPrevious();
      Serial.println("<");
      break;
    case 'b':
    case 'B':
      PlayLoop();
      Serial.println("B");
      break;
    case '+':
      IncreaseVolume();
      Serial.println("+");
      break;
    case '-':
      DecreaseVolume();
      Serial.println("-");
      break;
  }
  // éventuellement on affiche ce que nous dit le module mp3
  printReturnedData();
}

voilà, normalement vous tapez dans la console série de l'IDE des commande J par exemple pour commencer à jouer la première chanson, > pour passer à celle suivante etc... Vous pouvez valider après chaque entrée mais si vous tapez plusieurs commandes à la suite, elles seront gérées correctement. par exemple si vous tapez +++ vous allez augmenter 3 fois le son.

Bonsoir, Merci pour vos messages...

Au niveau des codes que j'ai essayé, c'est seuelement des copies de ce site : https://github.com/Seeed-Studio/Grove_Serial_MP3_Player_V2.0

Sinon, je viens d'essayer les 2 codes proposés mais ils engendrent tous les 2 des erreurs :

Pour le premier code (Posted by J-M-L - Today at 09:44 am)

SoftwareSerial mp3(2, 3);

--> 'SoftwareSerial' does not name a type

Pour le second code (Posted by J-M-L - Today at 11:52 am)

 HardwareSerial mp3 = Serial1; // la librairie attend une variable mp3.

--> conflicting declaration 'HardwareSerial mp3'

J'avoue que c'est du chinois pour moi... et que je n'ai aucune idée du problème...

Sinon, indépendamment de cela, j'ai un problème de formatage de ma carte SD (en FAT32) : quand j'insère la carte dans le module, la petite LED verte ne s'allume pas (alors qu'avec la SD de mon téléphoné portable, formatée en FAT, ça s'allume..., mais j'ai des données dedans et je ne compte pas la formater, c'était juste pour essayer...).

Par ailleurs, j'ai une autre piste en attente : j'utilise l'Arduiblock de chez DuinoEdu et je viens d'apprendre que le bloc pour le module Grove-MP3-v2.0 arrive dans leur prochaine version d'Arduino Augmenté... mais je ne sais pas quand ça va sortir... d'ici là, j'aimerai bien arriver à un résultat avec la programmation en ligne de code... histoire d'apprendre à me débrouiller...

Merci encore pour votre aide !

--> conflicting declaration 'HardwareSerial mp3'

Avez vous effectué les modifications demandées sur la librairie?

--> changez de nom --> modifier le code de la librairie

comme expliqué dans #7

Pour votre librairie allez enlever le -master à la fin du nom du répertoire - c'est une ancienne convention pour les librairies mais pas adapté pour l'IDE aujourd'hui - mais dans votre cas ça ne suffira pas, pour simplifier l'idéal c'est que le répertoire ait le même nom que la librairie qu'on inclut (sans le .h) donc appelez le répertoire MP3Player_KT403A et redémarrez votre IDE

SoftwareSerial mp3(2, 3); ça veut dire utiliser un objet qui va simuler un port série en software. si vous reprenez juste l'exemple qui est dans la bibliothèque et que vous branchez les pins 2 au Tx du module et la 3 vers le Rx du module vous avez déclaré une variable de type port série simulé, appelée mp3 et parlant au module.

la librairie est codée en dur pour avoir une variable mp3 de type SoftwareSerial ce qui n'est pas une super idée... vu que vous avez un mega, vous devriez modifier le .h

//[s]#include [/s]// <-- commenter ou détruire
//[s]extern SoftwareSerial mp3;[/s] // <-- commenter ou détruire

extern HardwareSerial mp3; // <-- redéfinir comme cela

Ca y est, j'ai fini par réussir ! Premièrement, ma carte était mal formatée (j'ai utilisé un 3ème PC en choisissant FAT32 pour que ça marche, alors qu'avec les mêmes paramètres, ça ne donnait rien avec ma SD...) Deuxièmement, le problème venait de SoftwareSerial mp3(19,18); et non SoftwareSerial mp3(18,19);

Voici le code utilisé :

#include 

boolean __ardublockDigitalRead(int pinNumber)
{
  pinMode(pinNumber, INPUT);
  return digitalRead(pinNumber);
}


SoftwareSerial mp3(19,18);

void setup()
{
  pinMode( 2 , INPUT);
  pinMode( 4 , OUTPUT);
  mp3.begin(9600);
  delay(100);

  SelectPlayerDevice(0x02);       // Select SD card as the player device.
}

void loop()
{
  if (!__ardublockDigitalRead(2))
  {
    digitalWrite(4 , HIGH);
    SetVolume(500);
    SpecifyMusicPlay(1);
  }
}

J'utilise un bouton physique pour déclencher le son

Reste à résoudre mon problème de haut-parleur. Merci infiniment pour votre aide !!!

super - pour le haut parleur si j'étais vous je laisserai tomber le truc grove et j'achèterai sur Amazon le moins cher des haut parleur avec entrée Jack audio et une alimentation USB

par exemple si vous cherchez sur Amazon "Haut-parleur Enceinte Portable Rechargeable Hamburger Stéréo Net Usb Pc Subwoofer Dédié" ça vaut 3,19 euros avec livraison gratuite en france métropolitaine... (ou d'autres il y en a pleins sous 5€) et vous avez une carte avec entrée ligne - directement compatible avec la sortie de votre Grove MP3

vous enlevez la coque en plastique, regardez où arrive l'alim USB (ça prend juste 2 des pins de l'USB pour le 5V et la masse, donc vous avez ça sur votre Mega) et vous connectez le jack dans votre module MP3 et voilà.... et vous pouvez même récupérer le circuit de charge de la batterie et la batterie pour le bouquin peut être

Petites précision pour ceux que le sujet intéresse :

Mon problème de carte SD qui ne s'allumait pas (et que je croyais ne pas être reconnu ou mal formatée) était finalement dû au fait que les fichiers wma placés sur la carte ne sont pas reconnus. Dès que j'ai ajouté un fichier MP3 sur la carte, la LED verte s'est allumée sur le module !

Pourtant, sur la doc, il est dit que le format WMA est reconnu... mystère pour moi.

Et si il y a 50 fichiers non audio sur la carte SD, le premier fichier MP3 placé sur la carte est considéré comme étant l'index n°1 (SpecifyMusicPlay(1); )

Je vous tiens au courant pour le haut-parleur... (et l'idée de J-M-L) Merci encore

J'ai acheté la mini enceinte cité plus haut, c'est impeccable, je l'ai démonté, j'ai retiré la batterie et j'ai relié le 5v de la carte Arduino là où était la batterie (car alimenter sur le + et - indiqué sur le circuit ne fonctionne pas, ça met en charge la mini enceinte sans pouvoir l'utiliser). Ensuite, j'ai branché le mini jack à la carte Grove MP3 et le son est satisfaisant pour mon utilisation. Merci encore pour votre aide.

Super news :)

Bonjour à tous,

Je suis nouveau sur le forum et débutant en arduino. J'avais un problême similaire avec le lecteur grove mp3. Pas tout à fait le même, mais en lisant vos explications claires j'ai réussi à mieux comprendre le fonctionnement. J'ai donc résolu mon problème de com .

Je vous remercie donc pour vos explications et vos indications qui m'ont bien aidé !

Olivier

Super - merci d'avoir commenté

Je travaile aussi sur ce module et du coup j'ai une question:

comment on fait pour allumer le mp3 sans appuyer sur un bouton.

Ma piste serais de coder de façon à ce que lorsqu'une pine est High il s'allume mais mon code ne fonctionne pas.

Et sinon j'ai testé aussi de l'allumer des l'initialisation et ca ne marche pas non plus:

include

include

// Note: You must define a SoftwareSerial class object that the name must be mp3, // but you can change the pin number according to the actual situation. SoftwareSerial mp3(6, 7);

void setup() { mp3.begin(9600); Serial.begin(9600); delay(100);

if(Serial.available()){ PlayLoop(); }

SelectPlayerDevice(0x02); // Select SD card as the player device. SetVolume(0x1E); // Set the volume, the range is 0x00 to 0x1E. }

void loop(){}

Votre PlayLoop dépend de s'il y a quelque chose en attente sur le port série - et vous le faites avant le SelectPlayerDevice / SetVolume

Il faut d'abord initialiser proprement le module puis lancer la commande le lecture

Merci beaucoup de la réponse et du coup maintenant ça fonctionne mais ça s'arrête au bout de 2 ou 3 secondes...

include

include

// Note: You must define a SoftwareSerial class object that the name must be mp3, // but you can change the pin number according to the actual situation. SoftwareSerial mp3(6, 7);

void setup() { mp3.begin(9600); Serial.begin(9600); delay(100);

SelectPlayerDevice(0x02); // Select SD card as the player device. SetVolume(0x1E); // Set the volume, the range is 0x00 to 0x1E.

if(Serial.available()){ PlayLoop(); } }

void loop(){ }

J'ai testé ca sinon et ça ne marche pluss :/

void setup() { mp3.begin(9600); delay(100);

SelectPlayerDevice(0x02); // Select SD card as the player device. SetVolume(0x1E); // Set the volume, the range is 0x00 to 0x1E.

if(mp3.available()){ PlayLoop(); } }

void loop(){}

Je n'ai pas le module mais ne faut-il pas d'abord choisir un numéro de playlist? Genre avec un SpecifyMusicPlay(1);

Appeler mp3.available() n'est sans doute pas une bonne idée ...

Je sais pas je n'y arrive vraiment pas je crois que ce module ne s'active qu'en communiquant avec le moniteur.

J'ai essayé plusieurs bidouillages mais ils sont infructueux...

Quel arduino avez vous, comment tout est connecté, alimenté etc?

c'est bon c'est regléééééééé, enfait ce module est un peu bizarre. Enfait j'avais mis des if en trop dans le code, en tout cas merci de votre réactivité !!

Bonjour à Tous, Je déterre ce topic après plus de 6 mois, et surtout après plusieurs jours de "pateaugeage"...

Après avoir reçu mon Grove MP3 v2.0, j'ai tout d'abord modifié la librairie pour me passer du softwareSerial comme lumineusement expliqué ici (j'utilise un Mega). Voici ce que ça donne :

#ifndef __MP3PLAYER_KT403A_H__
#define __MP3PLAYER_KT403A_H__


//#include 

//extern SoftwareSerial mp3;

extern HardwareSerial mp3;

void SelectPlayerDevice(uint8_t device);
void SpecifyMusicPlay(uint16_t index);
void SpecifyfolderPlay(uint8_t folder, uint8_t index);
void PlayPause(void);
void PlayResume(void);
void PlayNext(void);
void PlayPrevious(void);
void PlayLoop(void);
void SetVolume(uint8_t volume);
void IncreaseVolume(void);
void DecreaseVolume(void);
uint8_t QueryPlayStatus(void);
void printReturnedData(void);


#endif

Je l'ai éditée en utilisant Wordpad, pour garder une mise en page lisible.

J'ai ensuite formaté une MicroSD 4Go en FAT32 et rangé dessus une petite dizaine de fichiers mp3. Ces fichiers sont parfaitement lisibles sur Windows.

j'ai dans un premier temps testé sans succès le sketch de ce topic. Pour plus de visibilité (l'empilage de dialogues en liaison série me perturbant, vu mon grand âge), j'ai écrit un sketch basé sur un switch / case scrutant le signal ana d'un potentiomètre.

Je passe de case en case après dépassement en + puis en - de 2 valeurs "distantes" pour éviter les aléas (comme >800/1023 et 400/1023). 2 cases en sens + envoient chacun à leur tour une ligne de commande de la librairie modifiée. je surveille aussi avec le moniteur série l'état du graphe (switch). je vois nettement la LED de TX clignoter à chaque case en +. j'ai bien entendu sélectionné la lecture sur SD ainsi que le volume moyen en setup. Voici le sketch :

#include 
HardwareSerial mp3 = Serial3; // la librairie attend une variable mp3.
    int lecteur = 0;
    int potar = 0;

void setup()
{   mp3.begin(9600);
    Serial.begin(9600); 
    delay(100);
    
    SelectPlayerDevice(0x02);       // Select SD card as the player device.
    SetVolume(0x0E);                // Set the volume, the range is 0x00 to 0x1E.
}

void loop()
{
   potar = analogRead(A0);

   switch (lecteur)  {

    case 0 :
    if (potar > 700)
    {Serial.println("Play 1");
    SpecifyMusicPlay(1); 
    delay(500);
    printReturnedData();
    lecteur = 1;  }
    break;

    case 1 :
    if (potar < 400)
    {//Serial.println("2");
    lecteur = 2;}
    break;

    case 2 :
    if (potar > 700)
    {Serial.println("Play 2");
    SpecifyMusicPlay(2);
    delay(500);
    printReturnedData();
    lecteur = 3;  }
    break;

    case 3 :
    if (potar < 400)
    { lecteur = 0; }
    break;    
   }
   

}

Problème : aucune réaction du Grove, malgré la LED verte allumée (carte SD ready) avec un casque stéréo branché dessus. Côté audio tout est OK car j'entends un petit "tic" à la mise sous tension du Grove.

Ne pouvant lire le flux entrant dans le Grove, j'ai connecté sur le premier Mega un second Mega en lieu et place du Grove, et écrit un sketch d'écoute et d'affichage sur le moniteur du flux reçu

Tout d'abord en string complète avec détection de nouvelle ligne, puis caractère par caractère.

C'est le calme plat ... en string : le blanc éblouissant, et caractères : une cascade de "-1", caractère Ascii nul.

Force est de constater que les commandes élaborées par la bibliothèque ne passent pas.

Aurais-je raté quelque chose ??? Merci d'avance pour votre aide !!!