[resolved] Arduino SMD R2 no tx

I am having problems with my arduino SMD R2. I just got it and it's my first so maybe Im doing something wrong.

When I got it it was not detected as a serial device in linux and it wouldn't work in windows either. I read about updatind the dfu and I did that.

The instruction on the website are wrong. After triggering the reset pin it says do: dfu-programmer at90usb82 flash Arduino-usbserial-uno.hex That does not work and makes no sense, I did the following: dfu-programmer atmega8u2 Arduino-usbserial-uno.hex (of course I did erase first and then reset)

Since I have done that now the serial device shows up in linux as ttyACM0

The problem still: When I send a sketch to it the RX light on the board blinks but the TX does not, and avrdude gives me stk500_recv() error.

Loop back test passed, both leds blink and I get my messages exhoed back.

When I first opened the box I tried to push the reset button to see what would happen (it was plugged in of course!) and nothing happened.

Now it still does nothing and as I understand at least L should light up...

So what I think is that I got a board that originally had no dfu on the 8u2. Is it possible it also doesnt have a bootloader? I really hope its something simpler than that. I don't really have time to send this board back. It's my only board so I can't do ISP with an other board :S

:(

If it passes the loop-back test and upload fails can be caused by:

  • issues with auto-reset / defective auto-reset (there was some discussion on the forum about that and using a diode to fix it)
  • missing or corrupt bootloader
  • defective microcontroller

Thanks for your reply. I guess my fears will be / are confirmed.

I have tried running avrdude on the command line with a python script in front of it that I found on the forums. It's supposed to manually reset the arduino before uploading the sketch. I also tried manually resetting it momentarily just before uploading the sketch, several times. So now its down to a bootloader or dead chip. Hopefully I can get it replaced if it's a dead chip.

But before that I will be driving some 100km to pick up an uno R3, and I will try to use that to revive this one before returning it. Im having some horrible luck with hardware this week so far...

Oh well. It will be nice to have two anyways, in case you nuke the bootloader. and I wanted the removable chip ability anyways. Not a big fan of the smd thing either but my kit came with it because of r3 shortage.

I'll let you know how the programming goes.

Actually I just read your signature. Do you still need an ISP if you have two arduinos? :D

You can live with a 2nd arduino, but do you always want to change it to be a programmer? AVR programmers like usbtiny / usbasp are way cheaper than a real arduino board. On ebay you can find clones for less than 10$. I know what I would do ;-)

And if it should turn out that the AVR is dead, don't throw the board away. Someone who is reasonably skilled with soldering can easily replace that chip.

Yea, I’ll buy one eventually. For now I’ll have two boards. Got an uno R3 for $45. Overpriced but thats what you get for using a brick and mortar store…

I did the ISP thing. I reflashed the broken uno with the new one. Now it behaves normally, and when I press the reset button the L led flashes!
So it did not come with a bootloader or a dfu…

Still I cannot load sketches to it, the new one works fine though.
I think either the 8u2 chip is defective, or for some reason the rx trace doesn’t come alive (maybe bad solder joint?). I’ll try getting it replaced as trying
to solder an smd will get real messy and if that doesn’t work then I will have no way to rma it anymore… Thanks a lot for all the help though :smiley:

Just as a side node. Problem kept me awake. I used a very small pin to rework the solder on one of the connections on the 328p (pin 31, the tx pin).

After this when uploading a serial output program (using an external programmer of course) the TX actually light lights up which it has never done before, except for the loop back test. Unfortunately its output is garbage. Same with avrdude. Where it has gotten back absolutely no response before, it now gets a response after the first chunk of data unfortunately its not what avrdude expects. So it fails with something along the lines of invalid reply.

So yes this board is boogered up. The solderjob on the 328p is very poor, especially since I'm certain pin31 never made a connection before I touched it up. There are still problems with the board but its beyond my skills to find what that might be. I think its a weak solder joint on a timing circuit of some sort or elsewhere along the tx. And once if i did fix that, there might be more. I hope I'll be able to get them to replace it with an R3, not a big fan of this smd stuff.