[resolved] macOS 10.15 Nano 33 IoT upload fails (No device found)

[issue resolved]

After reading a few more posts I tried setting the Nano 33 IoT into boot loader mode by double pressing the reset button. This worked and now I can upload.

[original post below]


I've had all sorts of issues trying to stabilise Arduino on macOS Mojave and Catalina. This was due to outdated FTDUSB drivers which when removed cured the issues.

But I now have a problem where I can't upload sketches to a Nano 33 IoT, uploading to Nano Every and UNO R3 work without errors. All boards are official Arduino. Note: during the upload the process appears to pause / stall for a period (2-3mins) and then fails.

Any help with uploading to the Nano 33 IoT would be appreciated, error message below:

-- error massage --

Arduino: 1.8.13 (Mac OS X), Board: "Arduino NANO 33 IoT"

[lines removed]

PORTS {/dev/cu.864U-Bluetooth-Incoming, /dev/cu.Bluetooth-Incoming-Port, /dev/cu.MALS, /dev/cu.SOC, /dev/cu.usbmodem145101, /dev/tty.864U-Bluetooth-Incoming, /dev/tty.Bluetooth-Incoming-Port, /dev/tty.MALS, /dev/tty.SOC, /dev/tty.usbmodem145101, } / {/dev/cu.864U-Bluetooth-Incoming, /dev/cu.Bluetooth-Incoming-Port, /dev/cu.MALS, /dev/cu.SOC, /dev/cu.usbmodem145101, /dev/tty.864U-Bluetooth-Incoming, /dev/tty.Bluetooth-Incoming-Port, /dev/tty.MALS, /dev/tty.SOC, /dev/tty.usbmodem145101, } => {}
Uploading using selected port: /dev/cu.usbmodem145101
/Users/sumo/Library/Arduino15/packages/arduino/tools/bossac/1.7.0-arduino3/bossac -i -d --port=cu.usbmodem145101 -U true -i -e -w -v /var/folders/4j/z_6bp83j4ld54fhfh5kx789h0000gn/T/arduino_build_60063/Blink.ino.bin -R
Set binary mode
No device found on cu.usbmodem145101
Send auto-baud
An error occurred while uploading the sketch
Set binary mode

-- //error massage --