[resolved] usb conflict with nRF24L01

Hi all, I have been working with two nRF24L01 look like this

I prepared in my desk two arduino boards with one nr24L01 for each. Also I connected each arduino in differents PC (with USB cable) for debugging data transmition by serial port.
I’m using the Mirf library.
http://www.arduino.cc/playground/InterfacingWithHardware/Nrf24L01

In this moment all works ok. I can send a data between arduinos and debug the communication from pc.
It’s fantastic!!

But…
The problem begins when I disconnect one arduino from usb cable. Obviously I connect it to a batery.
The comunication fails.
I don’t know why? what’s happening?

I tested:

  • Change the battery (5 or 12v. is the same)
  • Disconnect only arduino server, in this case the client report “time out”
  • Use the original pin example
  • Extend the time out limit (to 5000 ms, original is 1000), client report “time out”
  • Remove Serial connection and debuging points

I haven’t idea about that.

Is there any tip of how I can fix it?

thanks a lot

Market

The comunication fails. I don't know why? what's happening?

Connect the battery ground to the other arduino's ground.

Grumpy_Mike, thanks for your response. I would like to send you a good news but... the testing fails again.

Let me explain about the testing.

The yellow cables are connected with the nRF24L01 components.

1) This test didn't work. I could test it connecting some leds and checking lights.

2) But... changing the battery for usb connection works good!!

I'm going crazy with this porblem =(

Is there any tip?

Market

Is it a 9V battery like you showed. These have very little power I suspect that the voltage under load is less than the 7.5V you need to drive the regulator. Have you measured the voltage under load?

Hi, thanks for your quickly response. I had a bad DC 12v. I bought a new DC 12 v. and tried again... It worked ok for some minutes... Now I'm dealing with differents problem all related to connection and synchronism

The test was successful !!

Sorry for your time, and thanks a lot for your replies.

Market