RFID MFRC522 Digital self test failed meaning

Hello everyone, I'm new at arduino and this is my second assemble with an RFID module but i cant make it work.

I have this module

And use this library https://github.com/ljos/MFRC522 but when i run the check_firmware.ino sketch i get this message:

Looking for MFRC522. Found chip MFRC522 Firmware ver. 0x92. 1 Digital self test by MFRC522 failed.

What the "failed" mean? My module is broken?

King Regards

Hello i am quite experienced with this module. I didn't use this library before, I think problem is a software bug (at least you can get firmware version). If you have any RFID tags can you please use this library and try to dump a PICC's (tag's) information (DumpInfo example).

https://github.com/miguelbalboa/rfid

Already ran it, i only get this message when i approach my plastic and card tag to the module.

Scan PICC to see UID and type...

thx for ur help omer

Ok, how do you power RFID module? Check connections again, Are you connecting other modules at the same time? Which arduino do you use? Connections change if it is mega or not mega arduino (probably you know that but still just make sure), In your sketch you must define SS and RST pins correctly ?

I power it with 3.3v connection.

I have an Arduino Uno, yes i triple check all connections. Not other modules at the same time, only the RFID. In the sketch both are defined correctly.

I think my module is broken :(

Yes maybe it can be defected, is the IC chip (marked RC522) overheating? It should be at room temp.

Yes is at room T°.

I will buy another then =(. Do you know if i can buy and rfid tag active detector for arduino?

I don't have enough knowledge about active rfid tags and its' readers. Maybe someone else suggest you. Did a google search there are plenty.

Dear all, I am new in using the MFRC522; I am having problems to get the Arduino IDE to work correctly, I have tried the file DumpInfo to test, but I am always receiving the following error. (I have confirmed that I have all the MFRC522 files in the Arduino Library, in this location C:\Program Files\Arduino\libraries\MFRC522

PLEASE CON SOMEONE HELP…??

I have downloaded the files from GitHub - miguelbalboa/rfid: Arduino RFID Library for MFRC522

The error I receive is:

This report would have more information with
“Show verbose output during compilation”
enabled in File > Preferences.
Arduino: 1.0.6 (Windows Vista), Board: “Arduino Uno”
In file included from DumpInfo.ino:37:
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:276: error: use of enum ‘PICC_Type’ without previous declaration
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:276: error: expected primary-expression before ‘{’ token
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:276: error: expected ‘;’ before ‘{’ token
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:291: error: use of enum ‘StatusCode’ without previous declaration
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:291: error: expected primary-expression before ‘{’ token
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:291: error: expected ‘;’ before ‘{’ token
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:337: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:354: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:355: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:356: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:357: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:358: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:359: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:360: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:365: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:367: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:368: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:369: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:370: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:371: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:372: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:373: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:374: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:375: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:376: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:381: error: ‘StatusCode’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:384: error: expected ‘;’ before ‘(’ token
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:385: error: ‘PICC_Type’ does not name a type
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:388: error: expected ‘;’ before ‘(’ token
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:394: error: ‘PICC_Type’ has not been declared
C:\Users\ALBERT\Documents\Arduino\libraries\MFRC522/MFRC522.h:413: error: ‘StatusCode’ does not name a type