(RISOLTO) lentezza assurda per aprire ide in win 7

riscontro un lentezza di circa 50 secondi per aprire arduino.exe nessuno sketch e 20 secondi per aprire il seria monitor

insomma una lentezza generale,

questo non si verifica con il sistema operativo appena reistallato ma man mano che inizio ad usare l’ide sembra che si affossi sempre di piu fino ad arrivare a questo punto,

ho provato a pulire il disco dai file temporanei rimettere l’ide 1.0.1 da capo
ma nulla provato anche ha cancellare tutti i registri degli eventi

qualche suggerimento ?

In genere sono i dispositivi con porte seriali (tipo chiavette bluetooth) che causano rallentamenti perché all'avvio scansiona le porte disponibili

Ciao

l''ide si appoggia sul java, che versione hai messo ?
ora c'e' la serie 7 in giro, se hai questa prova a rimettere la vecchia serie 6

Può essere per le librerie aggiunte nella directory libraries: l'IDE legge tutte le librerie alla partenza.

Ettore Massimo Albani

flz47655:
In genere sono i dispositivi con porte seriali (tipo chiavette bluetooth) che causano rallentamenti perché all'avvio scansiona le porte disponibili

Ciao

tanks, 8) mi sa che hai centrato il bersaglio sembra proprio che sia una chiavetta usb per il bluetooth

da solo non ci sarei arrivato facilmente a scoprire la cosa

Mi ha fatto lo stesso scherzo anche a me… la chiavetta cerca i dispositivi e bisogna aspettare il timeout…
Potrebbero rendere l’operazione non bloccante nella prossima versione, mano a mano che vengono trovate porte le aggiunge all’elenco in modo asincrono e… partenza immediata

Ciao

Testato:
l''ide si appoggia sul java, che versione hai messo ?
ora c'e' la serie 7 in giro, se hai questa prova a rimettere la vecchia serie 6

nah, uso java 7 sia su win che su linux e non dà problemi

lesto:
nah, uso java 7 sia su win che su linux e non dà problemi

La versione Window dell'IDE di Arduino ha la runtime di java integrata (cartella java), mi pare versione 6.x, di default utilizza quella e non l'eventuale run time installata sul pc.

ah già, me l’ero dimenticato

Mi aggiungo al coro, anche io ho questo problema, non solo all'avvio, ma anche caricando lo sketch.. il problema è sempre il bluetooth..
ma dice che è il suo timeout ? non potrebbe essere anche perchè di solito viene assegnato un numero di com alto, e per arrivare a quello testa tutte le porte intermedie possibili?

a questo punto secondo me ci sarebbe da aprire un topic BT+Win7-64
io ad esempio ho rpovato diverse chiavette bt, win7 installa i driver delle com, pero' alcuni sw non le vedono, altri le vedoo ma accedendovi si inchioda tutto, pochi riescono a gestire normalmente la com bt

capita anche a voi ?
ho rpovato tutto, chiavette widdcom con driver ufficiali, con driver microsoft, chiavette thosiba che hanno uno stack diverso, ma non e' stabile la cosa.
su win xp tutto ok

Testato:
a questo punto secondo me ci sarebbe da aprire un topic BT+Win7-64
io ad esempio ho rpovato diverse chiavette bt, win7 installa i driver delle com, pero' alcuni sw non le vedono, altri le vedoo ma accedendovi si inchioda tutto, pochi riescono a gestire normalmente la com bt

capita anche a voi ?
ho rpovato tutto, chiavette widdcom con driver ufficiali, con driver microsoft, chiavette thosiba che hanno uno stack diverso, ma non e' stabile la cosa.
su win xp tutto ok

Io non ho messo driver particolari, l'ha riconosciuto di suo..
ma siamo sicuri che il problema sia solo con win7 e la versione a 64? se è legato al bluetooth credo che sia per tutte le versioni di windows..

il problema l'ho trovato da quando ho iniziato a usare la vecchia 000018 :grin:
basta disattivare il bluetooth integrato o la chiavetta

e invece anche su xp fa la stessa cosa. chiavetta widcomm, sistema operativo 32bit, ide 1.0. se attivo il bt addio pc.
con questo caldo poi...

intendi tutto il pc, non solo l'IDE ?
a me si inchioda la relativa porta bt com

Testato:
intendi tutto il pc, non solo l'IDE ?
a me si inchioda la relativa porta bt com

beh il mio pc è un po' vecchiotto, comunque si può dire che è l'ide a bloccarsi. dopo circa 2 minuti si avvia, dopodichè se devo usare il menu ci mette molto tempo a caricare una voce, tipo devo selezionare una board e ci metto 1 minuto. se invece il bt è disattivato questi problemi non ci sono