[RISOLTO]LM35DZ e pir sensore di movimento come farli funzionare?

Ciao a tutti oggi mi sono arrivati tre prodotti che avevo comprato un dispay lcd 16x4 e LM35DZ e un pir sensore di movimento, ma lasciando stare il pir, volevo fare un piccolo progetto con il sensore di temperatura e il display, cioè volevo fare un termometro, e sul display mi indicasse la temperatura che c'è nel ambiente dove si trova. Ma io non so da dove iniziare, sopratutto non so fare i collegamenti con LCD e arduino! Ditemi tutto quello che occorre sapere. Visto che mi avete sempre aiutato nei miei piccolo progetti volevo una mano anche in questo.

googla Arduino e LM35 e trovi schemi e sketch pronti all'uso; poi però mi permetto di darti un consiglio: cerca sul PlayGround "Display LCD" o "Liquid Crystal" e poi cerca "LM35", e troverai due articoli separati, ci perderai un po' di tempo, però poi avrai imparato a fare qualcosa di tuo seppur soltanto miscelando due tutorial, altrimenti sarai sempre bloccato dal complesso "pappapronta". Da quando, con questo espediente, ho realizzato uno stand-alone con tastiera esadecimale e display LCD (20x4), ho trovato lo stimolo ad iniziare tentando di fare quel che posso da solo, e poi magari chiedo al Forum di aiutarmi a risolvere gli inghippi. :)

Ciao Michele grazie, ho collegato il sensore di temperatura ad arduino e a quando ho capito il pin centrale e quello del segnare e altro è alimentatore e altro ancora e la massa, ora una volta collegato ha funzionato poi ho scollegato tutto per cambiare pc e collegando di nuovo mi fa fumo e si riscalda molto i collegamenti sono sicuro che sono giusti sia nel primo caso che nel secondo caso ho collegato il sensore al pin dei 5v e l'arduino è alimentato da porta usb. MI sapete dire cosa può essere successo, ho perso il sensore? o arduino gli si è rotto un qualcosa? come posso vedere se arduino sta bene?

lo schema del collegamento lo ho preso da qua http://www.adrirobot.it/sensori/lm35/scheda_arduino_lm35.htm

Cosa fumava, il sensore o l'arduino? Scollega tutto e prova a caricare qualche sketch, il blink ad esempio; se lo carica prova ad usare il pin dove era collegato il sensore.

Pelletta: Cosa fumava, il sensore o l'arduino? Scollega tutto e prova a caricare qualche sketch, il blink ad esempio; se lo carica prova ad usare il pin dove era collegato il sensore.

si si scusa il sensore fumava, ma il sensore io lo ho collegato ne uscita A0, gli posso collegare un led li??

Certamente, però ricordati di mettere una resistenza sul led. Poi prova sempre il blink ma imposta il pin A0 come digitale 14, in questo modo si accenderà il led su A0 (cambia il 13 sullo sketch e metti 14). Gli ingressi analogici possono anche essere usati come pin digitali, quindi A0 diventa digitale 14 e A5 diventa digitale 19.

Alberto, la prima volta che ho usato l'LM35 ha fumato pure con me, c'ha proprio il vizio :sweat_smile: avevo invertito il V+ con l'uscita o qualcosa del genere, ti garantisco che Arduino non ha subito alcun danno, se non altro perché lo alimenti a 5V, come il sensore; e posso assicurarti che se non l'hai tenuto in quelle condizioni per più di un minuto il sensore funziona ancora, quindi abbi un po' di fiducia e riprova ma attenzione ai collegamenti, sono sicuramente sbagliati

Pelletta:
Certamente, però ricordati di mettere una resistenza sul led.
Poi prova sempre il blink ma imposta il pin A0 come digitale 14, in questo modo si accenderà il led su A0 (cambia il 13 sullo sketch e metti 14).
Gli ingressi analogici possono anche essere usati come pin digitali, quindi A0 diventa digitale 14 e A5 diventa digitale 19.

si si il led funziona, questo che vuol dire??

[quote author=Michele Menniti link=topic=131578.msg989848#msg989848 date=1352492812] Alberto, la prima volta che ho usato l'LM35 ha fumato pure con me, c'ha proprio il vizio :sweat_smile: avevo invertito il V+ con l'uscita o qualcosa del genere, ti garantisco che Arduino non ha subito alcun danno, se non altro perché lo alimenti a 5V, come il sensore; e posso assicurarti che se non l'hai tenuto in quelle condizioni per più di un minuto il sensore funziona ancora, quindi abbi un po' di fiducia e riprova ma attenzione ai collegamenti, sono sicuramente sbagliati [/quote]

non mi ha lasciato perchè lo ha fatto tanto tanto fumo e poi era molto caldo infatti ora che lo ricollegato fuma ancora di più è morto menomale che mi è costato 1.50euro

allora lo hai tenuto acceso parecchio, io ricordo che ho prima sentito il cassico odore di elettronica arrosto, poi ho tolto l'alimentazione ed il sensore bruciava proprio però effettivamente fumo non ne ricordo, comunque di sicurto hai invertito due poli tra loro, quindi fai attenzione al prossimo che prendi

[quote author=Michele Menniti link=topic=131578.msg989928#msg989928 date=1352495120] allora lo hai tenuto acceso parecchio, io ricordo che ho prima sentito il cassico odore di elettronica arrosto, poi ho tolto l'alimentazione ed il sensore bruciava proprio però effettivamente fumo non ne ricordo, comunque di sicurto hai invertito due poli tra loro, quindi fai attenzione al prossimo che prendi [/quote]

ora lascio tutto perchè ho paura di fare altri danni :cold_sweat: Michele mi spieghi come devo collegare il mio lcd cioè è come la leonado senza i headers cioè ci sono solo i buchi i non i cosi neri? E questo http://www.robotstore.it/product/436/Display-LCD-16x4-retroilluminato-BLU-driver-SPLC780D.html

intanto dimentica collegamenti con fili innestati nei fori, serviranno solo a farti impazzire; o saldi i fili direttamente nei fori, oppure saldi dei pin nei fori prevedendo poi di innestarli in una fila di header sul PCB che andrai a realizzare, oppure saldi nei fori una fila di header (uguale a quella che hai messo alla Leonardo) e poi colleghi tutto mediante cavetti jumper maschio-maschio

[quote author=Michele Menniti link=topic=131578.msg989990#msg989990 date=1352497275] intanto dimentica collegamenti con fili innestati nei fori, serviranno solo a farti impazzire; o saldi i fili direttamente nei fori, oppure saldi dei pin nei fori prevedendo poi di innestarli in una fila di header sul PCB che andrai a realizzare, oppure saldi nei fori una fila di header (uguale a quella che hai messo alla Leonardo) e poi colleghi tutto mediante cavetti jumper maschio-maschio [/quote] come si fa a saldare i header nei fori ?

allo stesso modo della Leonardo, non lo hai già fatto?

[quote author=Michele Menniti link=topic=131578.msg990030#msg990030 date=1352498966] allo stesso modo della Leonardo, non lo hai già fatto? [/quote]

non io no ho la leonardo,non ho mai saldato, lo solo citata per far capire meglio come è la mia situazione :cold_sweat:

e che cavolo ne so io che scheda hai, benedetto figliolo XD? gli header sono i connettori laterali della UNO, 2009 o ciò che hai, alla base della parte plastica ci sono dei pin metallici che devi infilare nei fori del connettore LCD e saldarli dal lato opposto con saldatore e stagno, alla fine esce esattamente una cosa come quella di Arduino, quindi ti trovia sia i pin di Arduino che quelli dell'LCD come header (femmina) e per unirli tra loro usi dei cavetti jumper maschio-maschio, con buona affidabilità di collegamento e facile scambio dei contatti per le varie eventuali prove

Ragazzi oggi mi sono svegliato :) e ho preso in mano il sensore e gli ho detto "perchè perchè" :0 poi mi stavo vestendo per andare a comprane un altro,però siccome io sono testardo :sweat_smile: ho fatto di nuovo i collegamenti e ha adesso con mia grande sorpresa FUNZIONA FUNZIONA $) Avevi ragione Michele su tutto, sia sul vizio del fumo XD sia che non era morto del tutto, che bello che bello, grazie a tutti ora dopo viene la parte più difficile però so che posso contare su delle brave persone grazie

alberto39: Ragazzi oggi mi sono svegliato :) e ho preso in mano il sensore e gli ho detto "perchè perchè" :0 poi mi stavo vestendo per andare a comprane un altro,però siccome io sono testardo :sweat_smile: ho fatto di nuovo i collegamenti e ha adesso con mia grande sorpresa FUNZIONA FUNZIONA $) Avevi ragione Michele su tutto, sia sul vizio del fumo XD sia che non era morto del tutto, che bello che bello, grazie a tutti ora dopo viene la parte più difficile però so che posso contare su delle brave persone grazie

Ah, così mi piacete XD sono contento per te!

Ciao a tutti, ieri mi sono documentato su come funziona il pir sensore di movimento quello che ho io è questo http://www.robotstore.it/product/204/PIR-Sensore-di-movimento-e-di-prossimit%C3%A0-ad-infrarossi.html allora quando io lo ho comprato pensavo che un filo serviva per dare l'allarme cioè che quando passava qualcuno davanti il pir, mandava un segnare ad arduino e il segnare poteva essere tipo acceso/spento cioè 1/0, vi chiedo il ragionamento che ho fatto è giusto?cioè funziona cosi?

L’uscita Open Collector significa che è gestita da un transistor, se alimenti il sensore a 5V la puoi mandare direttamente ad un pin digitale di Arduino, magari mettendo una 220ohm in serie per limitare la corrente, inoltre devi usare una pull-upovviamente i collegamenti li fai così:
rosso a 5V di Arduino
marrone a GND di Arduino
nero ad una R da 220ohm con l’altro capo ad un pin digitale di Arduino
nero ad una R da 10kohm con l’altro capo a 5V
in tal modo in assenza di allarme il pin legge 5V, in presenza legge 0V