[RISOLTO]LM35DZ e pir sensore di movimento come farli funzionare?

ho capito, è come pensavo io.
Michele visto che ti ami l’ordine e la chiarezza :slight_smile: , ho fatto un schema :)(scusate ma non ho trovato il pir ma ho messo un cosa simile, scusate se non è perfetto ma il programma lo solo scoperto ieri sera e ancora non sono molto bravo :cold_sweat: nel usarlo bene) dimmi se è giusto?

Allora Fritzing è qualcosa di terribile, ha una sua utilità NON come illustrazione di schema elettrico, per la cui funzione dovresti imparare ad usare Eagle, ma come illustrazione di schema pratico, a patto di essere estremamente ordinati. Personalmente non lo adoro, in genere crea più confusione che altro. Chiusa la premessa lo schema è sbagliato: il filo nero del sensore va collegato ad entrambe le resistenze da 10k e 220; poi i restanti capi delle R vanno: la prima a 5V e la seconda al pin di Arduino.

no no no pensavo di fare una cosa gradita,a ma piace una illustrazione di schema.
cosi è giusto?

Scusami Alberto, mi sono espresso malissimo, ovviamente ho apprezzato il tuo intento, visto che hai ben compreso che amo l'ordine, solo facevo la differenza tra uno schema pratico ed uno schema elettrico: il primo va bene per chi deve "copiare" dei collegamenti da realizzare, il secondo va bene per chi deve valutare la validità di uno schema; diciamo che avrei dovuto essere io a fare quel disegno e postarlo per te :grin: e non viceversa. Però hai fatto bene perché ci siamo accorti di quel piccolo problema. Il nuovo schema è perfetto; in caso di incertezza di comportamento puoi provare a levare completamente quella da 220ohm, ma se non ti crea problemi è meglio se c'è.

ok ok grazie di tutto, ti farò sapere :slight_smile: :slight_smile:

niente non riesco a far funzionare sto benedetto pir, ho scritto un piccolo programmino e ho cambiato una cosa nel collegamento al pir (e si non potevo mettere due cavi nello pin di arduino non ci entravano) ditemi dove sbaglio!? :blush:

il codice è questo

int Pin = 10; // pin dove è collegato il pir
int e=13; // pin dove è collegato il led
int dato; // dato e quello che legge nel pin 10

void setup()
{
Serial.begin(9600); // va be lo sapete cosa voldire
pinMode(Pin,INPUT); // ho impostato il pin in ricezione
pinMode(e,OUTPUT); // ho impostato il pin in uscita
}

void loop()
{
dato=digitalRead(Pin); // dice che cosa è il dato
Serial.println(dato);
if(dato==LOW) // questa è la condizione, con low si indica un valore che va da 0a2
{
digitalWrite(e, 1); // accende il led
delay(500);
digitalWrite(e,0); // spegne il led
}

}

ma la seriale cosa ti restituisce? non cambia nulla da sensore "libero" a sensore attivo? Attenzione che non ci sia qualche impostazione di ritardo di lettura, molti sensori dopo un allarme non fanno letture per diversi secondi, altri hanno bisogno di almeno due eventi per dare l'allarme, te lo sei studiato il datasheet?

da sempre 1 quando e tutto è collegato invece prima da 0. il programma giusto è??

sembra giusto; quindi il sensore non reagisce, non ha dentro un piccolo LED che mostra quando percepisce qualcosa? hai visto il datasheet che dice in proposito

Io lo ho letto ma non dice un granchè http://www.sparkfun.com/datasheets/Sensors/Proximity/SE-10.pdf

Contrariamente a quanto dice il sito che mi hai linlato all'inizio, sia il datasheet che su Futura Elettronica, che tratta lo stesso prodotto, parla chiaramente i alimentazione a 12V e non fa cenno ai 5V, per cui temo che il problema possa essere questo, Ce l'hai un alimentatore a 12V ed un tester?

Michele ho fatto un altro ricerca su google con il modello del pir cioè SE-10 e ho trovato questa discussione a qui hai preso parte pure tu. http://arduino.cc/forum/index.php/topic,78898.0.html gli ho dato una lettura, e non ho capito tante cose e poi non ho capito come finisce,e se funziona.

tu che mi sai dire??

[quote author=Michele Menniti link=topic=131578.msg991849#msg991849 date=1352650357] Ce l'hai un alimentatore a 12V ed un tester? [/quote] si ho tutte e due

Allora togli di mezzo Arduino, al posto di 5V e GND colleghi + e - dell’alimentatore a 12V ed al posto del pin 10 metti il positivo del tester su scala 20V, mentre il negativo del tester lo colleghi pure a GND, ignora il LED per ora.
Appena alimenti dovresti leggere una tensione di circa 12V, come attivi il sensore dovrebbe scendere vicino a 0V.
fammi sapere.

[quote author=Michele Menniti link=topic=131578.msg991870#msg991870 date=1352651138] Allora togli di mezzo Arduino, al posto di 5V e GND colleghi + e - dell'alimentatore a 12V ed al posto del pin 10 metti il positivo del tester su scala 20V, mentre il negativo del tester lo colleghi pure a GND, ignora il LED per ora. Appena alimenti dovresti leggere una tensione di circa 12V, come attivi il sensore dovrebbe scendere vicino a 0V. fammi sapere. [/quote] michele contro ordine il mio amico non ha a casa il tester quindi sono senza tester.

si può fare un altro modo??

al posto del tester metti una R da 1kohm su +12V, l'altro capo all'anodo del LED, il catodo del LED sul negativo: LED acceso sensore inattivo, LED spento sensore attivo, ma fammi capire, io dico a te e tu dici al tuo amico che sta a casa sua o sei con lui?

[quote author=Michele Menniti link=topic=131578.msg991897#msg991897 date=1352652480] al posto del tester metti una R da 1kohm su +12V, l'altro capo all'anodo del LED, il catodo del LED sul negativo: LED acceso sensore inattivo, LED spento sensore attivo, ma fammi capire, io dico a te e tu dici al tuo amico che sta a casa sua o sei con lui? [/quote] no io sono a casa da solo, siccome lui a il tester per vari motivi e abita vicino casa mia pensavo che me lo poteva prestare. ma tu parli con me, e basta.

no figurati, mica ero preoccupato o dispiaciuto, pensavo che tu stessi facendo da ponte radio e la cosa mi divertiva :grin: Ok, la prova col led puoi farla?

[quote author=Michele Menniti link=topic=131578.msg991919#msg991919 date=1352653142] no figurati, mica ero preoccupato o dispiaciuto, pensavo che tu stessi facendo da ponte radio e la cosa mi divertiva :grin: Ok, la prova col led puoi farla? [/quote] no =( =( =( io a casa ho solo in kit workshop di arduino e quella resistenza che dici tu non c'è. niente domani vado a comprare un tester.

mi volevo risolvere il problema sta sera, ma mi sa che non si può fare. Michele ma quella discussione ci può essere di aiuto?? e questa guida che ho trovato http://bildr.org/2011/06/pir_arduino/ ?

Lo schema che hai linkato sembra confermare che il PIR debba lavorare a 5V :fearful: Quello è identico a ciò che ti ho detto di fare, solo che non c'è la R da 220ohm che ti avevo detto di togliere eventualmente. Per scrupolo prova questo schema con il loro sketch che è molto simile al tuo. Se non va dobbiamo dare per scontato che il tuo PIR è a 12V e trovare una soluzione alternativa. Fammi sapere