Robot tagliaerba for dummies

Ciao a tutti,
intanto mi presento visto che sono nuovo su questo Forum.
Sono un programmatore di software e da qualche tempo ho rispolverato la passione/curiosità sulla robotica che avevo da piccolo.

Ho spulciato questo e altri forum da cima a fondo e ho letto migliaia di post sull'argomento "Robot Tagliaerba" notando che è un argomento che affascina molti.

Alla fine ho deciso di provare anche io a realizzarne uno, così mi sono rimboccato le maniche e mi sono messo all'opera.
Visto che le mie conoscenze elettroniche sono limitate e i ricordi dell'università annebbiati, ho deciso di iniziare con una versione semplice e dalle funzionalità limitate, ovvero:
"un robot a batteria capace di evitare gli ostacoli e che mentre gironzola tagli anche l'erba. "

In seguito magari sarebbe bello potergli fare degli upgrade per aggiungere funzionalità più evolute.

Vorrei condividere con voi questo progetto, sperando che possa essere una base di partenza per altri utenti alle prime armi (come me).

Se qualcuno ha dei suggerimenti su come migliorare o efficentare questo progetto sono molto ben accetti. Riconosco la mia ignoranza e so bene le cose si possono fare in modi migliori:

I componenti usati sono:

  • Arduino 2009 (mi sembrava la scelta più semplice per iniziare)
  • 2x L293D per pilotare i motori
  • 1 sensore SRF02 per individuare gli ostacoli.

Per i motori ho usato due avvitatori a batteria della Black&Decker da 9€, dovrebbero essere da 6 Volts e li piloto in PWM per rallentarli.
Anche il motore della lama viene dallo stesso avvitatore ma senza motoriduzione.
I dati tecnici (trovati su internet) sono:
Alimentazione: 6V
Giri: 130 RPM
Coppia: di 20 pollici/libbra (circa 2,26 N/m)

La batteria che uso adesso è una NICD da 9.6V 1500mA, ma vorrei passare ad una 12V.

Avete dei suggerimenti da darmi?

Un L293 è troppo piccolo per quei motori, come minimo devi usare dei ponti in grado di reggere almeno 5 Ampere.

Ed e’ possibile vedere una foto del montaggio della lama?

astrobeed:
Un L293 è troppo piccolo per quei motori, come minimo devi usare dei ponti in grado di reggere almeno 5 Ampere.

Scusa la mia ignoranza, ma posso chiederti da cosa lo capisci? :~

Ne ho finito di cosrtuire uno....
dopo due anni di prova sono riuscito a renderlo operativo..... ti posso assicurare che L293 è un ponte H troppo piccolo e per gestire il motore della lama sono riscito a bruciare un batteria di due mos in parallo con un I di utilizzo normale di 150A e 450 di picco facevano girare però una lama da 26Cm di diametro sagomata e piegata....
ora sono parrato ad un motore brushless da 18A ma con una lama da 20Cm di diametro sagomata e piegata....(Entrambe in Hergal=Alluminio ad alto tenore di carbonio)
le potenze in gioco sono davvero notevoli.....

Ma... un motore da 6V può assorbire ampere nell'ordine delle centinaia? :~
Come posso verificare questa cosa?
Scusate, ma nella mia infinita ignoranza sono un po' confuso.

Eventualmente quale ponte H mi consigliate?

nella prima versione usavo un motore di un avvitatore consumano circa 150-300W alcuni oltre il mio a vuoto 30W ma devi tenere conto dello sforzo.... solo con la lama e dipenda dalla lama il mio arrivava a 100W poi tagliando boh non riuscivo a misurare in movimento..... comunque il risultato è stato fumo fuoco il motore cotto e ore perse a sistemare i danni ....
la cosa più conveniente è un brushless.... all'inizio ero ostinato e non volevo provare ma sono davvero meglio... più giri meno rumore e un rendimento maggiore....
se poi prendi anche un ESC(la sua centralina dedicata) magari che ha l'auto protezione eviti di cucinare tutto :slight_smile: :wink:

denton:
Scusa la mia ignoranza, ma posso chiederti da cosa lo capisci? :~

E' una questione di potenza, un piccolo avvitatore come minimo usa un motore da 20 Watt, altrimenti non avrebbe tutta quella coppia, per ottenere 20 W a 6 Volt occorrono almeno 3A.

astrobeed:

denton:
Scusa la mia ignoranza, ma posso chiederti da cosa lo capisci? :~

E' una questione di potenza, un piccolo avvitatore come minimo usa un motore da 20 Watt, altrimenti non avrebbe tutta quella coppia, per ottenere 20 W a 6 Volt occorrono almeno 3A.

mi sento in grado di poterti correggere :wink: un avvitatore mooolto piccolo :):):slight_smile:

Ok, ammetto che mi sono un po' demoralizzato... Ma non troppo! :slight_smile:

Per adesso ho effettuato solamente un collaudo indoor con il motore della lama staccato e non mi è sembrato che il circuito scaldasse (peró ha girato solo qualche minuto)
Solo per info l'avvitatore per avere quella coppia ha una motoriduzione meccanica ed in origine era alimentato da 4 pile stilo...

Se attacco un multimetro in serie tra il piedino dell'L293 e il morsetto negativo del motore, riesco a misurare correttamente la corrente in gioco?

si solo che devi tenere conto che mettendo 4 batterie stilo queste si scaricano in 10 minuti :frowning:
per vedere cosa effettivamente consuma devi metterci una batteria tipo piombo-gel da almeno 4A
anche se è pochetta per vedere cosa consume il motore della lama :wink:

denton:
Solo per info l'avvitatore per avere quella coppia ha una motoriduzione meccanica ed in origine era alimentato da 4 pile stilo...

La coppia non viene fuori dal nulla, serve sempre la potenza a monte del riduttore per generarla.
La coppia, espressa in Nm, moltiplicata per la velocità di rotazione, espressa in rad/sec, da come risultato la potenza espressa in Watt.
2.6 N
m ( e non N/m) moltiplicati per 130 rpm, pari a 130/60 * 6.28 = 13.6 rad/sec, fanno la bellezza di 35.6 Watt meccanici, se mettiamo di mezzo il rendimento, non più del 40%, abbiamo una potenza elettrica massima di ben 57.6 Watt, a 6V occorrono ben 10A.
Dato che quasi sicuramente la velocità indicata è quella massima a vuoto possiamo rifare il conto alla velocità dove si ottiene la massima potenza meccanica, cioè circa 65 rpm (1/2 velocità a vuoto), il che ci porta ad una potenza meccanica massima disponibile pari a 17.8 Watt e una elettrica di circa 28.8Watt che a 6V sono poco meno di 5A, però se mandi in stallo il motore torniamo subito alla massima potenza di picco di 57.6 Watt e i relativi 10 A

astrobeed:

denton:
Solo per info l'avvitatore per avere quella coppia ha una motoriduzione meccanica ed in origine era alimentato da 4 pile stilo...

La coppia non viene fuori dal nulla, serve sempre la potenza a monte del riduttore per generarla.
La coppia, espressa in Nm, moltiplicata per la velocità di rotazione, espressa in rad/sec, da come risultato la potenza espressa in Watt.
2.6 N
m ( e non N/m) moltiplicati per 130 rpm, pari a 130/60 * 6.28 = 13.6 rad/sec, fanno la bellezza di 35.6 Watt meccanici, se mettiamo di mezzo il rendimento, non più del 40%, abbiamo una potenza elettrica massima di ben 57.6 Watt, a 6V occorrono ben 10A.
Dato che quasi sicuramente la velocità indicata è quella massima a vuoto possiamo rifare il conto alla velocità dove si ottiene la massima potenza meccanica, cioè circa 65 rpm (1/2 velocità a vuoto), il che ci porta ad una potenza meccanica massima disponibile pari a 17.8 Watt e una elettrica di circa 28.8Watt che a 6V sono poco meno di 5A, però se mandi in stallo il motore torniamo subito alla massima potenza di picco di 57.6 Watt e i relativi 10 A

bella spiegazione verra buona anche a me :wink:

Caspita! Spiegazione decisamente esaustiva!
Quindi direi che le strade sono 2: o cambio motori o cambio i ponti H.

Quale ponte posso usare? Con le correnti che mi dite non va bene neppure L298D, Giusto?
Mi sa che ci vuole qualcosa di piú complesso

io cambierei motori… e farei un ponte ad H con 2 relays a doppio scambio così costa poco e hai meno problemi di gestione

Scusate ma la struttura del robot, da dove viene fuori? Sarei curioso di vedere che faccia ha questo coso che si muove tra l’erba alta roteando lame :slight_smile:

Ok, mi hai convinto, cambio i motori. :slight_smile:
Che ne dici di questi?

http://www.robotstore.it/product/220/Motoriduttore-12V-33rpm-100Ncm-diam.-40mm.asp
http://www.robotstore.it/product/46/Motoriduttore-12V-36rpm-12kgf-cm.asp

Peró vorrei continuare ad usare l'L293D e magari usare il relé per il motore della lama.

Che ne pensi?

Federico:
Scusate ma la struttura del robot, da dove viene fuori? Sarei curioso di vedere che faccia ha questo coso che si muove tra l'erba alta roteando lame :slight_smile:

Hai ragione, mi avevi anche chiesto della lama. :slight_smile:
Al momento sono in giro per lavoro, lunedi appena torno a casa faccio qualche foto.
Comunque al momento si tratta piu che altro di un prototipo per cspire se la cosa è fattibile!

Si il motore va bene è lo stesso che uso sul mio :slight_smile: questo puoi usarlo con un ponte H che è pin to pin con l'L293 cioè L'SN754410NE che però sopporta correnti di 1A per canale
il motore della lama devi per forza controllarlo con un mos o cho un altro integrato in modo da regolargli la velocità senno ti mangia la batteria in un attimo ...
punto due non puoi usare il motore dell'avvitatore perchè lavorando con la lama a sbalzo gli bruci la bronzina e gli distruggi l'albero e butti il motore per quello ti dicevo di usare un beushless.... oltre ad essere molto più semplici da usare in quest'applicazione sono più robusti e hanno i cuscinetti a sfera .... io dopo averli fatti fuori ho dovuto farmi tornire i supporti per la lama e un supporto per un cuscinetto esterno al motore.... -_-"

Federico:
Scusate ma la struttura del robot, da dove viene fuori? Sarei curioso di vedere che faccia ha questo coso che si muove tra l'erba alta roteando lame :slight_smile:

An la struttura del mio è tutta d'alluminio è modulare nel senso che cè un pianale fisso e le parei ed altro che si possono togliere senza dover togliere i motori o il circuito :slight_smile: