Robotdyn M0-mini and Robotdyn W5500 ethernet

Having some problems getting these to work. Here is how I have them wiried:

3.3v to 3.3v on M0 (not feeding 5v to VIN)
3.3v to w5500

Wiz 5500 M0-Mini
RST RST
MISO MISO on ICSP header (also tried D12)
MOSI MOSI on ICSP header (also tried D11)
CLK SCK on ICSP header (also tried D13)
CSN Tried both D9 and D10

Using the eithernet2 library loaded in from the library manager. When I tried the Webserver example i get "server is at 255.255.255.255" despite that not being the IP I set, when I try the DHCP server example "Failed to configure Ethernet using DHCP".

One thing of note is that I have to change all the Serial commands to SerialUSB. As far I can tell this means I have the .org bootloader and not the .cc bootloader and as such I should (and do) use the plain M0 option in the boards menu.

carry on, i feel kind of dumb now after playing with this for a few hours. i was using the wrong pinout diagram for the icsp header.

so if anyone else tries ths, the MISO, MOSI, and CLK go to the icsp header and CSN go to D10