Rookie Question

We uploaded the prizm library, works great for me on my district account, however every student after uploading and including the prizm library gets an error when validating on the prizm.h

Trying to get a classroom full of middle school kids going and all of them get a fatal error: PRIZM.h: No such file or directory. When I look at their Library on Custom, the Textrix_Prizm zip file has been uploaded. They are all on ChromeOS. I am baffled I'm also on ChromeOS and it is working fine for me.

Works fine on my account.

Kids downloaded the zip file from

They upload the library into the site.

They include the library and then when trying to verify they receive a error that PRIZM.h cannot be found.

@Paul-Beadles, do not hijack. Post removed.

Threads merged.


Your question was moved to the section SPECIFIC to the CHROME version of the editor. The team will be in soon and as it is an EDU topic I am sure they will look at it as an important issue.

As suggested by Pert please do read a little more as it is always crucial to get as much information as possible about things that may be a bug (or not).

As it only happens on the kids chrome tablets and not yours, BTW I am not too familiar with Chromebooks but do you have any forms of security or policy in place for them and not you ?

Hi @Paul-Beadles,

I just tried this and had no issues, see screenshot and lib used in the attachments.

Could you please try to remove the custom library and re-upload it? (49.7 KB)

I did try having them delete the library and add it back, had some try downloading it again and doing the same thing no luck. It's like it does not recognize the library as being present.

I'm also on ChromeOS so I don't think it's a issue with the operating system. I also thought it was some district restriction so I made a student the same access as me (Only took them about 10 seconds to realize they could now play hearthstone after I did that) but no luck.

Created a new account using my personal email outside of our educational classroom and also received the same error where the library shows as uploaded but when verifying tells me prizm.h library is not found.

Just to confirm you have an include for PRIZM.h (the case matters)?

Did you retry with the same zip file I attached to my previous reply?

If you continue to have this issue, please contact with the Arduino ID you are logging into Create with.

Yes, Yes. I did reach out to support but no luck yet. I also noticed that they can’t use any of the default libraries. Same error about every thing they try to include like #include <UnoWiFiDev.Ed.h> will tell them no such library or directory

Any update on this? I'm having a similar problem; I imported a library from Github, it shows up in my custom library list, allows me to #include it, but when compiling I get "no such file or directory".

The only advice I have gotten back is to remove and add the library again, but that has not been working for my students so far.

Thanks. Like your students, I'm a new user (of the Chrome/web IDE) and this was the very first thing I tried, was surprised to find it didn't work. I'll go back to using the regular IDE.

There are quite a few reports of this issue with the Arduino Web Editor. Here are the ones I found after a quick glance:

So this is not really a Chrome App-specific issue but rather an Arduino Web Editor issue. The Arduino developers are looking into this. The latest word from them is that it only occurs for new users, which matches your experience of the problem not occurring for your account, but only for the students.

Thanks for putting all that together! Makes me feel less crazy!