RP2040 Nano Connect crashes on blink.ino.elf.uf2

Randy,
I'm having kinda the same issue with my RP2040 Connect, but I can use the IDE to upload from my laptop, but my desktop has issues.
One thing I have noticed is that when uploading from the laptop, the volume or drive will mount for a second and then disconnect again. On my desktop, the volume or drive will not disconnect so the upload will fail.

Maybe test on a different computer if you can or with Linux?

Tomas

Hi Tomas, I have already tried using Ubuntu under a Linux VM but I'll see if I can try either on a Raspberry Pi I have or find a different computer I can try it on. Let me know if you find any clues as to what the problem might be.

Thanks,

Randy

@blakebr Take a look at Nano RP2040 Connect not being detected on USB port – Arduino Help Center . If your board is an official Arduino, doing any step outside of what Arduino recommended will compromise your board.

@RandySpurlock

Hi Randy,

I had the same problem with two RP2040 Connect boards, both having the AT25SF128A flash IC. I managed to get them working again by doing the following:

  1. Short REC to GND, connect the board, remove the short (the well-known procedure).
  2. Once the board is detected as a flash drive, copy the flash_nuke.uf2 file.
  3. After the board resets and it is detected again as a flash drive, use Arduino IDE 1.8.16 or 2.0 beta to upload the Blink example. The important detail: in my case, the board started working again only if the Arduino Mbed OS Nano Boards v2.1.0 core was used. I also tried v2.3.1 and v2.4.1 but without success. Now, the serial port is detected by the OS and the board can be programmed as usual.
  4. After the orange led started to blink, I have updated the Arduino Mbed OS Nano core to v2.5.2 and flashed the Blink example again. Everything worked perfectly and the board is still functioning.

I tried the steps above for both Arduino IDE 1.8.16 and 2.0 beta and on both Windows 10 and Linux (Manjaro) operating systems.

I hope this procedure helps you and everybody else facing the same issue!

2 Likes

Thanks Alex, we're currently moving so most of my stuff is packed away but I'll definitely give this a trip when I get things unpacked again!

Thanks,

Randy

Thank you so much for sharing this; I can confirm that v2.1.0 does it.