Ruido electrico usando chispero Y arduino

Hola, estoy armando un proyecto para automatizar una vieja secadora de ropa.
la cuestion es que utilizo un chispero de calefon de 1.5v a 180mha. este lo único que hace es generar una chispa de unos 5mm entre 2 electrodos. resulta que utilizo una pila para alimentar este dispositivo y con un relay conecto 2 pines que se encargan de prender y apagar dicho chispero (estos pines ya estan diseñados para encender y apagar el mismo).
mientras que el chisperoi esta encendido arduino se vuelve loco y comienza a prender y apagar las luces de tx y rx, deja encendido el relay, etc.
tambien probe de reemplazar la pina por una fuente de 2v ac, dc y me genera tanto ruido en la red que mi pc comienza a desconectar y conectar perifericos, deja de andar el mouse, etc.
El codigo es super basico, a travez de millis prende 4 segundos el relay y lo apaga por 2 segundo.
Alguien me puede ayudar?
gracias de ante mano....

Su publicacion se MUEVE a su ubicacion actual ya que es mas adecuada.

¿Que modulo de Rele estas usando? Un error muy común es dejar el puente entre JV-VCC y VCC. Con el puente se activa la bobina con la tensión del Arduino. Sin el puente hay que alimentar el relè externamente, pero disminuye el ruido que entra al Arduino.
Saludos

uso un relay comun de 1 solo canal, no tiene ningun jumper y tiene solo 3 pines, gnd,vcc y data.
pensaba en comprar un relay de estado solido pero recien vi que solo vienen para AC pero esto se alimenta de una pila...

Eso significa que estas activando la bobina con la tensión del Arduino o tienes gnd común con la fuente que alimenta la bobina. No es el mejor de los escenarios. Deberías aislar completamente los circuitos con un optoaclopador o comprar un rele que ya lo posea (los circuitos aislados).
Saludos

Tu problema es que el chispero genera una gran cantidad de EMI Interferencia Electromagnética y las pistas del Arduino se convierten en antes e inducen corrientes y por eso se vuelve loco.
Tienes que armar una jaula de Faraday, traducido, poner el arduino con cuidado en una caja metálica. Envuelvelo en plastico y coloca papel de alumunio para probar, si no hace cosas raras es porque tengo razón.
Mira como son las cajas de las fuentes de switching, son metálicas con agujeros bueno necesitas algo asi con pequeños agujeros o mallada. Pero primero la prueba.

no hice exactamente lo que me dijiste pero si algo similar, conecte la bobina con su respectiva pila y la active, manualmente. A la parte del electrodo (donde salta la chispa) la puse dentro de una pequeña caja de papel aluminio y listo, (a todo esto, con solo tener el arduino cerca del circuito ya se prendían las luces de RX y TX) me dejo de pasar interferencia pero de todas formas, al conectar el relay, vuelve a pasar la interferencia. supongo que pasa del relay al arduino.... no me parece un sistema eficiente. ahora voy a probar algo muy diferente y es en vez de usar un chispero, usar un calentador de auto o hacer alguna resistencia incandecente con nicromio. si en estos días no logro conseguir resultados vuelvo a molestar a ver si se les ocurre algo nuevo.
Ahora se viene un nuevo problema, como adapto el calentador incandecente de auto, de 12V, 8A DC a 110V AC o a 220V AC. veremos que sale, si es suficiente para encender el gas, etc.... gracias por todo. Adjunto imagen de los calentadores que voy a intentar adaptar.
image

El sistema original utilizaba este tipo de resistencias pero en argentina son extremadamente caras y la idea es adaptar algo mas "moderno" o almenos mas accesible. lo bueno de esto es que no genera ningun tipo de interferencias o almenos eso creo...
image

Porque con el relay te volvió a ocurrir? El relay dijiste que ponía en marcha el chispero, a través de una pila de 1.5V.
Me hubiera gustado que protegieras el Arduino + relay. Si podéshacé la prueba.