Running Arduino (serial v2.0a) on Windows 7 x64

Hello there,

I finally got an Arduino serial v2.0a and I'm trying to make it work with my Windows 7 x64. I have read some posts in the forum that say that I should go to http://www.ftdichip.com/Drivers/VCP.htm and get the drivers...but I can't see any download link (for any OS). Should I download anything else in order to make it work?

Thanks a lot to everyone in advance! Greetings.

The FTDI drivers are only for the USB versions of the arduino. For the serial version it is connected into one of your serial ports and requires no drivers.

On the arduino IDE at the top is where you select what serial port you are using. If you don’t know which one it is then just select one and if it don’t work then try a different one.

Mowcius

Well, this Arduino I have, has a converter from serial to USB, and it’s connected to my USB port. The problem is that in Arduino IDE I cannot choose a serial port because it doesn’t recognize the drivers, and that’s why I need to download the USB drivers…

Oh ok, If you go into the arduino (17 - if not then download 17) IDE folders then you will find that there is a 'drivers' folder. When you plug in your arduino and it asks for the drivers just navigate to that folder.

If it does not ask for the drivers then go into computer management in control panel, click on device manager, find the device with an exclamation mark and right click - update drivers. Mowcius

If you can't find the drivers in the arduino IDE files then:

On the drivers page: http://www.ftdichip.com/Drivers/VCP.htm The drivers are located on the links of driver version. The one you will want is: http://www.ftdichip.com/Drivers/CDM/CDM%202.04.16%20WHQL%20Certified.zip

Mowcius

Not working yet; I downloaded it and tried to update the driver, but it says that Windows has a more recent version. I also tried to uninstall the Windows driver, but still the same issue..

Damn windows. I presume that it is just windows 7 issues...

So is the device is coming up in device manager as a virtual serial port? If so, have you tried changing the serial port of the device to see if it comes up in the arduino IDE?

Does it come up as an unknown device or whatever in device manager? Does it come up as a virtual serial port in device manager?

Mowcius

what converter are you using for the usb to serial i have got my serial arduino to work with Aten serial convertor but not with a prolific one