RX led always lighted

I got a yun since 1 month, dealing with stability issues.
Now it has become worst, and I start to think there's something wrong with my board.
2 points :

  • the Arduino Yun wifi SSID, the one I have to connect to configure, has never stopped to appear and disappear during the first 3 weeks, making ethernet the only stable solution to configure. Then, arduino access trough wifi as a client was very unstable (connecting and disconnecting in loop)
  • For one week now, I never success to connect wifi or make the default arduino SSID appear, although I tried all the reset porcedures I could. Also, no matter what I do, RX led is constantly lighted, from the moment I connect micro usb. I can upload sketches trough usb (blink sketch make blink the L13) but ethernet as wifi are not working anymore.
    I didn't succeed to find such a case in the yun topics.
    Don't you think there's something wrong with hardware ?

If there is something wrong on the linino side, many informations can be gathered via YunSerialTerminal (or SSH access)
Please, upload the YunSerialTerminal example via USB then open the serial monitor then reset the ar9331 (pressing the white button near the leds)
Serial monitor will start printing a lot of text. Leave it printing for a couple of minutes than please copy the WHOLE content of the serial monitor and attach it to the forum

Once we are sure the linino side is working fine, we can work on the 32u4 side and check what's going on there.

I've tried it but nothing happens. I've uploaded the YunSerialTerminal example. Success message and the led13 stopped blinking (blink was the previous sketch I uploaded).
Then I opened the serial monitor.
Then I tried to press on YUN RST button, but nothing new happens :

  • RX LED stay lighted forever
  • nothing is writing on the serial monitor
    Same result if I unplug and re-plug the micro usb ...

Does it look like the USB led is lit?

no, only RX is lit, yellow, non stop.