Sagem Hilo GSM module network locked? (+CPIN: PH-NET PIN)

Hi,

my new Sagem Hilo GSM/GRPS module does not register with the my network service provider.

I have bought this module from Libellium a few month ago, and had a different Sagem Hilo GSM/GRPS module (bought from a provider in Germany) running ok last year.

Network registration status:
at+creg?
+CREG: 0,0
OK

The Sagem Hilo documentation says: "0: not registered, ME is not currently searching a new operator to register to"

The PIN status shows:
at+cpin?
+CPIN: PH-NET PIN
OK

The Sagem Hilo documentation says: "PH-NET PIN - ME is waiting personalization password to be given"

I looks like the module is rejected by the network service provider ("o2 - de").
The used SIM card is working fine with my Android phone.

Any ideas??

Some more module status {

State related to SIM and its access:
at+ksrep?
+KSREP: 0,0
OK

Network operator:
at+cops=?
+COPS: (1,"Vodafone.de","","26202"),(1,"o2 - de","","26207"),,(0,1,4),(0,2)
OK

Lock status:
at+clck=?
+CLCK: ("AO","OI","OX","AI","IR","AB","AG","AC","FD","SC","PN","PU","PP")
OK
}

Thank you!
Andre

Hi,
with the command AT+CREG you ask to module the registration status.
With the command AT+CSQ you find the quality signal.
Try also this command.
The antenna is ok?
Remove the pin using a normal phone, to be sure.

Hi, thank you for your reply!

The SIM pin is removed already.

The Network signal strength:
at+csq
+CSQ: 27,99
OK

To me this looks ok...

The Network registration status:
at+creg?
+CREG: 0,0
OK

but I don't like this status.

try putting a large capacitor across the power supply terminals to the GSM module. If you're getting power supply fluctuations you'll definitely have problems registering to the network.

The CSQ answer is ok, but I don't understand the CREG response...
What antenna do you use?
In a my application I used an antenna near the module and SIM, and the field reset the SIM card... Try an antenna with a cable.