SainSmart UNO R3

Hey guys,

Okay so i been having problems every since my first run. As i started the 'Getting Started' guide half way through where the step requires for you to update via device manager, i noticed something quite unusual.... even though i selected the drivers folder, it kept telling me that it's already up-to-date, and other times my USB installed the drivers itself. Once i had a stable connection i started working on a 4 LED program(default blink program but with 4 LEDs instead of one) but after uploading and testing many times the connection issues just kept on getting worse. It stopped showing up on the device manager eventually and even when i plugged in the USB, it didn't detect it. So i thought to myself "Hm, lets try restarting the PC." So i went on with it and after restarting, i plugged the USB back in and BAM! The connection was working again....until i got d/ced again after 10 minutes and NOW that same thing continues. I have to restart everytime i would like for it to connect to my PC. Tried it with 2 different USB cables and 4 different USB ports on my laptop, still no luck.

OS: Windows 7 Home Premium 64-bit

On-board situation: On LED is solid green and L is blinking red.