Salvaged motor not moving without help

I recently salvaged a 3.6V motor from a cordless drill that had a dead battery that wouldn't hold a charge. I have an identical drill with a battery that does hold a charge.

I've been trying to use the salvaged motor but have been having issues. When I hook it up to my power supply @ 3.6V it does nothing but use power. If I give the shaft a quick turn, then it begins to spin quickly. Since I salvaged it a while ago before tossing out the rest of the drill I can't study the inside. I did open the identical drill I have and didn't find anything particularly interesting before putting it back together and there's no special gearing inside.

I tried increasing the voltage a little but it still doesn't spin without giving it a little help to start.

What could cause this? I know my other drill doesn't get any help-- it actually has force applied against it as it starts sometimes.

Sounds like your power supply can not provide enough current. Measure the voltage output of it with the motor attached.

Or one of its commutator segments is defective.

Its a high power motor, it doesn't get out of bed for less than 5 amps!

Seriously it will need several amps to overcome friction, then probably dozens more to do
its job if its a 3.6V cordless drill - do you have the specs for the drill or battery or motor?