SALVE A TUTTI!!! Nuovo appassionato sulla via della pazzia xD

Salve a tutti mi presento sono Sergio e sn un noob in questo fantastico mondo dell’Arduino… Quindi umilmente esporrò qui i miei dubbi su un progetto ke sto portando avanti nella speranza ke qualcuno della community mi possa aiutare illuminandomi :slight_smile: Volevo inviare una temperatura letta da un sensore ad un server remoto che avrà il compito tramite uno script php di ricevere qst dati (modalità GET) e inserirli poi un Database… Ho già abbastanza esperienza di Php e MySQL … ma sono nuovo di elettronica e di Arduino in particolare… espongo il problema…
utilizzo lo sketch di esempio WebServer e voglio mandare al server una richiesta del tipo

   client.print("<a href=http://192.168.0.60/script.php?temp=");
            client.print(temperature);
            client.print(">Invia dati a DB </a>");
            client.println();

Cioè ke il browser mostra è un link http://192.168.0.60/script.php?temp= e poi nulla!!! in modalità GET dovrebbe portarmi il valore rilevato (es. ?temp=23.2) … Perchè la variabile non viene inclusa nella stringa del codice? e come devo fare? Grazie in anticipo dell’attenzione e mi scuso per la mia ignoranza sull’argomento :sweat_smile:

Scusa se te lo dico ma potresti, cortesemente, evitare abbreviazioni tipiche degli sms tipo ke? Grazie e scusa ancora ma quando le leggo in una frase mi interrompe il flusso del discorso.

Riguardo il tuo problema quasi sicuramente la variabile non contiene alcun valore. Potresti provare a stamparla da sola sul serial monitor per controllare.

Tutto risolto era questo il problema!! Grazie della dritta :wink:

Lieto di esserti stato d'aiuto. In elettronica sarò anche una pi... ma come programmatore qualche macello me lo sono smazzato :)