SAM ICE <--> Arduino Due

Hi there

I got my SAM ICE today and I tried to play a little with it but I have a problem which is that when I click on “change device” I cant finde any arm core famili. Did anyone had the same problem ?

You have to create/open an Arduino DUE project. Here an example:

File->New->Example Project. -Click on Kit. -Click on latest ASF version like (3.9.1) . -Click on Arduino Due/X. -Select the Getting-Started Application on SAM - Arduino Due/X example. -Accept the CMSIS license agreement. -After the project is loaded you will see ATSAM3X8E device in the tool bar. You will see also 'No Tool' in the right. -Click it and then select your debugger. It should shows up you SAM-ICE (serial number I guess) if it is connected to your computer. -Select JTAG. -Press F5. Once your project is loaded to your DUE, you will see the led L (13) blinking. The sample puts another led to blink (Pin 9 I guess)

And that's it. If everything goes OK, you should have loaded a project to DUE using SAM-ICE. Regards!

P

Thanks for your reply ...This is exactly my problem I cant choose my debugger... my windows see it and it is installed .. see attachment

Did you download and installed the J-Link USB drivers from Segger? Here the link just in case: http://www.segger.com/jlink-software.html

The J-Link ARM VX.XX application should recognize your SAM-ICE. SAM-BA also should recognize the DUE core.

EDIT: Which version is your SAM-ICE? There is a fix reset for V5.1 . See section 8.1 (http://www.atmel.com/Images/doc6206.pdf)

Hi thanks for your reply

I have SAM-ICE Hardware V6.

I didnt install the segger software cause my windows recognized the debugger immediatly I can see it under device manger..

I will try to install it tomorrow and will tell you if it worked or not

Thanks alot for your help

Hi I figured out the problem... it just doesent work with windows 8..I tried it with windows 7 and it worked

Here the AtmelUSB V11.9 drivers (including Segger). They support Windows 8.1 64bit. https://gallery.atmel.com/Products/Details/004ccabd-e18e-431a-8557-83deaea23341

HI
As a new user I installed Atmel Studio Atmel SAM_ICE and an(Olimex) ARM ICE 20 to10 cable adapter . The Arduino PCB does not allow the JTAG header to seat properly and I had no luck until I paired down the header to allow it to seat properly. Apart from that the system worked OK with suitable prompts where for instance the JTAG not selected, by me.