Sam3x8e upload but not working

Hi everyone,

I am design my pcb board for my job. I use Arduino Due devolop my code and ıt worked.After we design new pcb board and I used only Sam3x8e and default component(Crystal,cap,res…). I upload code to Sam3x8e using atmega16u2. After Arduino all pins show 3,3V(high) and not run program.
Anyone know what is the problem

Thanks

atmelsamba:
Anyone know what is the problem

Your personal pcb.

Yes ıts my personal pcb

atmelsamba:
Yes ıts my personal pcb

And there is your answer.

(deleted)

spycatcher2k:
Here is a hint :

POST YOUR SCHEMATIC AND LAYOUT - we are not frikin mind readers.

And is it really our "job" to help him debug a custom pcb ? ? ?
According to him the Arduino Due he has works just fine.

Arduino due works fine.After I draw new pcb and use sam3x8e and its default component,upload program.But it not working and always all pins high

ieee488:
And is it really our "job" to help him debug a custom pcb ? ? ?

help him a commercial venture

aarg:
help him a commercial venture

a commercial venture, you say

I am out!

ieee488:
a commercial venture, you say

I am out!

I am design my pcb board for my job.

I am sure about pcb , i want to say that Maybe Anyone know what is problem about sam3x8e.Maybe bootloader, maybe any pins

Thanks

(deleted)

I dont understand what is happen.I am try to answer your question.I am sorry

atmelsamba:
I dont understand what is happen.I am try to answer your question.I am sorry

Other than vague speculations about what might be wrong, you haven't provided any information about your project.

Look closely at reply #4.


its schmatic

And you've buzzed out the board and are happy its the same as the schematic? That alone is a lot of work,
but sometimes necessary commissioning a new PCB.

You did a close visual inspection?

You double checked absolutely every part of the schematic against a the Due design? It only takes
one tiny mistake to break things...

This is stuff only you can do I think, you have the actual board.

The bootloader is hard-programmed into the SAM chip, that shouldn't be an issue.

Hi Markt,
I did close visual inspection but it still not working

Hi,
Ops circuit;
0BrL6D.jpg

Should the gate to the erase MOSFET be open circuit?
Tom… :slight_smile:

Hi TomGeorge,
it should be like this?

Hi,
Your erase MOSFET
erasefet.jpg

DUO Erase MOSFET

Can you tell us your electronics, programming, Arduino, hardware experience?

It is a basic step to not leave a MOSFET gate open circuit.

Tom... :slight_smile:

erasefet.jpg