Schrittmotor Problem gegen den Uhrzeigersinn

Hallo,
Habe ein merkwürdiges Problem bei der Schrittmotorprogrammierung.
Steuere einen Nema 17 Motor mit einem TMC2209.
Im Uhrzeigersinn gibt es keine Probleme. Ich kann beliebig schnell bzw. langsam steuern. Gegen den Uhrzeigersinn funktioniert.es nur bei einem Delay zwischen den Schritten zw. 300 und 600 Mikrosekunden. Bei anderen Werten summt der Motor nur. Bei einem NEMA 14 das gleiche Problem.
Woran kann das liegen?
Gruß

Du wirst halt irgendetwas falsch machen... Leider haben wir keine hellseherischen Fähigkeiten. Wir kennen deinen Motor nicht ( NEMA17 definiert nur die Größe des Befestigungsflansches, sonst nichts ), wir kennen deine Schaltung nicht und wir kennen dein Programm nicht.
Etwas mehr Info wäre also sehr hilfreich um helfen zu können :wink:

Hast Du etwa in der Programmierung beim CCV DIR und STEP verwechselt?

Hatte die 5V am TMC vergessen! :see_no_evil:

Hast Recht, Daran habe ich nicht gedacht. Darum konnte Ich Dir nicht helfen.
Grüße Uwe

Kurz Nachgedacht.
Komisch daß der Treiber in einer Richtung überhaupt ohne Probleme funktioniert hat.
Grüße Uwe

Ja, das fand ich auch seltsam, dass er ohne die 5Volt wenigstens in eine Richtung funktioniert hat. :astonished: Aber vielleicht war das ein Aufbau am Breadboard und es ware noch irgendwas nicht richtig angesteckt. Ich hatte es schon mal, und ich glaube das war bei dem Treiber, dass nur eine Motorwiklung Spannung bekam. Und da ging er auch nur in eine Richtung. Wunderte mich nur, dass er überhaupt in eine Richtung gelaufen ist :roll_eyes: