schwingende Spannung am Power Supply bei Anschluss von LEDs

Hallo,

Ich habe folgendes Problem: Ich will mit einem Arduino Nano einen LED-Streifen steuern (60 RGBW-LEDs, 5V) Die Stromversorgung sollte über ein 12V Netzteil und einem normalen Breadbord 5V Power Supply (MB102) laufen Alle Teile sind getestet, funktionieren und das Programm läuft schon sehr gut, wenn der Arduino direkt dem Streifen Energie gibt (wird natürlich schnell sehr heiß, weshalb ich beide Geräte über den externen Power Supply laufen lassen wollte. Der Arduino soll mit 12V (Vin), Gnd am Trafo und DL (des Streifens) verbunden werden, der Streifen wird mit 5V angeschlossen.

Wenn ich jetzt allerdings die Geräte über den Power Supply laufen lasse, flackern die LEDs sehr stark. Wenn ich nur wenige LEDs anschließe, tritt dieser Effekt nicht auf. Ist der Power Supply überlastet? Eigentlich sollte er nicht überlastet sein von 1m LED-Streifen. Auch bei anderen Verschaltungen flackern die LEDs und der Power Supply wird sehr heiß.

Absurderweise funktioniert alles korrekt, wenn ich den 5V Port vom Arduino mit dem 5V Port des Power Supplys und dem 5V Eingang des LED Streifens verschalte. Kann mir jemand sagen, warum das so ist und wie man das fixen kann? Für Hilfe bin ich sehr dankbar.

Viele Grüße.

Auf jedenfall hat du das Board mehr als nur knapp überlastet

Hätte ich auch gesagt. allerdings blicke ich bei deiner Beschreibung nicht ganz durch. Stell mal links zu den verwendeten Teilen wie Power Supply, Netzteil, externen Power Supply und ggf. ein Anschlussplan rein

Der Begriff “Verschaltung” ist hier wohl ausschlaggebend.
Zeige uns ein Schaltbild, wie du alles verschaltet hast und wir sagen dir, wie du es richtig beschalten musst.

Edit:
Wie hast du denn die schwingende Spannung gemessen ?

Hallo,

Im Anhang ist jetzt der Schaltplan
Hier ist ein Link zu einem Bild vom Power Supply: http://artofcircuits.com/wp-content/uploads/2014/04/MB102-3V3-5V-3.jpg
Als LED-Streifen habe ich einen mit WS2811 Controllern benutzt, 60 Stück, 1m, 5V (mit nur einem Datenpin, ist im Bild etwas anders dargestellt)
Und einen normalen Arduino Nano.
Vielen Dank für eure Hilfe.

Viele Grüße

Das Teil ist kein Power supply, sondern ein Spannungsregler. Der schafft niemals die 3A die deine Leds benötigen.

Und nochmals, wie hast du deine schwingende Spannung gemessen ?

okay, das habe ich mir schon fast gedacht. Aber wie kann ich genügend 5V Strom für die Leds bereitstellen?

Naja die Leds flackern eben ziemlich stark, wenn alle leuchten

Hi

Wie HotSystems schon schrieb, muß der Strom für den LED-Streifen auch hier durch einen Spannungsregler, Der die 3,6A sogar (60 LEDs mit je 3x 20mA Maximalstrom) erst Mal liefern können muß.
Meiner Meinung nach hattest Du bis hier hin unglaubliches Glück, daß Dir Nichts um die Ohren geflogen ist oder zumindest Rauchschwaden über der Elektronik auftauchten.

Wie sehen Deine 12V aus?
Wie ‘fett’ ist dieses Netzgerät?
Vll. hilft Dir ein Elko auf der 5V-Seite, um kurzzeitigen Stromhunger zu stillen (die Welligkeit zu reduzieren) - aber der benötigte Strom (bis zu 3,6A bei 5V) wollen irgendwo her kommen.

Wenn auf der Steckbrett-Versorgung auch nur ein Linear-Regler vorhanden ist, muß Dieser mehr Leistung verheizen, als Dein Stripe überhaupt braucht (12V rein, 5V raus, bleiben 7V zum Verheizen - Mal den Strom von 3,6A wären Das 25,2W im worst case!!)
Hier MUSS ein Schaltregler sich um die 5V kümmern, Das bekommst Du linear nicht gekühlt.

MfG

PS: Denke, das Flackern kommt vom Netzteil, Das der Sache nicht gewachsen ist.

Istalger: okay, das habe ich mir schon fast gedacht. Aber wie kann ich genügend 5V Strom für die Leds bereitstellen?

Naja die Leds flackern eben ziemlich stark, wenn alle leuchten

Weil der Strom nicht reicht. Und wenn du wie üblich, mal die Spannung messen würdest, stellst du fest, die bricht zusammen.

Wie du es aufbauen musst, wurde dir schon geschrieben. Also ändere das und es flackert nichts mehr.

Ach und rechnen solltest du auch, denn 60 Leds ziehen Strom, den du leicht selbst errechnen kannst.

okay Danke, habe ich das jetzt richtig verstanden?: Mein Netzteil schafft 12V, 2A, daran könnte ich einen Abwärtsregler anschließen, der genügend Leistung hat. Oder ich suche ein 5V Netzteil, das 3,6 A schafft?

Istalger: okay Danke, habe ich das jetzt richtig verstanden?: Mein Netzteil schafft 12V, 2A, daran könnte ich einen Abwärtsregler anschließen, der genügend Leistung hat. Oder ich suche ein 5V Netzteil, das 3,6 A schafft?

Mit 2 A kommst du nicht aus. Ein 5 Volt 5 A Netzteil ist da angesagt, du musst auch ein wenig Reserve haben.

Aber der Abwärtswandler müsste aus 12V 2A doch theorethisch 5V 4,8A machen?

Hi

Mit einem Linear-Regler sind nur 2A möglich, auch auf 5V-Seite, da diese Reglerart 'nur' Alles verheizt, was zu viel ist. Dabei bleibt der Strom auf beiden Seiten gleich. Bei einem Schaltregler hast Du nahezu gleiche Leistung auf beiden Seiten (klar, ein Teil geht hier auch verloren). Somit hast Du am Eingang 12V x 2A = 24W, was auf der 5V-Seite knapp unter 5A ergeben wird (bei 25W wären wir genau auf 5A, ohne Verluste).

Das heißt für Dich, daß Du einen Schaltregler brauchst, Der mindestens 6A sekundär liefern können muß (damit Du etwas Luft hast und den Regler nicht auf 100% belastest), wie auch, daß Du NICHT alle LEDs gleichzeitig auf lange Zeit laufen lassen kannst, da der nötige Strom nicht verfügbar ist. Mit einem Puffer-Kondensator auf der 5V-Seite kannst Du aber auch den kompletten Stripe in 255,255,255 für kurze Zeit leuchten lassen - ab wann 'zu lang' ist siehst Du, wenn der Stripe nicht mehr Das macht, was Du vorgegeben hast.

Solche Spannungswandler sind nicht mehr sonderlich klein, schlage Dir deshalb eine separate 5V-Quelle mit genügend 'Dampf' vor. Bei mehreren Netzteilen: GND miteinander verbinden (Sternförmig und nur 1x, entsprechend dick ist von Vorteil)

MfG

PS: Jupp, Du bist zu schnell :) Die 4,8A sind aber nur der theoretisch mögliche Wert. Ein Elko auf der 12V-Seite kann Dir hier auch etwas helfen, aber wie auch bei der 5V-Seite, der Strom muß irgendwo her kommen.

Istalger: Aber der Abwärtswandler müsste aus 12V 2A doch theorethisch 5V 4,8A machen?

Ja, Aber Du brauchst einen Abwärtswandler und keinen 5V Spannungsstabilisator wie auf dem Arduino oder auf dem MB102

Grüße Uwe